Lost My Graphical Boot Sequence. How Do I Get It Back?

When my desktop starts now, I only have a text boot sequence. My LUKS password prompt isn’t even graphical and I don’t even know it’s time for it, I just start typing and then I see the * and the path that I’m decrypting. When that is complete, I do get a graphical login screen though.

I’ve reinstalled grub but not sure what else to do since my login is graphical.

Can you run plymouth-set-default-theme and plymouth-set-default-theme -l and share their outputs?

1 Like

$ plymouth-set-default-theme
hot-dog
$ plymouth-set-default-theme -l
bgrt
breeze
breeze-text
charge
details
fade-in
hot-dog
script
solar
spinfinity
spinner
text
tribar

You can set your plymouth theme with sudo plymouth-set-default-theme -R theme-name. Change theme-name to one of the available ones (output of 2. command above). Yours is set to hot-dog, I don’t know why you are getting a wall of text instead of a hot dog theme. Maybe try some other themes (other than details, it is the wall of text theme).

1 Like

I changed it to solar and rebooted but still the same result.

So I have changed my theme to bgrt (which is provided by plymouth-theme-spinner package) and I got a OEM logo and spinning circle below it. Here is the list of installed packages on my system, can you compare with yours:

$ sudo dnf list installed "*plymouth*"
Installed Packages
plymouth.x86_64                 0.9.5-2.20210331git1ea1020.fc34 @fedora         
plymouth-core-libs.x86_64       0.9.5-2.20210331git1ea1020.fc34 @fedora         
plymouth-graphics-libs.x86_64   0.9.5-2.20210331git1ea1020.fc34 @fedora         
plymouth-plugin-label.x86_64    0.9.5-2.20210331git1ea1020.fc34 @updates-testing
plymouth-plugin-two-step.x86_64 0.9.5-2.20210331git1ea1020.fc34 @updates-testing
plymouth-scripts.x86_64         0.9.5-2.20210331git1ea1020.fc34 @fedora         
plymouth-theme-spinner.x86_64   0.9.5-2.20210331git1ea1020.fc34 @updates-testing

Post the output to verify your settings:

sudo grep -r -e ^options /boot/loader/entries; \
head -v -n -0 /etc/default/grub /proc/cmdline; \
rpm -q -a grub\* plymouth\* | sort
1 Like
$ sudo dnf list installed "*plymouth*"

Installed Packages
plymouth.x86_64    0.9.5-2.20210331git1ea1020.fc34    @fedora 
plymouth-core-libs.x86_64    0.9.5-2.20210331git1ea1020.fc34    @fedora 
plymouth-devel.x86_64    0.9.5-2.20210331git1ea1020.fc34    @fedora 
plymouth-graphics-libs.x86_64    0.9.5-2.20210331git1ea1020.fc34    @fedora 
plymouth-kcm.x86_64    5.21.4-1.fc34    @updates
plymouth-plugin-fade-throbber.x86_64    0.9.5-2.20210331git1ea1020.fc34    @fedora 
plymouth-plugin-label.x86_64    0.9.5-2.20210331git1ea1020.fc34    @fedora 
plymouth-plugin-script.x86_64    0.9.5-2.20210331git1ea1020.fc34    @fedora 
plymouth-plugin-space-flares.x86_64    0.9.5-2.20210331git1ea1020.fc34    @fedora 
plymouth-plugin-two-step.x86_64    0.9.5-2.20210331git1ea1020.fc34    @fedora 
plymouth-scripts.x86_64    0.9.5-2.20210331git1ea1020.fc34    @fedora 
plymouth-system-theme.x86_64    0.9.5-2.20210331git1ea1020.fc34    @fedora 
plymouth-theme-breeze.x86_64    5.21.4-1.fc34    @updates
plymouth-theme-charge.x86_64    0.9.5-2.20210331git1ea1020.fc34    @fedora 
plymouth-theme-fade-in.x86_64    0.9.5-2.20210331git1ea1020.fc34    @fedora 
plymouth-theme-hot-dog.noarch    0.5-18.fc34    @fedora 
plymouth-theme-script.x86_64    0.9.5-2.20210331git1ea1020.fc34    @fedora 
plymouth-theme-solar.x86_64    0.9.5-2.20210331git1ea1020.fc34    @fedora 
plymouth-theme-spinfinity.x86_64    0.9.5-2.20210331git1ea1020.fc34    @fedora 
plymouth-theme-spinner.x86_64    0.9.5-2.20210331git1ea1020.fc34    @fedora
1 Like
/boot/loader/entries/b1e588b178a745cb9fb29df97f26b1ad-0-rescue.conf:options root=UUID=c44188e0-dc97-48e3-8f25-089510d53b20 ro rootflags=subvol=root  
/boot/loader/entries/b1e588b178a745cb9fb29df97f26b1ad-5.11.14-200.fc33.x86_64.conf:options root=UUID=c44188e0-dc97-48e3-8f25-089510d53b20 ro rootflags=subvol=root
/boot/loader/entries/b1e588b178a745cb9fb29df97f26b1ad-5.11.17-300.fc34.x86_64.conf:options root=UUID=c44188e0-dc97-48e3-8f25-089510d53b20 ro rootflags=subvol=root
/boot/loader/entries/b1e588b178a745cb9fb29df97f26b1ad-5.11.17-200.fc33.x86_64.conf:options root=UUID=c44188e0-dc97-48e3-8f25-089510d53b20 ro rootflags=subvol=root
==> /etc/default/grub <==
GRUB_TIMEOUT=15
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX=""
GRUB_DISABLE_RECOVERY="true"
GRUB_ENABLE_BLSCFG=true
GRUB_CMDLINE_LINUX="rd.lvm.lv=rhel/root rd.md=0 vconsole.keymap=us $([ -x /usr/sbin/rhcrashkernel-param ] && /usr/sbin/rhcrashkernel-param || :) rd.luks=0 vconsole.font=latarcyrheb-sun16 rd.lvm.lv=vg_rhel/swap quiet"

==> /proc/cmdline <==
BOOT_IMAGE=(hd0,gpt2)/vmlinuz-5.11.17-300.fc34.x86_64 root=UUID=c44188e0-dc97-48e3-8f25-089510d53b20 ro rootflags=subvol=root
grub2-common-2.06~rc1-4.fc34.noarch
grub2-efi-ia32-2.06~rc1-4.fc34.x86_64
grub2-efi-ia32-cdboot-2.06~rc1-4.fc34.x86_64
grub2-efi-x64-2.06~rc1-4.fc34.x86_64
grub2-efi-x64-cdboot-2.06~rc1-4.fc34.x86_64
grub2-pc-2.06~rc1-4.fc34.x86_64
grub2-pc-modules-2.06~rc1-4.fc34.noarch
grub2-tools-2.06~rc1-4.fc34.x86_64
grub2-tools-efi-2.06~rc1-4.fc34.x86_64
grub2-tools-extra-2.06~rc1-4.fc34.x86_64
grub2-tools-minimal-2.06~rc1-4.fc34.x86_64
grubby-8.40-51.fc34.x86_64
plymouth-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-core-libs-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-devel-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-graphics-libs-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-kcm-5.21.4-1.fc34.x86_64
plymouth-plugin-fade-throbber-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-plugin-label-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-plugin-script-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-plugin-space-flares-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-plugin-two-step-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-scripts-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-system-theme-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-theme-breeze-5.21.4-1.fc34.x86_64
plymouth-theme-charge-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-theme-fade-in-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-theme-hot-dog-0.5-18.fc34.noarch
plymouth-theme-script-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-theme-solar-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-theme-spinfinity-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-theme-spinner-0.9.5-2.20210331git1ea1020.fc34.x86_64
2 Likes

Looks like you are missing the rhgb parameter.

1 Like

I’ve added that back to my cmdline but that didn’t resolve the issue.

Customize /etc/default/grub and make sure to regenerate the configs:
Boot ends in Dracut Emergency Shell with warning that root device does not exist - #6 by vgaetera

$ sudo grub2-mkconfig -o /boot/grub2/grub.cfg
Generating grub configuration file ...
Script `/boot/grub2/grub.cfg.new' contains no commands and will do nothing
Syntax errors are detected in generated GRUB config file.
Ensure that there are no errors in /etc/default/grub
and /etc/grub.d/* files or please file a bug report with
/boot/grub2/grub.cfg.new file attached.


$ sudo dracut -f --regenerate-all
depmod: WARNING: could not open modules.order at /var/tmp/dracut.93Vc4Z/initramfs/lib/modules/5.11.11-200.fc33.x86_64: No such file or directory
depmod: WARNING: could not open modules.builtin at /var/tmp/dracut.93Vc4Z/initramfs/lib/modules/5.11.11-200.fc33.x86_64: No such file or directory
libkmod: kmod_module_parse_depline: ctx=0x55e6b83b2700 path=/lib/modules/5.11.14-200.fc33.x86_64//weak-updates/nvidia.ko.xz error=No such file or directory
libkmod: kmod_module_parse_depline: ctx=0x55e6b83b2700 path=/lib/modules/5.11.14-200.fc33.x86_64//weak-updates/nvidia-modeset.ko.xz error=No such file or directory
libkmod: kmod_module_parse_depline: ctx=0x55e6b83b2700 path=/lib/modules/5.11.14-200.fc33.x86_64//weak-updates/nvidia.ko.xz error=No such file or directory
libkmod: kmod_module_parse_depline: ctx=0x555ee6e3df20 path=/lib/modules/5.11.14-200.fc33.x86_64//weak-updates/nvidia-modeset.ko.xz error=No such file or directory

I believe as part of my attempt to reinstall grub, one of the commands was to ‘rm /etc/grub.d/*’.

1 Like

Check the output:

sudo rpm -V -a grub2\*
$ sudo rpm -V -a grub2\*
missing   c /etc/grub.d/00_header
missing   c /etc/grub.d/01_users
missing   c /etc/grub.d/08_fallback_counting
missing   c /etc/grub.d/10_linux
missing   c /etc/grub.d/10_reset_boot_success
missing   c /etc/grub.d/12_menu_auto_hide
missing   c /etc/grub.d/14_menu_show_once
missing   c /etc/grub.d/20_linux_xen
missing   c /etc/grub.d/20_ppc_terminfo
missing   c /etc/grub.d/30_os-prober
missing   c /etc/grub.d/30_uefi-firmware
missing   c /etc/grub.d/40_custom
missing   c /etc/grub.d/41_custom
missing     /etc/grub.d/README
.M.......  c /boot/grub2/grub.cfg
.M.......  c /boot/grub2/grub.cfg
missing     /etc/sysconfig/grub
1 Like

Try again after reinstalling the packages:

sudo dnf reinstall grub2-common grub2-tools
$ sudo rpm -V -a grub2\*
.M.......  c /boot/grub2/grub.cfg
.M.......  c /boot/grub2/grub.cfg
missing     /etc/sysconfig/grub
1 Like
$ sudo grub2-mkconfig -o /etc/grub2/grub.cfg
Generating grub configuration file ...
Found Fedora release 23 (Twenty Three) on /dev/sde2
done

$ sudo dracut -f --regenerate-all
depmod: WARNING: could not open modules.order at /var/tmp/dracut.cgCNJ1/initramfs/lib/modules/5.11.11-200.fc33.x86_64: No such file or directory
depmod: WARNING: could not open modules.builtin at /var/tmp/dracut.cgCNJ1/initramfs/lib/modules/5.11.11-200.fc33.x86_64: No such file or directory
libkmod: kmod_module_parse_depline: ctx=0x56497efb5700 path=/lib/modules/5.11.14-200.fc33.x86_64//weak-updates/nvidia.ko.xz error=No such file or directory
libkmod: kmod_module_parse_depline: ctx=0x56497efb5700 path=/lib/modules/5.11.14-200.fc33.x86_64//weak-updates/nvidia-modeset.ko.xz error=No such file or directory
libkmod: kmod_module_parse_depline: ctx=0x56497efb5700 path=/lib/modules/5.11.14-200.fc33.x86_64//weak-updates/nvidia.ko.xz error=No such file or directory
libkmod: kmod_module_parse_depline: ctx=0x5598501cef20 path=/lib/modules/5.11.14-200.fc33.x86_64//weak-updates/nvidia-modeset.ko.xz error=No such file or directory

$ sudo grep -r -e ^options /boot/loader/entries; head -v -n -0 /etc/default/grub /proc/cmdline; rpm -q -a grub\* plymouth\* | sort
/boot/loader/entries/b1e588b178a745cb9fb29df97f26b1ad-0-rescue.conf:options root=UUID=c44188e0-dc97-48e3-8f25-089510d53b20 ro rootflags=subvol=root  
/boot/loader/entries/b1e588b178a745cb9fb29df97f26b1ad-5.11.14-200.fc33.x86_64.conf:options root=UUID=c44188e0-dc97-48e3-8f25-089510d53b20 ro rootflags=subvol=root
/boot/loader/entries/b1e588b178a745cb9fb29df97f26b1ad-5.11.17-300.fc34.x86_64.conf:options root=UUID=c44188e0-dc97-48e3-8f25-089510d53b20 ro rootflags=subvol=root
/boot/loader/entries/b1e588b178a745cb9fb29df97f26b1ad-5.11.17-200.fc33.x86_64.conf:options root=UUID=c44188e0-dc97-48e3-8f25-089510d53b20 ro rootflags=subvol=root
==> /etc/default/grub <==
GRUB_TIMEOUT=15
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="rhgb quiet"
GRUB_DISABLE_RECOVERY="true"
GRUB_ENABLE_BLSCFG=true
GRUB_CMDLINE_LINUX="rhgb quiet"

==> /proc/cmdline <==
BOOT_IMAGE=(hd0,gpt2)/vmlinuz-5.11.17-300.fc34.x86_64 root=UUID=c44188e0-dc97-48e3-8f25-089510d53b20 ro rootflags=subvol=root
grub2-common-2.06~rc1-4.fc34.noarch
grub2-efi-ia32-2.06~rc1-4.fc34.x86_64
grub2-efi-ia32-cdboot-2.06~rc1-4.fc34.x86_64
grub2-efi-x64-2.06~rc1-4.fc34.x86_64
grub2-efi-x64-cdboot-2.06~rc1-4.fc34.x86_64
grub2-pc-2.06~rc1-4.fc34.x86_64
grub2-pc-modules-2.06~rc1-4.fc34.noarch
grub2-tools-2.06~rc1-4.fc34.x86_64
grub2-tools-efi-2.06~rc1-4.fc34.x86_64
grub2-tools-extra-2.06~rc1-4.fc34.x86_64
grub2-tools-minimal-2.06~rc1-4.fc34.x86_64
grubby-8.40-51.fc34.x86_64
plymouth-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-core-libs-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-devel-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-graphics-libs-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-kcm-5.21.4-1.fc34.x86_64
plymouth-plugin-fade-throbber-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-plugin-label-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-plugin-script-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-plugin-space-flares-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-plugin-two-step-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-scripts-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-system-theme-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-theme-breeze-5.21.4-1.fc34.x86_64
plymouth-theme-charge-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-theme-fade-in-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-theme-hot-dog-0.5-18.fc34.noarch
plymouth-theme-script-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-theme-solar-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-theme-spinfinity-0.9.5-2.20210331git1ea1020.fc34.x86_64
plymouth-theme-spinner-0.9.5-2.20210331git1ea1020.fc34.x86_64


$ sudo rpm -V -a grub2\*
.M.......  c /boot/grub2/grub.cfg
.M.......  c /boot/grub2/grub.cfg
missing     /etc/sysconfig/grub

Did make some progress.