Low audio volume even with 100% (Thinkpad X1C6)

Hey,
on F30 gnome even with volume up to 100% the audio volume on my Thinkpad X1C6 is much lower then in windows, anyone having the same issue?

Hi @ib54003! Welcome to the community! Please do take a few minutes to go over the introductory posts in #start-here when you have the time. They contain lots of useful information.

You can try checking hardware volume meters using alsamixer in the terminal. After starting the program you’ll need to press [F6] and select actual sound card (by default pulseaudio master volume meter is selected), then check all the meters available and see if one of them set too low, and if you can increase it.

One more thing to check is if your sound output profile is the correct one (i.e. stereo output and not some 7.1 surround output). With previous gnome versions you could easily check it in the sound settings, but now these settings have been simplified. One way I know from the top of my head is to install pavucontrol

sudo dnf install pavucontrol

launch it (it’s a graphical application, you can launch it from the terminal by typing pavucontrol or from Gnome menu by searching for pavucontrol), go to the last tab (Configuraton) and check which profile is chosen. Default is “Analog stereo duplex”.

Both these suggestions are generic, not for your thinkpad specifically, and in my opinion have a slim chance to help. But on the other hand they’re easy to check.

One more thing you can try is the setting to allow volume above 100% in gnome-tweak-tool. Install the application with

sudo dnf install gnome-tweak-tool

if you haven’t already, launch it, then on the Main settings page (first one from the top) the third option is the one I speak of. This is a workaround, not the solution though, and it may or may not help in your case.

1 Like

one thing that bothered me is that “With previous gnome versions you could easily check it in the sound settings, but now these settings have been simplified”
But now it requires to install another application to do same thing?
How that is simplified? Or I misunderstood something!

@chetankhilosiya, “simplified” as in “removed settings developers deemed unnecessary/confusing/superficial”. I’m not trying to defend them, I like more settings and more control myself – but clearly gnome’s policy is to provide minimum settings.

My opinion: they have the right, they are the developers, and some are with vision and a clear view of how to get there. I’m a user, and I don’t contribute to development. I can open bugs, engage in discussions of how things should be, etc. – I choose not to. I take thing they made ready for me, then I adapt it to my needs, adapt to it – or switch to something different, if it doesn’t suit me. Again, that’s just my opinion :slight_smile:

We can migrate to KDE, they say it has a myriad settings for everything on the Earth and then again some more :slight_smile: And also it’s very good too )) Also mate is good. We have options)

2 Likes

Got it. IMO “removed” or “not available now” would have been more clearer.

I actually thought that I’ve read somewhere about sound settings “being simplified” for the new Gnome release, but to be fair Gnome’s Release notes says:

The Sound settings has been redesigned to support a vertical layout and a more intuitive placement of options.

– which actually not equals to “simplified”, but still they don’s say that what they’ve done is removed quite a few controls ))

To all: sorry for offtopic.

thanks, that solves it but its not pretty …

@ib54003, can you specify which of the three ways I suggested did actually help you? I’m interested to know.

gnome-tweak-tool …

Thanks for clarifying.

1 Like

had the same exact problem… not pretty

Hi @limestree! Welcome to the community! Please do take a few minutes to go over the introductory posts in #start-here when you have the time. They contain lots of useful information.

What hardware do you have? Is it the same laptop @ib54003 has, or something completely different?

Can you both provide output of

lspci -k | grep -i 'audio' -A 4
lspci -k | grep -i 'audio' -A 4
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
	Subsystem: Lenovo Device 225c
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel, snd_soc_skl
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)

I opend a bug to get this fixed.

https://bugzilla.redhat.com/show_bug.cgi?id=1737092