LUKS cryptsetup error on each reboot/shutdown

I have my system set up with LVM on LUKS. On every reboot or shutdown, journalctl shows this error:

systemd-cryptsetup: Device luks-[UUID] is still in use.
systemd-cryptsetup: Failed to deactivate: Device or resource busy

lsblk

NAME                                          MAJ:MIN RM  SIZE RO TYPE  MOUNTPOINT
sda                                             8:0    0  1.9T  0 disk  
├─sda1                                          8:1    0  200M  0 part  /boot/efi
├─sda2                                          8:2    0    1G  0 part  /boot
└─sda3                                          8:3    0  1.9T  0 part  
  └─luks-[UUID]                               253:0    0  1.9T  0 crypt 
    ├─[MACHINE]-root                          253:1    0   50G  0 lvm   /
    ├─[MACHINE]-data                          253:2    0    1T  0 lvm   /media/data
    ├─[MACHINE]-home                          253:3    0  100G  0 lvm   /home
    └─[MACHINE]-swap                          253:4    0    4G  0 lvm   [SWAP]

/etc/crypttab

luks-[UUID] UUID=[UUID] none discard

/etc/fstab

/dev/mapper/[MACHINE]-root /                       ext4    defaults,x-systemd.device-timeout=0 1 1
UUID=[BOOT-UUID] /boot                             ext4    defaults        1 2
UUID=[BOOT-EFI-UUID]       /boot/efi               vfat    umask=0077,shortname=winnt 0 2
/dev/mapper/[MACHINE]-home /home                   ext4    defaults,x-systemd.device-timeout=0 1 2
/dev/mapper/[MACHINE]-data /media/data             ext4    defaults,x-systemd.device-timeout=0 1 2
#/swapfile		 none			swap	defaults	0 0
/dev/mapper/[MACHINE]-swap none                    swap    defaults,x-systemd.device-timeout=0 0 0