Make user default -- prompted to create new user after update

I installed fedora 34, after few weeks i ran the update command and restarted my laptop.

The laptop directly boot into main window and asked me create a new user which was weird as i already had a user so why create a new one again, i thought the update somehow reset my system and i lost everything related to that user account so i looked into /etc/passwd to check the old user in system.

The user was there, so now i have to use not listed option in login screen to be able to login to old user account. so how do i make user account as default one so i dont have to use not listed option in login screen.

So what has happened (likely) is that the file gnome-initial-setup-done likely is either not in ~/.config or has “No” in it instead of “Yes”. So you can edit the file ~/.config/gnome-initial-setup-done to have “Yes” instead of “No” in it.

1 Like

@knightcrusty if jakfrost’s suggestion works for you, please mark his post as your solution so that others searching for a solution to this problem go to this thread for help. And we may need to get someone to edit your thread title to help with searches, something like “Prompted to create new user after update”. Thanks

Actually i didnt had any choice at that time so i created a new user using the intial setup. now the problem is that it shows only the new user on the login screen and i have to use not listed option to login into old account.

I want my old account to be shown as default on the login screen. how to do that?

i tried deleting the new user but again i end up with intial setup screen…what to do?

sudo sed -i -r -e "s/^(SystemAccount=).*/\1false/" \
    /var/lib/AccountsService/users/${USER}

busctl get-property org.freedesktop.Accounts \
    /org/freedesktop/Accounts/User${UID} \
    org.freedesktop.Accounts.User SystemAccount

User account set to system account after upgrade - Silverblue - Fedora Discussion

didnt worked and second command throw this output

busctl get-property org.freedesktop.Accounts \
    /org/freedesktop/Accounts/User${UID} \
    org.freedesktop.Accounts.User SystemAccount

b false


I even edited the old user file and set the systemAccount to true in that file but still same thing