Maximum screen brightness every boot up

Hi, i am very new to fedora. it just works for now. But every restart does not remember previous level of brightness. Not a big deal may be i just wanted to share, thank you.

Hello @akiata, and welcome to the community! Please do take a few minutes to go over the introductory posts in #start-here when you have the time. They contain lots of useful information.

Can you share the your system specs. It might be related to the GPU drivers.

i have only fedora os on my about ten years old laptop. it is optimus laptop but i do not use nvidia, terrible screen tearing. so i did not install nvidia driver just enabled rpmfusion repo and installed broadcom wireless driver. other than that os is very responsive.

i have reinstalled fedora a few times and somehow the problem disappeared. upcoming updates should have fixed the issue.

what is the output of this command .

ls /sys/class/backlight/

@youssefmsourani, problem showed up again.
output is : intel_backlight nv_backlight

1 Like

There should be a systemd service running to load/save backlight .

Service name is systemd-backlight@ + backlight + : + VGA_BACKLIGHT + .service ,something like that .

systemctl status systemd-backlight@backlight:intel_backlight.service

systemctl status systemd-backlight@backlight:nv_backlight.service

thank you for your reply. i edited the grub, at the GRUB_CMDLINE_LINUX line add acpi_backlight=vendor and update the grub. so far it works.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.