Md type primary error when updating from gnome software

well simply enough i cannot update from gnome software anymore because i have this error, any help?for info i am using fedora gnome 32

just for info, zchunk is already disabled and i’ve already refreshed the cache, with no luck at all…

You can try these tasks:

  • on a terminal, issue this command:
    pkmon -v
    then start GNOME Software. Look if something interesting appears in the terminal.
  • look at the system logs:
    journalctl -b -u packagekit
    journalctl _COMM=gnome-software -b
  • from the command line issue this command:
    killall gnome-software && gnome-software --verbose > /tmp/gs.log
    then look in the produced file for errors and warnings

this is the pkmon -v output from gnome software

Transactions:
1 /2272_acebccbd
Daemon state: 'State:
0 resolve /2272_acebccbd state[running] exclusive[1] background[0]

/2272_acebccbd allow_cancel 1
/2272_acebccbd percentage -1
21:32:16 PackageKit role now resolve
/2272_acebccbd role resolve
/2272_acebccbd status setup
/2272_acebccbd status query
/2272_acebccbd percentage 3
/2272_acebccbd status loading-cache
/2272_acebccbd percentage 5
/2272_acebccbd status finished
21:32:17 PackageKit failed to adopt: loading of MD_TYPE_PRIMARY has failed.
21:32:17 PackageKit emit transaction-list-changed
21:32:17 PackageKit last: /2272_acebccbd
21:32:17 PackageKit emit removed: /2272_acebccbd
21:32:17 PackageKit removed: /2272_acebccbd

this is the output of journalctl packagekit

– Logs begin at Sun 2020-05-17 11:36:32 CEST, end at Sun 2020-06-14 21:37:20 CEST. –
giu 14 21:28:40 localhost.localdomain systemd[1]: Starting PackageKit Daemon…
giu 14 21:28:40 localhost.localdomain PackageKit[1345]: daemon start
giu 14 21:29:04 localhost.localdomain systemd[1]: Started PackageKit Daemon.
giu 14 21:29:13 localhost.localdomain PackageKit[1345]: uid 1000 is trying to obtain org.freedesktop.packagekit.system-sources-refresh auth (only_trusted:0)
giu 14 21:29:13 localhost.localdomain PackageKit[1345]: uid 1000 obtained auth for org.freedesktop.packagekit.system-sources-refresh
giu 14 21:29:16 localhost.localdomain PackageKit[1345]: refresh-cache transaction /2263_cecebede from uid 1000 finished with cancelled-priority after 2593ms
giu 14 21:29:29 localhost.localdomain PackageKit[1345]: resolve transaction /2264_bdcecacd from uid 1000 finished with failed after 12865ms
giu 14 21:29:29 localhost.localdomain PackageKit[1345]: resolve transaction /2265_bddabaea from uid 1000 finished with failed after 448ms
giu 14 21:29:30 localhost.localdomain PackageKit[1345]: resolve transaction /2266_aeaadaea from uid 1000 finished with failed after 453ms
giu 14 21:29:31 localhost.localdomain PackageKit[1345]: resolve transaction /2267_cebcabce from uid 1000 finished with failed after 449ms
giu 14 21:29:32 localhost.localdomain PackageKit[1345]: resolve transaction /2268_dbaadcec from uid 1000 finished with failed after 439ms
giu 14 21:29:32 localhost.localdomain PackageKit[1345]: resolve transaction /2269_edabacdd from uid 1000 finished with failed after 441ms
giu 14 21:29:33 localhost.localdomain PackageKit[1345]: get-updates transaction /2270_edbecbdd from uid 1000 finished with failed after 486ms
giu 14 21:29:34 localhost.localdomain PackageKit[1345]: resolve transaction /2271_bcdbaddb from uid 1000 finished with failed after 483ms
giu 14 21:32:16 localhost.localdomain PackageKit[1345]: resolve transaction /2272_acebccbd from uid 1000 finished with failed after 521ms
giu 14 21:32:17 localhost.localdomain PackageKit[1345]: resolve transaction /2273_daebcebb from uid 1000 finished with failed after 464ms
giu 14 21:32:18 localhost.localdomain PackageKit[1345]: resolve transaction /2274_bcbeeedc from uid 1000 finished with failed after 489ms

this is the output of journalctl gnome-software

– Logs begin at Sun 2020-05-17 11:36:32 CEST, end at Sun 2020-06-14 21:35:10 CEST. –
giu 14 21:29:09 localhost.localdomain gnome-software[1419]: enabled plugins: desktop-categories, fwupd, os-release, packagekit, packagekit-local, packagekit-offline, packagekit->
giu 14 21:29:09 localhost.localdomain gnome-software[1419]: disabled plugins: dummy
giu 14 21:29:29 localhost.localdomain gnome-software[1419]: not handling error failed for action refine: failed to resolve package_ids: loading of MD_TYPE_PRIMARY has failed.
giu 14 21:29:30 localhost.localdomain gnome-software[1419]: not handling error failed for action refine: failed to resolve package_ids: loading of MD_TYPE_PRIMARY has failed.
giu 14 21:29:30 localhost.localdomain gnome-software[1419]: not handling error failed for action refine: failed to resolve package_ids: loading of MD_TYPE_PRIMARY has failed.
giu 14 21:29:31 localhost.localdomain gnome-software[1419]: Only 2 apps for popular list, hiding
giu 14 21:29:31 localhost.localdomain gnome-software[1419]: not handling error failed for action refine: failed to resolve package_ids: loading of MD_TYPE_PRIMARY has failed.
giu 14 21:29:31 localhost.localdomain gnome-software[1419]: Only 4 apps for recent list, hiding
giu 14 21:29:32 localhost.localdomain gnome-software[1419]: not handling error failed for action refine: failed to resolve package_ids: loading of MD_TYPE_PRIMARY has failed.
giu 14 21:29:32 localhost.localdomain gnome-software[1419]: hiding category productivity featured applications: found only 0 to show, need at least 9
giu 14 21:29:32 localhost.localdomain gnome-software[1419]: not handling error failed for action refine: failed to resolve package_ids: loading of MD_TYPE_PRIMARY has failed.
giu 14 21:29:33 localhost.localdomain gnome-software[1419]: hiding category audio-video featured applications: found only 1 to show, need at least 9
giu 14 21:29:34 localhost.localdomain gnome-software[1419]: not handling error failed for action refine: failed to resolve package_ids: loading of MD_TYPE_PRIMARY has failed.
giu 14 21:32:17 localhost.localdomain gnome-software[1419]: not handling error failed for action refine: failed to resolve package_ids: loading of MD_TYPE_PRIMARY has failed.
giu 14 21:32:17 localhost.localdomain gnome-software[1419]: not handling error failed for action refine: failed to resolve package_ids: loading of MD_TYPE_PRIMARY has failed.
giu 14 21:32:19 localhost.localdomain gnome-software[1419]: not handling error failed for action refine: failed to resolve package_ids: loading of MD_TYPE_PRIMARY has failed.

this is the gs log

https://fpaste.me/Qz0ljqwOEf

1 Like

Could you run this command?
pkcon -v refresh force
(As you know, GNOME Software doesn’t use dnf, but it uses packagekit).
Do you receive the same error as well?

13:23:20 PackageKit Verbose debugging enabled (on console 1)
13:23:20 PackageKit filter=(null), filters=0
13:23:20 PackageKit adding state 0x7f1c3c003d50
13:23:20 PackageKit role now refresh-cache
Aggiornamento della cache [=========================] :23:20 PCaricamento della cache [=========================]
Scaricamento informazioni sul repository[=========================]
Caricamento della cache [=========================]
Scaricamento informazioni sul repository[=========================]
Caricamento della cache [=========================]
Scaricamento informazioni sul repository[=========================]
Caricamento della cache [=========================]
Scaricamento informazioni sul repository[=========================]
Caricamento della cache [=========================]
Scaricamento informazioni sul repository[=========================]
Caricamento della cache [=========================]
Scaricamento informazioni sul repository[=========================]
Caricamento della cache [=========================]
Scaricamento informazioni sul repository[=========================]
Caricamento della cache [=========================]
Scaricamento informazioni sul repository[=========================]
Caricamento della cache [=========================]
Scaricamento informazioni sul repository[=========================]
Caricamento della cache [=========================]
Scaricamento informazioni sul repository[=========================]
Caricamento della cache [=========================]
Scaricamento informazioni sul repository[=========================]
Caricamento della cache [=========================]
Scaricamento informazioni sul repository[=========================]
Caricamento della cache [=========================]
Scaricamento informazioni sul repository[=========================]
Caricamento della cache [=========================]
Scaricamento informazioni sul repository[=========================]
Caricamento della cache [=========================]
Scaricamento informazioni sul repository[=========================]
Caricamento della cache [=========================]
Scaricamento informazioni sul repository[=========================]
Caricamento della cache [=========================]
Interrogazione [=========================]
Caricamento della cache [=========================]
Completato [ ] (0%) 13:24:48 PackageKit remove state 0x7f1c3c003d50
[=========================]
Errore irreversibile: loading of MD_TYPE_PRIMARY has failed.

I can see you are already participating in this bug report: https://bugzilla.redhat.com/show_bug.cgi?id=1779104 that seems similar to your issue.

seems to be exactly the same, someone said solved the thing by disabling zchunk, but unfortunately it’s already disabled in my case

Have you tried to selectively disable repositories?

Could you provide the result of this command?
dnf repolist

1 Like

that’s the result

copr:copr.fedorainfracloud.org:gnumdk:eolie Copr repo for eolie owned by gnumdk
copr:copr.fedorainfracloud.org:gnumdk:lollypop Copr repo for lollypop owned by gnumdk
fedora Fedora 32 - x86_64
fedora-cisco-openh264 Fedora 32 openh264 (From Cisco) - x86_64
fedora-modular Fedora Modular 32 - x86_64
rpmfusion-free RPM Fusion for Fedora 32 - Free
rpmfusion-free-updates RPM Fusion for Fedora 32 - Free - Updates
rpmfusion-nonfree RPM Fusion for Fedora 32 - Nonfree
rpmfusion-nonfree-updates RPM Fusion for Fedora 32 - Nonfree - Updates
updates Fedora 32 - x86_64 - Updates
updates-modular Fedora Modular 32 - x86_64 - Updates
vivaldi-snapshot vivaldi-snapshot

Try to disable these repositories:
sudo dnf copr disable gnumdk/eolie
sudo dnf copr disable gnumdk/lollypop
sudo dnf config-manager --disable vivaldi-snapshot

Just out of curiosity, look at the result of the following command
pkcon repo-list |grep Enabled

Then try again with
pkcon -v refresh force

If the problem is still in place, try to disable rpmfusion-nonfree, rpmfusion-nonfree-updates, rpmfusion-free and rpmfusion-free-updates. And again, if this doesn’t change anything, try to disable fedora-cisco-openh264, fedora-modular and updates-modular as well. (This is only a test, you can subsequently re-enable all the repositories).

1 Like

ok so, i’ve disabled everything subsequently through gnome-software then killed it and reopened, unfortunately i had no luck at all

also running pkcon repo-list |grep Enabled give me absolutely nothing and pkcon -v refresh force results in the same “md type primary” error, honestly i’m getting tired, i might end up resetting everything…

Everything: you mean also the fedora repositories as well? If yes, pkcon repo-list will report only Disabled repositories, hence grep Enabled output will be empty.

No need to became tired. Sometime problems are a great chance to learn new things.

yes yes i know, but seems there is no solution to this problem, wondering if this is a problem of mine, or really a bug that may be solved over time…

So, pkcon repo-list reports that all the repositories are disabled, and at the same time you get the same error?

yep, everything is disabled apart from the fedora repo (which can’t be disabled) , and still have the same error, even with pkcon -v refresh force

Disclaimer: I’m not a developer.
In the libdnf source code, in the section that fires the error MD_TYPE_PRIMARY has failed there is this comment

It could happen when repomd file has no "primary" data or they are in unsupported format like zchunk

But zchunk is disabled. :thinking: (btw, as far as I understand, packagekit doesn’t take into account /etc/dnf/dnf.conf)

Look at this other post: Can not update!
A proxy was involved :thinking:

Oh oh. I was able to get the same error. I put the wrong baseurl in /etc/yum.repos.d/fedora-updates.repo
While dnf was not complaining any error, pkgcon exited with MD_TYPE_PRIMARY has failed
Btw, it could be a very different issue.

Supposing that all the other repositories are disabled, out of curiosity, could you paste here the content of /etc/yum.repos.d/fedora.repo

so, as for the proxy, i use a 4g modem with an ho-mobile card, and yes they are using some proxy which is the culprit of my zchunk error, but i guess there’s no way to change that, need to call them…

as for the fedora repo, everything is disabled now

[fedora]
name=Fedora $releasever - $basearch
#baseurl=http://download.example/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=$basearch
enabled=1
countme=1
metadata_expire=7d
repo_gpgcheck=0
type=rpm
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False

[fedora-debuginfo]
name=Fedora $releasever - $basearch - Debug
#baseurl=http://download.example/pub/fedora/linux/releases/$releasever/Everything/$basearch/debug/tree/
metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-debug-$releasever&arch=$basearch
enabled=0
metadata_expire=7d
repo_gpgcheck=0
type=rpm
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False

[fedora-source]
name=Fedora $releasever - Source
#baseurl=http://download.example/pub/fedora/linux/releases/$releasever/Everything/source/tree/
metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-source-$releasever&arch=$basearch
enabled=0
metadata_expire=7d
repo_gpgcheck=0
type=rpm
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False

Ok.
Just another test.
Could you edit the /etc/yum.repos.d/fedora.repo file, and in the [fedora] repo-id, comment the metalink line and add a baseurl line.
Like this:

...
baseurl=http://fedora.mirror.garr.it/fedora/linux/releases/$releasever/Everything/$basearch/os/
# metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=$basearch
...

Then (with all the other repositories disabled) check if it is ok, for instance with this command:

sudo dnf check-update --refresh

and once again, retry with:

pkcon -v refresh force

so it should look like this i guess

[fedora]
name=Fedora $releasever - $basearch
baseurl=http://fedora.mirror.garr.it/fedora/linux/releases/$releasever/Everything/$basearch/os/
# metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=$basearch
enabled=1
countme=1
metadata_expire=7d
repo_gpgcheck=0
type=rpm
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False

[fedora-debuginfo]
name=Fedora $releasever - $basearch - Debug
#baseurl=http://download.example/pub/fedora/linux/releases/$releasever/Everything/$basearch/debug/tree/
metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-debug-$releasever&arch=$basearch
enabled=0
metadata_expire=7d
repo_gpgcheck=0
type=rpm
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False

[fedora-source]
name=Fedora $releasever - Source
#baseurl=http://download.example/pub/fedora/linux/releases/$releasever/Everything/source/tree/
metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-source-$releasever&arch=$basearch
enabled=0
metadata_expire=7d
repo_gpgcheck=0
type=rpm
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False

anyway if it’s correct the the result is exactly the same, md type primary error

meanwhile in this case

[fedora]
name=Fedora $releasever - $basearch
#baseurl=http://download.example/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=$basearch
baseurl=http://fedora.mirror.garr.it/fedora/linux/releases/$releasever/Everything/$basearch/os/
# metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=$basearch
enabled=1
countme=1
metadata_expire=7d
repo_gpgcheck=0
type=rpm
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False

[fedora-debuginfo]
name=Fedora $releasever - $basearch - Debug
#baseurl=http://download.example/pub/fedora/linux/releases/$releasever/Everything/$basearch/debug/tree/
metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-debug-$releasever&arch=$basearch
enabled=0
metadata_expire=7d
repo_gpgcheck=0
type=rpm
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False

[fedora-source]
name=Fedora $releasever - Source
#baseurl=http://download.example/pub/fedora/linux/releases/$releasever/Everything/source/tree/
metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-source-$releasever&arch=$basearch
enabled=0
metadata_expire=7d
repo_gpgcheck=0
type=rpm
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False

i do have the usual zchunk error…