Memory leak in packagekitd makes my laptop slow

I leave my laptop running overnight and I wake up to a slow laptop that’s using a lot of swap space.

I run:

$ ps vax --sort=-rss | head -n 2
PID TTY      STAT   TIME  MAJFL   TRS   DRS   RSS %MEM COMMAND
3417213 ?        Dsl  138:37      9     0 1856820 1329320  8.1 /usr/libexec/packagekitd

Also:

$ free 
              total        used        free      shared  buff/cache   available
Mem:       16337168     8612140     1484512     2478372     6240516     4903036
Swap:      33659900      246612    33413288

Particulars:

$ uname -svrp
Linux 5.6.13-300.fc32.x86_64 #1 SMP Thu May 14 22:51:37 UTC 2020 x86_64
$ lsb_release -d
Description:	Fedora release 32 (Thirty Two)

Some things never change:

https://bugzilla.redhat.com/show_bug.cgi?id=1354074

Screenshot from 2020-05-23 09-46-09

How can I get rid of software that has memory leaks and still get updates, please?

The best thing to do if you suspect a memory leak is to open a new bug to get the developer’s attention. Reporting it here will probably serve less of a purpose beyond expressing frustrations.

Normally, to uninstall software, you would run $ sudo dnf remove packagename where “packagename” is the name of the software you are wanting to remove.

Please do not tell people to remove their package management software. I’m assuming you made a mistake in good faith but telling people to damage their systems is not ethical.

My question was not answered because it asked for two things and you only provided an answer for one of them. You replied with how to remove software but in a way that prevents updates and the question was to do both remove the software with memory leaks and still get updates.

You asked me to open a bug report but it would be a duplicate of the existing bug report. If you examine that bug report it was closed and reopened in the past rather than opening a duplicate.

OK, if the bug’s already been reported, add a comment giving any new information you can.

Instead of uninstalling stuff, you can disable the automatic updates in the GNOME software center. That should be enough to prevent the memory-leaking service from starting until the bug is fixed.

Regarding updates, you can still keep your system updated through dnf instead of packagekit. Use sudo dnf upgrade to perform a system update, and if you’d like for this to be done automatically, take a look at dnf-automatic.