Mic doesn't work after updating to fedora 33

I had fedora 32 installed and the internal microphone worked well all the time.
But, after updating to fedora 33 I haven’t been able to make it work, in the Gnome settings the device is recognized but it does not catch any sound.
imagen

When I plug a earphone the microphone of it does work.
This is the output of arecord -l

**** List of CAPTURE Hardware Devices ****
card 1: Generic_1 [HD-Audio Generic], device 0: ALC257 Analog [ALC257 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: acp [acp], device 0: DMIC capture dmic-hifi-0 []
  Subdevices: 0/1
  Subdevice #0: subdevice #0

and de output of uname -r

5.8.16-300.fc33.x86_64

Hi, I solved with:

1.-
sudo nano /etc/modprobe.d/blacklist-local.conf

then inside paste:

2.-
blacklist snd-soc-dmic
blacklist snd-acp3x-rn
blacklist snd-acp3x-pdm-dma

close(crtl+x) and save(y).

3.-reboot

after that work mic and speaker:

image

4 Likes

Thank you it’s solved!

Hi, @mamaldonadov, welcome to this forum and thanks. This indeed works.

However, it’s only a workaround of course. I came here from this thread and already opened a bug report here.

Can you explain why that happens/link a bug report or so one can follow, so we can see when there will be a “real” fix of this bug?

1 Like

I have reported my case in the same bug report as you, but I don’t know why it happens.

Maybe @mamaldonadov, would you help us with this please?

2 Likes

Yeah, I reported it as a pulseaudio bug. Also don’t know yet whether it is really a bug in pulseaudio or the kernel or so.

Also i do have a possibly related bug: Even when I use Bluetooth headsets now, the microphone never works, regardless of which codec I choose.

Still waiting for some reply in the bug report, so I’ve now assigned it to the kernel component in the hope more people read there…

Also anyone got a solution for external microphones? As said, the internal one works now, but external (Bluetooth) do not. As said:

Maybe also this thread can help, but it’s about Fedora 31, so really oldish…

1 Like