Microphone volume keeps resetting

Hi,

So I have my fedora workstation 33 setup to use a headset and mic.
When I set the mic input volume in Pulse Audio Volume Control, after a few minutes it resets back to 100%.

This is also true for the output volume, but right now I would like to be able to to control the input volume so that background noises are not detected when I am on a call. This is not just an issue with fedora 33, it also happened with previous versions as well.

Any help in being able to to control the pulseaudio setting would be appreciated.

Regards,

Pace

In my case, the mic volume keeps going down.
Even when I set it back to 100%, it keeps going down after a few minutes.
And this also happened in Fedora 32 too.

I once thought that this happen due to Zoom settings.
But when i use another app like Google Duo and Google Meet, the mic volume still going down after a few minutes.

Any idea what might be the cause?

I think it may be due to pulseaudio being set to to use flat-volumes.

I am currently testing this by deleting the contents of ~/.config/pulse and creating a ~/.config/pulse/daemon.conf with the line:
flat-volumes=no

I will let you know if it helps.

I tried the solution specified here https://nzeid.net/pulseaudio-disable-auto-volume
I think this is now allowing me to specify my input volumes through pulsuaudio control, and the solution above has separated my audio devices.

I will test further, but I seem to be able to separately specify the recording device level in pulseaudio. On my mic icon the mic input moves, but in pulseaudio recording devices it seems to stay where it is.