MLT framework crash via Kdenlive rendering

I want to render a Kdenlive project using the rendering dialog:

Bildschirmfoto_20200728-09:52:28-c2e-Rendering—Kdenlive

However, that crashes without giving me much to work with:

In the system log I found this crash within the MLT framework:

Jul 28 09:52:34 mu-x220 systemd-coredump[82646]:
  Process 82642 (mlt-melt) of user 1000 dumped core.
                                                 
  Stack trace of thread 82642:
  #0  0x00007f5b859ad9e5 raise (libc.so.6 + 0x3c9e5)
  #1  0x00007f5b85996895 abort (libc.so.6 + 0x25895)
  #2  0x00007f5b7d8f1a7f _ZNK14QMessageLogger5fatalEPKcz (libQt5Core.so.5 + 0x91a7f)
  #3  0x00007f5b7de65e85 _ZN13QFontDatabaseC2Ev.cold (libQt5Gui.so.5 + 0xeae85)
  #4  0x00007f5b746ca5cb _ZL5fontsv (libpbf.so + 0x2e5cb)
  #5  0x00007f5b746caa85 _ZN4Font13fromJsonArrayERK10QJsonArray (libpbf.so + 0x2ea85)
  #6  0x00007f5b746ba879 _ZN5Style5Layer6LayoutC1ERK11QJsonObject (libpbf.so + 0x1e879)
  #7  0x00007f5b746beee7 _ZN5Style5LayerC1ERK11QJsonObject (libpbf.so + 0x22ee7)
  #8  0x00007f5b746c08a0 _ZN5Style4loadERK7QString (libpbf.so + 0x248a0)
  #9  0x00007f5b746b5a88 _ZN9PBFPluginC2Ev (libpbf.so + 0x19a88)
  #10 0x00007f5b746d5375 qt_plugin_instance (libpbf.so + 0x39375)
  #11 0x00007f5b7dab3564 _ZN15QLibraryPrivate14pluginInstanceEv (libQt5Core.so.5 + 0x253564)
  #12 0x00007f5b7daae16d _ZNK14QFactoryLoader8instanceEi (libQt5Core.so.5 + 0x24e16d)
  #13 0x00007f5b7def0fa6 _ZL23createReadHandlerHelperP9QIODeviceRK10QByteArraybb (libQt5Gui.so.5 + 0x175fa6)
  #14 0x00007f5b7def1d84 _ZN19QImageReaderPrivate11initHandlerEv (libQt5Gui.so.5 + 0x176d84)
  #15 0x00007f5b7def27e0 _ZNK12QImageReader7canReadEv (libQt5Gui.so.5 + 0x1777e0)
  #16 0x00007f5b7ebc17fa init_qimage (libmltqt.so + 0x167fa)
  #17 0x00007f5b7ebbcdf5 producer_qimage_init (libmltqt.so + 0x11df5)
  #18 0x00007f5b85cf6542 mlt_factory_producer (libmlt.so.6 + 0x29542)
  #19 0x00007f5b7ea5308e create_producer (libmltcore.so + 0xa08e)
  #20 0x00007f5b7ea536a9 producer_loader_init (libmltcore.so + 0xa6a9)
  #21 0x00007f5b85cf6542 mlt_factory_producer (libmlt.so.6 + 0x29542)
  #22 0x00007f5b85d17c90 on_end_element (libmltxml.so + 0x9c90)
  #23 0x00007f5b856a10cd xmlParseEndTag1.constprop.0 (libxml2.so.2 + 0x4a0cd)
  #24 0x00007f5b856a11c4 xmlParseElementEnd (libxml2.so.2 + 0x4a1c4)
  #25 0x00007f5b856a5721 xmlParseContent (libxml2.so.2 + 0x4e721)
  #26 0x00007f5b856a6dc0 xmlParseDocument (libxml2.so.2 + 0x4fdc0)
  #27 0x00007f5b85d18dce producer_xml_init (libmltxml.so + 0xadce)
  #28 0x00007f5b85cf6542 mlt_factory_producer (libmlt.so.6 + 0x29542)
  #29 0x00007f5b7ea532a1 create_producer (libmltcore.so + 0xa2a1)
  #30 0x00007f5b7ea536a9 producer_loader_init (libmltcore.so + 0xa6a9)
  #31 0x00007f5b85cf6542 mlt_factory_producer (libmlt.so.6 + 0x29542)
  #32 0x00007f5b7ea547fa producer_melt_init (libmltcore.so + 0xb7fa)
  #33 0x00007f5b85cf6542 mlt_factory_producer (libmlt.so.6 + 0x29542)
  #34 0x0000558ec88772b5 main (mlt-melt + 0x32b5)
  #35 0x00007f5b85998042 __libc_start_main (libc.so.6 + 0x27042)
  #36 0x0000558ec887838e _start (mlt-melt + 0x438e)

With gnome-abrt I can see it:

And I get some details:

But somehow I cannot report it:

How can I further diagnose this issue and hopefully fix it?

1 Like

The reason why you can’t report report the bug currently is that Fedora’s ABRT servers (retrace.fpo) are being moved and still offline.

I would suggest you open an issue on Kdenlive’s bug tracker: https://invent.kde.org/multimedia/kdenlive/-/issues

Okay, I have opened a bug: https://bugs.kde.org/show_bug.cgi?id=424759