Mouse cursor shape gets stuck

Hi,

I just moved my workstation over to Fedora Silverblue 35 and I really like it. However I have a strange problem which is hard to explain. :slight_smile:

As you know the cursor has various shapes like the following:

  • A shape when you drag a window
  • A shape when you resize windows
  • A shape when you click on a link

etc…

The problem is that it gets stuck with whatever I did and gets corrected when I go into overview and come back to the normal view. It also gets corrected when I hover over another window. For example, when I hover over the links on this forum, I see the normal cursor shape as I write this. I had a magnification shape 5 minutes ago hovering over windows. :slight_smile:

Anyone else having similar issue?

$ cat /etc/os-release 
NAME="Fedora Linux"
VERSION="35.20220131.0 (Silverblue)"
ID=fedora
VERSION_ID=35
VERSION_CODENAME=""
PLATFORM_ID="platform:f35"
PRETTY_NAME="Fedora Linux 35.20220131.0 (Silverblue)"
ANSI_COLOR="0;38;2;60;110;180"
LOGO=fedora-logo-icon
CPE_NAME="cpe:/o:fedoraproject:fedora:35"
HOME_URL="https://fedoraproject.org/"
DOCUMENTATION_URL="https://docs.fedoraproject.org/en-US/fedora-silverblue/"
SUPPORT_URL="https://ask.fedoraproject.org/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"
REDHAT_BUGZILLA_PRODUCT="Fedora"
REDHAT_BUGZILLA_PRODUCT_VERSION=35
REDHAT_SUPPORT_PRODUCT="Fedora"
REDHAT_SUPPORT_PRODUCT_VERSION=35
PRIVACY_POLICY_URL="https://fedoraproject.org/wiki/Legal:PrivacyPolicy"
VARIANT="Silverblue"
VARIANT_ID=silverblue
OSTREE_VERSION='35.20220131.0'
$ gnome-extensions list
nightthemeswitcher@romainvigier.fr
appindicatorsupport@rgcjonas.gmail.com
soft-brightness@fifi.org
sound-output-device-chooser@kgshank.net
Vitals@CoreCoding.com
caffeine@patapon.info
apps-menu@gnome-shell-extensions.gcampax.github.com
background-logo@fedorahosted.org
launch-new-instance@gnome-shell-extensions.gcampax.github.com
places-menu@gnome-shell-extensions.gcampax.github.com
window-list@gnome-shell-extensions.gcampax.github.com
1 Like

Welcome to ask.:fedora:edora @tunix

Can you test if the problem exist while start gnome without extentions ?

The window-list extension is famous for making problems.

window-list was already disabled. I don’t think current set of extensions would cause such an issue but I will try your suggestion.