My Fedora system cant recognise my Nvidia GPU

I installed the Nvidia Drivers by rpm fusion. The drivers installed correctly. But still my system doesn’t recognise my nvidia GPU even after the Nvidia app is installed on the system and works fine.

lspci -vmk | grep -A 8 -B 2 VGA

Device: 00:02.0
Class: VGA compatible controller
Vendor: Intel Corporation
Device: HD Graphics 620
SVendor: Lenovo
SDevice: Device 505c
Rev: 02
Driver: i915
Module: i915

It only shows the Intel GPU for every command. I cannot figure what i have to do with the nouveau even after watching a dozen videos and my system now works even slower because i guess after it installed Nvidia Drivers it removed the Xorg and now it boots and works even slower.

TL;DR - Nvidia drivers got installed without any issue but neither the GPU is used nor is it acknowledged by the system.

PS - sorry for any grammatical error or stupidity in the question.

Erm… that might sound stupid, but: what makes you sure that you have a NVIDIA card at all? I mean, after all, there is an Intel GPU reported. That will never change, no matter what kind of other drivers you install for NVIDIA: there is a physically Intel GPU in your computer!

The only thing that comes to my mind is that you might have a NVIDIA Optimus system: in such systems you have an Intel and a NVIDIA chip installed. The Intel one does the normal rendering, the NVIDIA GPU only does the heavy lifting of games and so on.
There the above mentioned output will however still produce the above mentioned output - since the Intel card does not go away. However there is the way to offload apps towards the NVIDIA GPU. There is a howto on rpmfusion explaining this.

@liquidat
My laptop has sticker of Nvidia GPU, and my dual booted Windows 10 shows the Nvidia GPU and I have installed Nvidia Drivers on other distros which I had on this laptop (Like Ubuntu and Manjaro) and they all recognised my GPU. So… I am pretty sure it’s there. :joy::joy:. (No offense dude)

Also, I do have the Nvidia Optimus system and I tried installing the Nvidia Drivers both ways - from RPM fusion and Bumblebee project.
But it still didn’t help. The settings panel as well as other commands bear same output with Intel being my only GPU.

Thank you so much for putting in time to help me out though!!

My laptop has sticker of Nvidia GPU, and my dual booted Windows 10 shows the Nvidia GPU and I have installed Nvidia Drivers on other distros which I had on this laptop (Like Ubuntu and Manjaro) and they all recognised my GPU. So… I am pretty sure it’s there. :joy::joy:. (No offense dude)

Ok, yes, it definitely sounds like you have a NVIDIA GPU :joy: :joy: Just wanted to be sure :wink:

So, checklist what I would do:

  • Verify in bios that nvidia gpu is actually turned on, that means optimus is turned on and not set to integrated graphics card only - though I assume if Windows can see it, it is configured properly in bios…
  • Check if secure boot is enabled - this would block the nvidia driver from loading if I am not mistaken
  • Make sure that you do not run Rawhide Fedora, but a released versioin (Rawhide has Kernel GPL only afaik)
  • Make sure you are not running Wayland, you need to run xorg
  • Check dmesg for anything relevant
1 Like

Found the answer by making Nvidia my primary GPU. Thank You for your help!

@sysoni Glad that you could solve this. Would you mind marking your answer as the official solution for others who might have the same problem?

1 Like

Hi @sysoni, you might want to follow this tutorial. [Optimus] Setting the NVIDIA GPU as primary (RPMFusion in Fedora 32 Workstation)

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.