My system updated after reboot .... but I have no idea what was actually updated

Today it happened something I never experienced before.

In general to update my system I issue sudno dnf upgrade, I see the proposed updates and then I confirm them.

Today when I shut down my PC, it asked if I wanted to install updates and I answered “Yes”. I do not remember the exact message. Later on I booted my PC and after boot a screen appeared “Installing updates”. When it arrived to 100% it shut down. It did not reboot, just shut down. Then I booted it up again and now it works.

How can I know which updates were installed?

I have Fedora Workstation 34

dnf history
2 Likes

No it doesn’t work.

With dnf history this is the only relevant element:

ID     | Command line              | Date and time    | Action(s)      | Altered
--------------------------------------------------------------------------------
    72 |                           | 2021-06-12 20:30 | Upgrade        |   47 

All other entries refer to days in the past.

It only says that 47 (47 what?) were altered.

It doesn’t specify which alterations were made.

Thanks

From there you can do

dnf history info 72
2 Likes

Thank you very much. Your help has been invaluable :slight_smile:

Why it required a reboot? When I issue dnf upgrade it doesn’t require a reboot.

I mean, it may update the kernel but I can continue to work with the old kernel.

It’s the first time it updates at reboot

1 Like

I noted with Fedora 33 that packagekit began the automatic update with a shutdown. You see a checkbox in the last power off window that says to update on shutdown. I suspect 34 continues that horrendous practice which reminds me of microsoft. Some may appreciate it but as you found it hides what is done until you search for it, and does not allow an informed approval, only an after-the-fact review. It can easily break a system when your hardware or software needs a little tlc during updates.

The autoupdates can be halted by following the steps at fedora-31-disable-autoupdate

If you think it’s package kit you can check
pkcon get-transactions

https://www.mankier.com/1/pkcon

1 Like

I followed the steps in your linked post to try to disable automatic updates, and this is the result I obtained from the terminal:

Created symlink /etc/systemd/system/packagekit.service → /dev/null.
Unit packgekit-offline-update.service does not exist, proceeding anyway.
Created symlink /etc/systemd/system/packgekit-offline-update.service → /dev/null.

Is it fine? It says one of the services dies not exist.

I executed the scripts you linked in your post, namely:

sudo systemctl stop packagekit.service

sudo systemctl disable packagekit.service

sudo systemctl mask packagekit.service

sudo systemctl stop packagekit-offline-update.service

sudo systemctl disable packagekit-offline-update.service

sudo systemctl mask packgekit-offline-update.service

I have Fedora 34 Workstation

It should have no negative effects. The link was to a generic method of making sure the automatic updates were disabled and did not happen at shutdown. I have seen nothing from that and as far as I can see the only issue was that the packagekit-offline-update was not installed when the command was run so it gave you the warning but caused no harm.

1 Like