Nautilus doesn't open in Fedora 37

Yeah, I think it’s related to tracker too. FWIW I had Files work again then sorta unexpectedly become unresponsive to me and Logs showed me this:

no nautilus plugins installed here either.

UPDATE: I just noticed the not responding prompt on a nightly build of Files as well when tracker3.Miner.Files starts happening, but the difference is that it managed to recover on its own unlike the rev. bundled with F37

Not sure if this matters, but this is also happening on a recently upgraded Fedora Silverblue instance as well.

I can get Files to open once, then it won’t again with no real error on the screen.

Is there any way to open Nautalis from the Terminal to see if I can get errors?

I have a very similar set of possibly Tracker related bugs:

  1. nautilus doesn’t open or the moment I search a file it hangs forever
  2. search in GNOME activity stops providing results for files after around 15s after user login
  3. shutdown process is blocked for 1m30s by trying to stop tracker-extract-3 and/or tracker-miners-fs-3

I was unaware of this forum post. Thanks to IRC and Telegram friends I was able to determine it probably was, at least for me, a bug related to Tracker:

running

tracker3 reset --filesystem

Solved temporarily the issues 1 and 2, but shutdown still waits for a minute and a half. At next boot, the problems are still there.

When the above bugs occur

tracker3 status

never provides results.

I filed a bug report yesterday, feel free to add information.

https://bugzilla.redhat.com/show_bug.cgi?id=2143580

2 Likes

You should be able to run nautilus from shell by issuing “nautilus” plus a folder location. For example,

nautilus .

opens the folder you are currently in the terminal. If nautilus is freezed, however, this should not respond. I fixed it by first killing nautilus with

killall nautilus -9

then running as I described above

tracker3 reset --filesystem

Does this work for you?

Does this work for you?

It seems that me running killall nautilus has made it so I can reopen it from the GNOME menu consistently now. If it starts acting up again, I’ll try the tracker3 command.

Same issue here, just upgraded to Fedora 37 today.
Kernel: 6.0.8-300.fc37.x86_64
I have some NFS network mounting points configured in /etc/fstab using x-systemd.automount:

m4nas:/srv/exports	/media/m4nas	nfs	noauto,x-systemd.automount,x-systemd.device-timeout=10,retry=5,x-systemd.idle-timeout=300       0	0

First attempt to launch nautilus from the teminal gave me this before crashing:

❯ G_MESSAGES_DEBUG=all nautilus
(org.gnome.Nautilus:9265): GLib-GIO-DEBUG: 13:29:19.805: Using cross-namespace EXTERNAL authentication (this will deadlock if server is GDBus < 2.73.3)
(org.gnome.Nautilus:9265): GLib-GIO-DEBUG: 13:29:19.807: _g_io_module_get_default: Found default implementation gvfs (GDaemonVfs) for ?gio-vfs?
(org.gnome.Nautilus:9265): Tracker-DEBUG: 13:29:19.810: Loading ontologies from database.
(org.gnome.Nautilus:9265): Tracker-DEBUG: 13:29:19.811: Applying ontologies from /usr/share/nautilus/ontology to existing database
(org.gnome.Nautilus:9265): Tracker-DEBUG: 13:29:19.811: Current and DB locales match: 'C'
** (org.gnome.Nautilus:9265): DEBUG: 13:29:19.812: *** Cancel Results Meta requests
Failed to register: Timeout was reached

Then I deleted ~/.cache/tracker3 and try again, nautilus would hang indefinitely, at a different step:

❯ G_MESSAGES_DEBUG=all nautilus
(org.gnome.Nautilus:10423): GLib-GIO-DEBUG: 13:35:26.481: Using cross-namespace EXTERNAL authentication (this will deadlock if server is GDBus < 2.73.3)
(org.gnome.Nautilus:10423): GLib-GIO-DEBUG: 13:35:26.483: _g_io_module_get_default: Found default implementation gvfs (GDaemonVfs) for ?gio-vfs?
(org.gnome.Nautilus:10423): Tracker-DEBUG: 13:35:26.487: Loading ontologies from database.
(org.gnome.Nautilus:10423): Tracker-DEBUG: 13:35:26.488: Applying ontologies from /usr/share/nautilus/ontology to existing database
(org.gnome.Nautilus:10423): Tracker-DEBUG: 13:35:26.488: Current and DB locales match: 'C'
(org.gnome.Nautilus:10423): GLib-GIO-DEBUG: 13:35:26.504: _g_io_module_get_default: Found default implementation dconf (DConfSettingsBackend) for ‘gsettings-backend’
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.504: watch_fast: "/org/gnome/desktop/interface/" (establishing: 0, active: 0)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.504: watch_fast: "/org/gnome/desktop/peripherals/mouse/" (establishing: 0, active: 0)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.504: watch_fast: "/org/gnome/desktop/sound/" (establishing: 0, active: 0)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.504: watch_fast: "/org/gnome/desktop/privacy/" (establishing: 0, active: 0)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.504: watch_fast: "/org/gnome/desktop/wm/preferences/" (establishing: 0, active: 0)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.504: watch_fast: "/org/gnome/settings-daemon/plugins/xsettings/" (establishing: 0, active: 0)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.504: watch_fast: "/org/gnome/desktop/a11y/" (establishing: 0, active: 0)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.504: watch_fast: "/org/gnome/desktop/a11y/interface/" (establishing: 0, active: 0)
(org.gnome.Nautilus:10423): GLib-GIO-DEBUG: 13:35:26.505: Using cross-namespace EXTERNAL authentication (this will deadlock if server is GDBus < 2.73.3)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.506: watch_established: "/org/gnome/desktop/interface/" (establishing: 1)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.506: watch_established: "/org/gnome/desktop/peripherals/mouse/" (establishing: 1)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.506: watch_established: "/org/gnome/desktop/sound/" (establishing: 1)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.506: watch_established: "/org/gnome/desktop/privacy/" (establishing: 1)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.506: watch_established: "/org/gnome/desktop/wm/preferences/" (establishing: 1)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.506: watch_established: "/org/gnome/settings-daemon/plugins/xsettings/" (establishing: 1)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.506: watch_established: "/org/gnome/desktop/a11y/" (establishing: 1)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.506: watch_established: "/org/gnome/desktop/a11y/interface/" (establishing: 1)
(org.gnome.Nautilus:10423): Gtk-DEBUG: 13:35:26.507: Connecting to session manager
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.548: watch_fast: "/org/gnome/nautilus/preferences/" (establishing: 0, active: 0)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.548: watch_fast: "/org/gnome/nautilus/compression/" (establishing: 0, active: 0)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.548: watch_fast: "/org/gnome/nautilus/window-state/" (establishing: 0, active: 0)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.548: watch_fast: "/org/gnome/nautilus/icon-view/" (establishing: 0, active: 0)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.548: watch_fast: "/org/gnome/nautilus/list-view/" (establishing: 0, active: 0)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.548: watch_fast: "/org/gtk/settings/file-chooser/" (establishing: 0, active: 0)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.548: watch_fast: "/org/gnome/desktop/lockdown/" (establishing: 0, active: 0)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.548: watch_fast: "/org/gnome/desktop/interface/" (establishing: 0, active: 1)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.548: watch_fast: "/org/gnome/desktop/privacy/" (establishing: 0, active: 1)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.549: watch_established: "/org/gnome/nautilus/preferences/" (establishing: 1)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.549: watch_established: "/org/gnome/nautilus/compression/" (establishing: 1)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.549: watch_established: "/org/gnome/nautilus/window-state/" (establishing: 1)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.549: watch_established: "/org/gnome/nautilus/icon-view/" (establishing: 1)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.549: watch_established: "/org/gnome/nautilus/list-view/" (establishing: 1)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.549: watch_established: "/org/gtk/settings/file-chooser/" (establishing: 1)
(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.549: watch_established: "/org/gnome/desktop/lockdown/" (establishing: 1)
(org.gnome.Nautilus:10423): seahorse-nautilus-DEBUG: 13:35:26.550: seahorse nautilus module initialized

(org.gnome.Nautilus:10423): dconf-DEBUG: 13:35:26.550: watch_fast: "/org/gnome/desktop/lockdown/" (establishing: 0, active: 1)
(org.gnome.Nautilus:10423): GLib-DEBUG: 13:35:26.573: setenv()/putenv() are not thread-safe and should not be used after threads are created
/usr/lib64/python3.11/site-packages/gi/module.py:168: Warning: g_boxed_type_register_static: assertion 'g_type_from_name (name) == 0' failed
  g_type = info.get_g_type()
/usr/lib64/python3.11/site-packages/gi/module.py:168: Warning: g_once_init_leave: assertion 'result != 0' failed
  g_type = info.get_g_type()
/usr/lib64/python3.11/site-packages/gi/module.py:203: Warning: g_type_get_qdata: assertion 'node != NULL' failed
  type_ = g_type.pytype
1 Like

I invite you to add all information you gathered, logs included, into the following bug tracker I mentioned before

Component tracker3 stops working in nautilus and in GNOME activity

Moreover, does resetting tracker3 act as a temporary fix for you?

Hello @sgob, I tried to run tracker3 reset --filesystem but this did not help. Not even temporarily. I have submitted my previous post on the bug track, as per your recommendation.

Thank you very much.

I come up with a (possible) solution or workaround.

Today I launched a sway session, and in there tracker3 was working very well with nautilus.

Issuing command tracker3 status in the sway session, unexpectedly, instead of freezing it reported that there were some files that caused errors. In particular, they were some .png files and some .cue files. Removing them from my disk has solved the issue: now nautilus works as expected and also the activity bug disappeared and the shutdown is regular as usual.

I currently have no time to reproduce it: tomorrow I will try to load those files again in my disk, and try to reproduce the bug, and report both files and behavior in the bug report.

I solved it by issuing tracker3 status on Sway, but it could also work on a TTY you open before logging in into GNOME. Still, I am not sure whether you will be able to solve it like I did, or in a TTY, because I could just have been lucky.

Under Gnome Wayland, the command tracker3 status works normally, and lists some errors, all image files (jpeg and png). The error states “Could not get any metadata for uri:…”. The images appear to be corrupted, I cannot open them from the terminal (using display). After I remove the images, tracker3 returns no error:

❯ tracker3 status
Currently indexed: 9551 files, 348 folders
Remaining space on database partition: 336.6 GB (33.71%)
All data miners are idle, indexing complete

Still after that, nautilus won’t start.

I finally got nautilus working !
I found this post on reddit suggesting to remove nautilus-python. I did, using sudo dnf remove nautilus-python and after a reboot nautilus stared to work again normally.

2 Likes

The package nautilus-python is not installed and the issue is still present.

The command tracker3 status is never ending. Nothing is printed out in the console. Just a blinking cursor without messages.

1 Like