Necesito ayuda para la instalación de firefox olpc xo 1.5

Buenos días, somos del país de Perú, tenemos un problema en la escuela, en 2010 nos dieron la computadora portátil olpc xo 1.5, pero hoy en día queremos usar el navegador, pero las páginas web modernas funcionan muy bien, actualizamos el sistema operativo. sistema a fedora 18 pero no encontramos el RPM compatible con esta versión, necesitamos ayuda para enseñar clases virtuales a niños, ellos pueden ayudarnos
Muchísimas gracias por todo

Leyendo la documentación, tienes una versión muy vieja y ya no tiene soporte, la ultima fue hecha con Fedora 18 (ya sin soporte) es 13.2.10. Imagino eso es lo que tienes. Yo recomendaria instalar Sugar desde un Fedora 30. O mi preferido DoudouLinux.

1 Like

Hola davidva, gracias por contestarme, si yo quise a otro distribución pero el problema es la capacidad de la olpc xo 1.5, ram 0.5 GB y almacenamiento es 4GB, otro restricción es el driver de wifi, que no funcionan bien en otras distribuciones, no necesito un navegador moderno, instale un navegador light de mozilla la versión light-38.0.en-US.linux-i686_r2.rpm, la instalación de realiza de forma correcta, pero al momento de ejecutar sale el siguiente error “Falló al ejecutar el proceso hijo <>(no existe el fichero o el directorio)”, alguna ayuda por favor.

512 de RAM? rayos! Entonces un Debian es necesario, te recomiendo antiX; recordando que Fedora dejara la plataforma de 32 bits en Fedora 31; y Ubuntu va por el mismo camino. Y desde allí instalar Sugar en antiX.

1 Like

Gracias davidva por echarme una mano, Instale un navegador light de mozilla la versión light-38.0.en-US.linux-i686_r2.rpm, la instalación de realiza de forma correcta, pero al momento de ejecutar sale el siguiente error “Falló al ejecutar el proceso hijo <>(no existe el fichero o el directorio)”
estere muy agradecido por tu respuesta.

Obviamente es difícil resolver dependencias cuando se crea un paquete en diferente sistema. Este es el caso, te pongo un ejemplo; cuando compilas un ffmpeg en Fedora 28; no hay garantía que funcione ese mismo ffmpeg en Fedora 30, ¿porque? porque cuando se construyo en Fedora 28 fue compilado con diferentes dependencias, estas dependencias podrían no existir donde se quiere instalar dicho paquete. Desde una terminal abre firefox desde alli y copia/pega todo el resultado en fpaste y comparte. Quizas así podamos todos ayudar.

1 Like

el programa que instale aparece en el menú de aplicaciones, con el “Light”, pero cuando lo ejecuto desde el terminal escribiendo light o sh light , aparece esto: “no se encontró la orden”, gracias por la ayuda basica.

Puedes de alguna forma extraer el tarball de firefox y ejecutarlo?

1 Like

probe el archivo binario descomprimido pero no funcion
[olpc@dhcppc28 firefox-68.0.1esr]$ sh firefox
firefox: firefox: no se puede ejecutar el fichero binario
creo que soy nuevo en fedora, gracia

0) sudo yum install bzip2
1) wget https://ftp.mozilla.org/pub/firefox/releases/68.0.1esr/linux-i686/es-CL/firefox-68.0.1esr.tar.bz2
2) tar xjfv firefox-68.0.1esr.tar.bz2 -C $HOME
3) pushd $HOME/firefox
4) ./firefox

1 Like

hola,realice lo siguiente

  1. descomprimí el archivo

  2. ubique el directorio de la descompresión
    [olpc@dhcppc28 firefox-68.0.1esr]$ pushd /home/olpc/Documentos/firefox-68.0.1esr
    ~/Documentos/firefox-68.0.1esr ~/Documentos/firefox-68.0.1esr

  3. trate de ejecutar el archivo firefox
    [olpc@dhcppc28 firefox-68.0.1esr]$ sudo ./firefox
    sudo: ./firefox: command not found

Gracias

  1. Aquí no necesitas sudo!
    ls
    ./firefox
1 Like

probe lo enviado
[olpc@dhcppc28 ~] cd '/home/olpc/Documentos/firefox-68.0.1esr' [olpc@dhcppc28 firefox-68.0.1esr] ls
application.ini gmp-clearkey libnss3.so omni.ja
browser gtk2 libnssckbi.so pingsender
chrome.manifest icons libnssdbm3.so platform.ini
crashreporter libfreeblpriv3.so libnssutil3.so plugin-container
crashreporter.ini liblgpllibs.so libplc4.so plugin-container.sig
defaults libmozavcodec.so libplds4.so precomplete
dependentlibs.list libmozavutil.so libsmime3.so removed-files
firefox libmozgtk.so libsoftokn3.so Throbber-small.gif
firefox-bin libmozsandbox.so libssl3.so updater
firefox-bin.sig libmozsqlite3.so libxul.so updater.ini
firefox.sig libmozwayland.so libxul.so.sig update-settings.ini
fonts libnspr4.so minidump-analyzer
[olpc@dhcppc28 firefox-68.0.1esr]$ ./firefox
bash: ./firefox: Permiso denegado

pero sale acceso denegado, quiero pegarlo en fpaste, pero no diferencia los colores

ls
chmod a+x firefox
./firefox
1 Like

1) [olpc@xo-5b-0e-56 firefox-68.0.1esr]$ chmod a+x firefox

2) [olpc@xo-5b-0e-56 firefox-68.0.1esr]$ ./firefox

  Exec failed with error: Permission denied

gracias por las respuestas

Intenta dar permisos de ejecución utilizando “su”

1 Like

1) [olpc@xo-5b-0e-56 ~]$ su
2) bash-4.2# cd /home/olpc/Documentos/firefox-68.0.1esr
bash-4.2# ls
application.ini gmp-clearkey libnss3.so omni.ja
browser gtk2 libnssckbi.so pingsender
chrome.manifest icons libnssdbm3.so platform.ini
crashreporter libfreeblpriv3.so libnssutil3.so plugin-container
crashreporter.ini liblgpllibs.so libplc4.so plugin-container.sig
defaults libmozavcodec.so libplds4.so precomplete
dependentlibs.list libmozavutil.so libsmime3.so removed-files
firefox libmozgtk.so libsoftokn3.so Throbber-small.gif
firefox-bin libmozsandbox.so libssl3.so updater
firefox-bin.sig libmozsqlite3.so libxul.so updater.ini
firefox.sig libmozwayland.so libxul.so.sig update-settings.ini
fonts libnspr4.so minidump-analyzer
3) bash-4.2# chmod a+x firefox
4) bash-4.2# ./firefox
Exec failed with error: Permission denied
Salio el mismo resultado.

ls
su
chmod 4755 $PWD/firefox
ls -l $PWD/firefox
exit
$PWD/firefox

1 Like

[olpc@dhcppc28 firefox-68.0.1esr]$ su
bash-4.2# chmod 4755 $PWD/firefox
bash-4.2# ls -l $PWD/firefox

-rwsr-xr-x 1 olpc olpc 13988 jul 17 21:30 /home/olpc/Documentos/firefox-68.0.1esr/firefox
bash-4.2# exit
exit
[olpc@dhcppc28 firefox-68.0.1esr]$ $PWD/firefox
Exec failed with error: Permission denied

no puede ser sale lo mismo gracias

Creo que mas de aquí, no encuentro la manera de poder ayudarde; creo que es algo de permisos ya usuario definidos. Lo único que puedo recomendarte es instalar un linux super ligero como antiX y darle vida a esta maquinita nuevamente.

1 Like