Network Manager not restarting when connection goes down

Hey guys!

So, i was using Fedora Worksation with GNOME, but i was having problem with GNOME + Nvidia so i switched to KDE. Since then, every time my internet connection goes down(even for a short period of time), i have to reboot my system or restart Network Manager service, like this:

$ systemctl restart NetworkManager.service

Anyone know if that is normal? Network Manager shouldn’t be doing this alone?

Ty for the attention!

It’s definitely not normal.

I’d try to see what’s going on (and what NM thinks is going on) before restarting service.

You can view information about your connections in GUI or in terminal:

nmcli device status

– will show you brief overview of all network devices/connections, check STATE for network device you use, does it say connected or not.

Also it can be useful to look at the ip a output:

$ ip a
1: enp7s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
link/ether AA:BB:CC:DD:EE:FF brd ff:ff:ff:ff:ff:ff
inet 192.168.0.222/24 brd 192.168.0.255 scope global noprefixroute enp7s0
valid_lft forever preferred_lft forever

Things to note here:
enp7s0 – is the name of network device I’m using
state UP – should mean the connection is UP (if I’m not mistaken)
inet 192.168.0.222/24 – is the current IP of you computer on this device/connection. If you don’t have an IP assigned – then you’re in some kind of trouble. )

Also check

nmcli connection

– to get name of your connection (and optionally UUID)

and try to restart your connection (without restarting NM service):

nmcli connection down <name_of_the_connection>
nmcli connection up <name_of_the_connection>

or

nmcli connection down uuid <UUID>
nmcli connection up uuid <UUID>

– if you want to use UUID.

If restarting connection manually does help, then check the properties of the connection, is “Connect automatically” checkbox on or off.

Run ‘nm-connection-editor’ in terminal and check connection – general – connect automatically checkbox is tick or not

Is ticked, but with the value -999. This -999 value is correct?

That value is the priority level with respect to other network connections, where I believe a larger number means a higher priority. Do you have other (perhaps not properly configured) connections that have a higher priority?

When there is an issue, take a look with ifconfig to see if you have an IP and to check the state of any connections.