New to Fedora (35), no headphones ouput sound

HI,

I feel like I have to open another of the many sound issue threads, but none of the solutions work, and I don’t want to resort to reverting to older Fedora choices like pipewire-media-session or even PulseAudio. As it’s a fresh install, it should “just work”.

I was previously using ArchLinux (and PulseAudio), so I know the hardware is not in cause. When migrating, I didn’t move my my old config files, so my session would start with sane defaults.

My issue looks similar to No sound on hedphones in fedora 34 but the conversation stopped.

As from reading all those threads, I can already tell wireplumber and its pipewire friends are active and running. The only warning in logs is:

mai 05 09:53:33 artos wireplumber[2815]: Failed to set scheduler settings: Operation not permitted

which seems to be caused by a io renice call. It doesn’t prevent sound from working, I’m listening to music as I’m writing this. Only when the headphones jack is plugged, the built-in speaker is muted as excepted, but no sound is coming from the headphones. I could push all the levels to the maximum, I wouldn’t even hear hiss.

Yet Gnome sound settings are showing the correct output device, and the VU meter is bouncing with the music:

Capture d’écran de 2022-05-05 12-11-54

I tried with my phone headphones, with a bult-in mic, I don’t have sound either, but the mic is functional, as I can see the VU meter following my voice.

I also tried alsamixer but the headphones channel is at 100, and nothing seems muted.

That’s where I’m puzzled.

now for the boring part

$ systemctl --user status wireplumber

● wireplumber.service - Multimedia Service Session Manager
     Loaded: loaded (/usr/lib/systemd/user/wireplumber.service; enabled; vendor preset: enabled)
     Active: active (running) since Thu 2022-05-05 09:53:33 CEST; 1h 43min ago
   Main PID: 2815 (wireplumber)
      Tasks: 4 (limit: 18978)
     Memory: 16.1M
        CPU: 2.822s
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/wireplumber.service
             └─2815 /usr/bin/wireplumber

mai 05 09:53:33 artos systemd[2484]: Started Multimedia Service Session Manager.
mai 05 09:53:33 artos wireplumber[2815]: Failed to set scheduler settings: Op?ration non permise

$ systemctl --user status pulseaudio

Unit pulseaudio.service could not be found.

$ systemctl --user status “pipewire.*”

● pipewire.socket - PipeWire Multimedia System Socket
     Loaded: loaded (/usr/lib/systemd/user/pipewire.socket; enabled; vendor preset: enabled)
     Active: active (running) since Thu 2022-05-05 09:53:31 CEST; 1h 43min ago
   Triggers: ● pipewire.service
     Listen: /run/user/1000/pipewire-0 (Stream)
     CGroup: /user.slice/user-1000.slice/user@1000.service/app.slice/pipewire.socket

mai 05 09:53:31 artos systemd[2484]: Listening on PipeWire Multimedia System Socket.

● pipewire.service - PipeWire Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; disabled; vendor preset: disabled)
    Drop-In: /usr/lib/systemd/user/pipewire.service.d
             └─00-uresourced.conf
     Active: active (running) since Thu 2022-05-05 09:53:33 CEST; 1h 43min ago
TriggeredBy: ● pipewire.socket
   Main PID: 2814 (pipewire)
      Tasks: 2 (limit: 18978)
     Memory: 11.0M
        CPU: 1min 40.548s
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
             └─2814 /usr/bin/pipewire

mai 05 09:53:33 artos systemd[2484]: Started PipeWire Multimedia Service.

$ systemctl --user status “pipewire-pulse.*”

● pipewire-pulse.socket - PipeWire PulseAudio
     Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.socket; enabled; vendor preset: enabled)
     Active: active (running) since Thu 2022-05-05 09:53:31 CEST; 1h 43min ago
   Triggers: ● pipewire-pulse.service
     Listen: /run/user/1000/pulse/native (Stream)
     CGroup: /user.slice/user-1000.slice/user@1000.service/app.slice/pipewire-pulse.socket

mai 05 09:53:31 artos systemd[2484]: Listening on PipeWire PulseAudio.

● pipewire-pulse.service - PipeWire PulseAudio
     Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.service; disabled; vendor preset: disabled)
     Active: active (running) since Thu 2022-05-05 09:53:33 CEST; 1h 43min ago
TriggeredBy: ● pipewire-pulse.socket
   Main PID: 2816 (pipewire-pulse)
      Tasks: 2 (limit: 18978)
     Memory: 27.2M
        CPU: 5min 16.033s
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire-pulse.service
             └─2816 /usr/bin/pipewire-pulse

mai 05 09:53:33 artos systemd[2484]: Started PipeWire PulseAudio.
mai 05 09:53:33 artos pipewire-pulse[2839]: 536870912

$ rpm -qa pipewire* pulseaudio* wireplumber

pulseaudio-libs-15.0-2.fc35.x86_64
pulseaudio-libs-glib2-15.0-2.fc35.x86_64
pipewire-0.3.51-1.fc35.x86_64
pipewire-libs-0.3.51-1.fc35.x86_64
pipewire-gstreamer-0.3.51-1.fc35.x86_64
pipewire-jack-audio-connection-kit-0.3.51-1.fc35.x86_64
pipewire-alsa-0.3.51-1.fc35.x86_64
pipewire-utils-0.3.51-1.fc35.x86_64
wireplumber-0.4.9-1.fc35.x86_64
pulseaudio-utils-15.0-2.fc35.x86_64
pipewire-pulseaudio-0.3.51-1.fc35.x86_64

I installed pulseaudio-utils because there was an error about pactl not found in the pipewire-pulse logs.

Thanks in advance for any help.

1 Like

Welcome to ask.:fedora:edora @oursique

To get a overview of your system, please also give us more info’s as :

inxi -Fzx in terminal and post the output as </> Preformatted text here.

Was it with Arch always this way?

Did you try what @jasonmccallister proposed?

Thanks for the reply.

I wanted to mean my sound hardware has nothing exotic (Intel integrated). On the old 4.19 kernel I was stuck to, I never had any sound issue. I had others that got me to stick to that 4.19 kernel, but not sound-related.

Jason’s suggestion doesn’t apply to me, I only have built-in audio on this laptop, and the headphones jack plug. Everything seems to work fine, headphones plugging in is recognized (Gnome shows a popup to ask whether it’s headphones only or it includes a mic), and audio output is switching to it as expected, just no sound is heard.

In the meantime, I tried wireless headphones (with a USB dongle, not Bluetooth), I had to manually switch in the Gnome sound settings, but I could hear the music fine.

Inxi output
$ inxi -Fzx
System:
  Kernel: 5.17.5-200.fc35.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-10.fc35 Desktop: GNOME v: 41.4
    Distro: Fedora release 35 (Thirty Five)
Machine:
  Type: Convertible System: ASUSTeK product: UX370UAR v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: UX370UAR v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: UX370UAR.311 date: 10/15/2019
Battery:
  ID-1: BAT0 charge: 24.2 Wh (100.0%) condition: 24.2/39.0 Wh (61.9%)
    volts: 7.7 min: 7.7 model: ASUSTeK ASUS Battery status: discharging
  Device-1: hid-0018:04F3:24CC.0002-battery model: ELAN24CC:00 04F3:24CC
    charge: N/A status: N/A
CPU:
  Info: quad core model: Intel Core i7-8550U bits: 64 type: MT MCP
    arch: Coffee Lake rev: A cache: L1: 256 KiB L2: 1024 KiB L3: 8 MiB
  Speed (MHz): avg: 856 high: 1007 min/max: 400/4000 cores: 1: 800 2: 800
    3: 795 4: 898 5: 893 6: 855 7: 803 8: 1007 bogomips: 31999
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: ASUSTeK driver: i915 v: kernel
    bus-ID: 00:02.0
  Device-2: IMC Networks USB2.0 VGA UVC WebCam type: USB driver: uvcvideo
    bus-ID: 1-5:3
  Display: wayland server: X.Org v: 1.21.1.4 with: Xwayland v: 21.1.4
    compositor: gnome-shell driver: gpu: i915 resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2)
    v: 4.6 Mesa 21.3.8 direct render: Yes
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
  Sound Server-1: ALSA v: k5.17.5-200.fc35.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
  Device-1: Intel Wireless 8260 driver: iwlwifi v: kernel bus-ID: 01:00.0
  IF: wlp1s0 state: up mac: <filter>
  IF-ID-1: br-d544814c2ae8 state: up speed: 10000 Mbps duplex: unknown
    mac: <filter>
  IF-ID-2: docker0 state: down mac: <filter>
  IF-ID-3: veth049e7cc state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-4: veth16fe536 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-5: veth3b5e577 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-6: veth45a5386 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-7: veth4a2daff state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-8: veth74698d8 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-9: veth8a495af state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-10: vetha050c2d state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-11: vethabf6807 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-12: vethb3ed2fe state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-13: vethc5a35c0 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-14: vethe2d7cf6 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-15: vethedf668b state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-16: vethf4f8d95 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-8:4
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
Drives:
  Local Storage: total: 5.01 TiB used: 570.33 GiB (11.1%)
  ID-1: /dev/sda vendor: SanDisk model: SD8SN8U512G1002 size: 476.94 GiB
  ID-2: /dev/sdb type: USB vendor: Western Digital model: WD Elements 2620
    size: 4.55 TiB
Partition:
  ID-1: / size: 475.34 GiB used: 272.31 GiB (57.3%) fs: btrfs dev: /dev/dm-0
    mapped: luks-744d1987-0031-4f92-8da7-98cb24459570
  ID-2: /boot size: 973.4 MiB used: 252.7 MiB (26.0%) fs: ext4
    dev: /dev/sda2
  ID-3: /boot/efi size: 598.8 MiB used: 13.8 MiB (2.3%) fs: vfat
    dev: /dev/sda1
  ID-4: /home size: 475.34 GiB used: 272.31 GiB (57.3%) fs: btrfs
    dev: /dev/dm-0 mapped: luks-744d1987-0031-4f92-8da7-98cb24459570
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 328.5 MiB (4.0%) dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 50.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 446 Uptime: 4h 25m Memory: 15.49 GiB used: 7.8 GiB (50.4%)
  Init: systemd runlevel: 5 Compilers: gcc: 11.3.1 Packages: N/A
  note: see --pkg Shell: Zsh v: 5.8.1 inxi: 3.3.14

can you open ‘alsamixer’ and select with F6 your intel PCH card (of course plug in headphones )


After that you will have something like this

Can you screenshot of that settings of alsamixer that we can see what is going on

Hi,

Pressing F6 shows the same integrated sound card as yours:

Before the headphones are plugged in:

After the headphones are plugged in:

Comparing with your screenshot, I already tried pushing all those channels to 100.

What I see is the expected behaviour of the Speaker channel being muted and the Headphones channel to 100 when I plug the headphones, and vice-versa when I unplug.

Out of curiosity, I tried swapping to pipewire-media-session, rebooted, but I got the exact same behaviour. Everything seems detected as expected, but not the slightest hiss coming from the headphones.

I had a similar problem in Arch Linux. I finally fixed it by running pavucontrol, going to the Configuration tab, and (oddly) setting both of my system’s sound cards to “Off”. Then, when my FiiO Q5s DAC is turned on, the Configuration adds it and sets it to “Pro Audio”, and my headphones work.

I have no idea whether your hardware is analogous to mine, but I hope this can help you.

Thanks, I gave it a try, but I couldn’t reproduce your success.

Update to F36 didn’t fix it.

I swapped to pulseaudio but I got the same behaviour, so I undid the changes to restore wireplumber.

Should I report my issue upstream? Is it rather a pipewire or wireplumber bug?

I guess it’s hard to say what component to log an issue against at this stage as it seems uncertain what is responsible. It’s interesting that the gnome sound panel is showing as if audio is being output.

Does
wpctl status show the built in sound card under “sinks” and the relevant playback happening under “streams”?