New User/New Install/New Laptop issues

So last month I obtained a new low budget laptop (HP Pavilion) and promptly decided to remove the OS that came pre-installed after downloading and burning a few popular distros to USB. With each and every distro I’ve attempted to install it appears that after installation it takes some time, usually >10 seconds to be able to log in using my passcode. Additionally, after various amounts of time the Desktop Environments stop functioning. This leads me to believe it probably is more a result of the HP hardware and or the Intel Hardware assembled within the system. Another issue appears to be within the BIOS that seems to be “locked down” by the vendor and I am very limited as to those parameters that can be changed.

With all that said, is there a way that I can in fact verify that it is indeed a vendor issue and what commands can I use to identify the causes of these issues?

2 Likes

Log in to a text TTY with Alt+Ctrl+F3 and perform full upgrade:

sudo dnf upgrade

In addition, try to update your BIOS/EFI firmware if possible.
If the problem persists, it’s likely related to hardware/drivers.

1 Like

Thank you for the response!

I tried the sudo dnf upgrade that you suggested but unfortunately I now get the following:

I get a black screen randomly and when I hit the power button I get a

Failed to unmount /home
Failed to unmount /boot/efi.
Failed to unmount /boot

1 Like

Output of sudo inxi -Faz and dmesg --level=err,warn should give us some useful information.

Any luck with that?

1 Like

The inxi command didn’t work and it appears I have to add another package to be able to run it.

The 2nd command gave me the following:

dmesg --level=err
[    0.255645] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PC00.TDGC], AE_NOT_FOUND (20200925/psargs-330)
[    0.255648] ACPI Error: Aborting method \_SB.PC00.PEG0.PC01._ON due to previous error (AE_NOT_FOUND) (20200925/psparse-529)
[    3.042687] ACPI BIOS Error (bug): Could not resolve symbol [\SAHT], AE_NOT_FOUND (20200925/psargs-330)
[    3.042692] ACPI Error: Aborting method \_SB.PC00.TCPU._TMP due to previous error (AE_NOT_FOUND) (20200925/psparse-529)

As far as the BIOS update, I have to go to my job where I can get access to a windows machine.

I truly appreciate all’s help and suggestions!

dnf install inxi

As for BIOS error, it should be fixed by laptop vendor, but unfortunately even in expensive business models sometimes they don’t care.

Results of inxi -Faz:

System: Kernel: 5.10.16-200.fc33.x86_64 x86_64 bits: 64 compiler: gcc v: 2.35-18.fc33)
parameters: BOOT_IMAGE=(hd0,gpt2)/vmlinuz-5.10.16-200.fc33.x86_64 root=UUID=c2f3197e-7585-4a9b-bdd7-98dc2eca83db ro
rootflags=subvol=root rhgb quiet
Console: tty 0 wm: gnome-shell DM: GDM 3.38.2.1 Distro: Fedora release 33 (Thirty Three)
Machine: Type: Laptop System: HP product: HP Pavilion Laptop 15t-eg000 v: Type1ProductConfigId serial: Chassis:
type: 10 serial:
Mobo: HP model: 87CB v: 34.26 serial: UEFI: Insyde v: F.05 date: 10/29/2020
Battery: ID-1: BAT0 charge: 42.1 Wh condition: 42.1/42.1 Wh (100%) volts: 12.9/11.3 model: HP Primary type: Li-ion
serial: status: Full cycles: 6
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse serial: charge: 55% (should be ignored)
rechargeable: yes status: Discharging
CPU: Info: Quad Core model: 11th Gen Intel Core i5-1135G7 socket: U3E1 bits: 64 type: MT MCP arch: Tiger Lake family: 6
model-id: 8C (140) stepping: 1 microcode: 66 L2 cache: 8192 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 38707
Speed: 1301 MHz min/max: 400/4200 MHz base/boost: 2400/4200 volts: 0.7 V ext-clock: 100 MHz Core speeds (MHz):
1: 1297 2: 1298 3: 1248 4: 1233 5: 1295 6: 1284 7: 1282 8: 1207
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics: Device-1: Intel TigerLake GT2 [Iris Xe Graphics] vendor: Hewlett-Packard driver: i915 v: kernel
bus ID: 0000:00:02.0 chip ID: 8086:9a49
Device-2: Luxvisions Innotech Limited HP Wide Vision HD Camera type: USB driver: uvcvideo bus ID: 3-3:3
chip ID: 30c9:000e
Display: server: Fedora Project X.org 1.20.10 compositor: gnome-shell driver: modesetting unloaded: fbdev,vesa
display ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3")
Monitor-1: XWAYLAND0 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") diag: 389mm (15.3")
OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 20.3.4 direct render: Yes
Audio: Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Hewlett-Packard driver: sof-audio-pci
alternate: snd_hda_intel,snd_sof_pci bus ID: 0000:00:1f.3 chip ID: 8086:a0c8
Sound Server: ALSA v: k5.10.16-200.fc33.x86_64
Network: Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel port: 3000 bus ID: 0000:00:14.3 chip ID: 8086:a0f0
IF: wlp0s20f3 state: up mac:
IF-ID-1: virbr0 state: down mac:
IF-ID-2: virbr0-nic state: down mac:
Drives: Local Storage: total: 465.76 GiB used: 6.65 GiB (1.4%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 980 PRO 500GB size: 465.76 GiB block size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 serial: rev: 1B2QGXA7 scheme: GPT
RAID: Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd v: 0.6 port: 3000 bus ID: 0000:00:0e.0
chip ID: 8086.9a0b rev: N/A
Partition: ID-1: / raw size: 464.17 GiB size: 464.17 GiB (100.00%) used: 6.42 GiB (1.4%) fs: btrfs block size: 4096 B
dev: /dev/nvme0n1p3
ID-2: /boot raw size: 1024.0 MiB size: 975.9 MiB (95.30%) used: 207.2 MiB (21.2%) fs: ext4 block size: 4096 B
dev: /dev/nvme0n1p2
ID-3: /home raw size: 464.17 GiB size: 464.17 GiB (100.00%) used: 6.42 GiB (1.4%) fs: btrfs block size: 4096 B
dev: /dev/nvme0n1p3
Swap: Kernel: swappiness: 60 (default) cache pressure: 100 (default)
ID-1: swap-1 type: zram size: 3.77 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors: System Temperatures: cpu: 39.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info: Processes: 288 Uptime: 1h 23m Memory: 7.54 GiB used: 1.60 GiB (21.2%) Init: systemd v: 246 runlevel: 5
target: graphical.target Compilers: gcc: 10.2.1 Packages: rpm: 1753 lib: 429 flatpak: 0 Shell: Bash (sudo)
v: 5.0.17 running in: gnome-terminal inxi: 3.1.08

1 Like

Upgraded BIOS but it appears that the latest updates don’t allow me to change from SATA to AHCI.

If RST is enabled it MUST be disabled before you can change the sata mode to AHCI.

1 Like