No bluetooth found // plug in dongle to use bluetooth

I just installed fedora 36 everything seems fine but bluetooth cannot be turned on .
And i cannot use bluetooth anymore which was working fine before in windows.
So please someone help me fix this issue

Welcome to ask.:fedora:edora @icetmzz

Fist of all i would propose you to read #start-here that you get an idea which kind of information we do need to be able to help you.

To start,
inxi -Fzx in terminal gives us an overview. Please post the output as </> Preformatted text here.

1 Like

Thank you for your response . Here’s the result

$ inxi -Fzx
System:
  Kernel: 5.18.7-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-27.fc36 Desktop: GNOME v: 42.2
    Distro: Fedora release 36 (Thirty Six)
Machine:
  Type: Laptop System: HP product: HP Laptop 15-da1xxx
    v: Type1ProductConfigId serial: <superuser required>
  Mobo: HP model: 8533 v: 70.31 serial: <superuser required> UEFI: Insyde
    v: F.22 date: 08/28/2019
Battery:
  ID-1: BAT1 charge: 37.6 Wh (98.7%) condition: 38.1/41.0 Wh (92.9%)
    volts: 12.2 min: 11.4 model: Hewlett-Packard PABAS0241231
    status: discharging
CPU:
  Info: quad core model: Intel Core i5-8265U bits: 64 type: MT MCP
    arch: Comet/Whiskey Lake note: check rev: C cache: L1: 256 KiB L2: 1024 KiB
    L3: 6 MiB
  Speed (MHz): avg: 607 high: 729 min/max: 400/3900 cores: 1: 500 2: 500
    3: 600 4: 620 5: 600 6: 612 7: 700 8: 729 bogomips: 28800
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620]
    vendor: Hewlett-Packard driver: i915 v: kernel arch: Gen9.5 bus-ID: 00:02.0
  Device-2: NVIDIA GM108M [GeForce MX110] vendor: Hewlett-Packard
    driver: nvidia v: 510.68.02 arch: Maxwell bus-ID: 01:00.0
  Device-3: Chicony HP TrueVision HD Camera type: USB driver: uvcvideo
    bus-ID: 1-5:2
  Display: wayland server: X.Org v: 1.22.1.2 with: Xwayland v: 22.1.2
    compositor: gnome-shell driver: gpu: i915 resolution: 1360x768~60Hz
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2)
    v: 4.6 Mesa 22.1.2 direct render: Yes
Audio:
  Device-1: Intel Cannon Point-LP High Definition Audio
    vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
  Sound Server-1: ALSA v: k5.18.7-200.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.52 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000 bus-ID: 02:00.0
  IF: eno1 state: down mac: <filter>
  Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
    vendor: Hewlett-Packard driver: rtw_8821ce v: N/A port: 3000
    bus-ID: 03:00.0
  IF: wlo1 state: up mac: <filter>
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
    v: 3.0 bus-ID: 00:17.0
Drives:
  Local Storage: total: 1.03 TiB used: 6.56 GiB (0.6%)
  ID-1: /dev/nvme0n1 vendor: Lenovo O.E.M. model: RPFTJ128PDD2EWX
    size: 119.24 GiB temp: 47.9 C
  ID-2: /dev/sda vendor: Western Digital model: WD10SPZX-60Z10T0
    size: 931.51 GiB
Partition:
  ID-1: / size: 117.66 GiB used: 6.3 GiB (5.4%) fs: btrfs dev: /dev/nvme0n1p3
  ID-2: /boot size: 973.4 MiB used: 259.2 MiB (26.6%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 14 MiB (2.3%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 117.66 GiB used: 6.3 GiB (5.4%) fs: btrfs
    dev: /dev/nvme0n1p3
Swap:
  ID-1: swap-1 type: zram size: 3.62 GiB used: 256 KiB (0.0%) dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 51.0 C pch: 45.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 310 Uptime: 3m Memory: 3.62 GiB used: 2.2 GiB (60.9%)
  Init: systemd target: graphical (5) Compilers: gcc: 12.1.1 Packages: N/A
  note: see --pkg Shell: Bash v: 5.1.16 inxi: 3.3.19

Please do the same for systemctl status blue* to see if we do see some errors.

Are you using a USB dongle for your Bluetooth?

No sir, its my laptop’s built in bluetooth.
and systemctl status blue* doesnt return anything

Please check on the HP website if you find a firmware upgrade for you Laptop alias for your

Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter

Bluetooth chip should be on the wireless adapter.

Yes it has a bios update of 2022 but it has mentioned only windows 10 . I have no idea if it will cause any problem to linux or not

There is a driver in github. But it is not specific for Fedora.

Please check also other toppics for rtl8821ce. You are not alone with this issue.

idk this isnt exact and have completely different things from my understanding. I tried installing rtl8821ce on fedora and it didnt worked either the commands doesnt works as they show or says. So please provide me a specific solution

I guess i gave you a hint in the direction you should go. I also mentioned that the driver …

Please search about firmware/bios and look for adequate driver. Your system is made to run with Windows and HP not supports Linux for your model.

First thing I would do is got the HP homepage and look for their support page. Then download the manual for the machine you have from there.

In the manual, check, if there is a hardware-switch for turning BT on/off. It could also be an Fn-key on your keyboard used for this…

If that is not the case, on the same HP support-website for your model, you could look into Bios update methods given there.

My first 2 cents…

Can you take look at the output of:
inxi -xE
lsusb | grep -i blue

I just installed fedora 36 everything seems fine but bluetooth cannot be turned on .

Can you confirm which destop environment you are running?

No sir, its my laptop’s built in bluetooth.
and systemctl status blue* doesnt return anything

Can you check the output of:
sudo dnf list installed | grep -i blue