No graphical login on Fedora 31

When I boot Fedora 31, it always boots to a command prompt. I have tried setting the default target to graphical and multi-user with systemd but it made no difference.

Not sure where to look to see why it didn’t load a graphical login…

systemctl list-units --failed
?

1 Like

Doesn’t show any failures…

Did you tried:

To switch from CLI to GUI: systemctl isolate graphical.target
If you use GNOME, systemctl enable gdm.service .
To set the GUI as default runlevel systemctl set-default graphical.target

According to this post you can start wayland from CLI:

https://wiki.archlinux.org/index.php/GNOME#Wayland_sessions

and check what error do you get?

Did you check your log?, you can do it follow this guide:

https://docs.fedoraproject.org/en-US/quick-docs/viewing-logs/

Regards.,

3 Likes

I had this happen on a older computer, i installed and switched to the SLiM log-in manager and all was well