No login screen after upgrade

After upgrading from 5.8.18-300.fc33.x86_64 to 5.9.9-200.fc33.x86_64 I cannot log in when booting into 5.9.9. I can still log in when booting into 5.8.18. When I boot into 5.9.9, the image on the screen appears compressed vertically so that the circular spinner becomes an ellipse. The screen then complains about lost signal and turns off before the login screen appears. I can then turn off the PC by pressing the power button and reboot into 5.8.18. From /var/log/messages I can see that 5.9.9 saw that I pressed the power button, so the system has been working fine, except that the screen went blank.

After looking at Xorg.0.log.old and Xorg.0.log I suspect the problem has to do with detection of the screen. I have a Philips Brilliance BDM4350UC 43" 4K PC-screen, an NVIDIA GP104 [GeForce GTX 1070 Ti], and I use nouveau drivers.

I can see from the Xorg logs that 5.9.9 uses initial mode 2560x1440 where 5.9.18 uses initial mode 3840x2160, and 5.9.9 does not even detect the 3840x… modes. So something has changed.

Can anyone point me in some direction here? I can understand that an upgrade can break everything. But why can 5.8.18 still work? And how can X detect the screen differently under 5.8.18 and 5.9.9?

Xorg.0.log.old (5.9.9) contains the following (among others):

(II) modeset(0): Not using default mode "2560x1440" (bad mode clock/interlace/doublescan)
...
(II) modeset(0): Output DP-1 using initial mode 2560x1440 +0+0
...
(II) modeset(0): Setting screen physical size to 677 x 381

Xorg.0.log (5.8.18) differs from the above as follows:

(II) modeset(0): Not using default mode "3840x2160" (bad mode clock/interlace/doublescan)
(II) modeset(0): Not using default mode "2560x1440" (bad mode clock/interlace/doublescan)
...
(II) modeset(0): Modeline "3840x2160"x60.0  533.25  3840 3888 3920 4000  2160 2163 2168 2222 +hsync -vsync (133.3 kHz eP)
(II) modeset(0): Modeline "3840x2160"x60.0  533.00  3840 3888 3920 4000  2160 2163 2168 2222 +hsync -vsync (133.2 kHz d)
(II) modeset(0): Modeline "3840x2160"x30.0  297.00  3840 4016 4104 4400  2160 2168 2178 2250 +hsync +vsync (67.5 kHz e)
(II) modeset(0): Modeline "3840x2160"x25.0  297.00  3840 4896 4984 5280  2160 2168 2178 2250 +hsync +vsync (56.2 kHz e)
(II) modeset(0): Modeline "3840x2160"x24.0  297.00  3840 5116 5204 5500  2160 2168 2178 2250 +hsync +vsync (54.0 kHz e)
(II) modeset(0): Modeline "3840x2160"x30.0  296.70  3840 4016 4104 4400  2160 2168 2178 2250 +hsync +vsync (67.4 kHz e)
(II) modeset(0): Modeline "3840x2160"x24.0  296.70  3840 5116 5204 5500  2160 2168 2178 2250 +hsync +vsync (53.9 kHz e)
(II) modeset(0): Modeline "3200x1800"x60.0  492.00  3200 3456 3800 4400  1800 1803 1808 1865 -hsync +vsync (111.8 kHz d)
(II) modeset(0): Modeline "3200x1800"x59.9  373.00  3200 3248 3280 3360  1800 1803 1808 1852 +hsync -vsync (111.0 kHz d)
(II) modeset(0): Modeline "2880x1620"x60.0  396.25  2880 3096 3408 3936  1620 1623 1628 1679 -hsync +vsync (100.7 kHz d)
(II) modeset(0): Modeline "2880x1620"x60.0  303.75  2880 2928 2960 3040  1620 1623 1628 1666 +hsync -vsync (99.9 kHz d)
...
(II) modeset(0): Output DP-1 using initial mode 3840x2160 +0+0
...
(II) modeset(0): Setting screen physical size to 1016 x 571

Xorg.0.log.old also contains Modeline lines, but none for a resolution of 3840x2160.

1 Like

Perhaps this:

1 Like

Thanks. If 5.9 hurts the nvidia drivers it could easily also hurt the nouveau drivers I use. I will try to browse https://nouveau.freedesktop.org/

1 Like

I’ve not read any reports of that yet, but it’s worth checking I guess.

Just for the sake of those who land here: The nice guys at https://nouveau.freedesktop.org/ look at the problem but there is no news. Meanwhile, here is what I did to recover until further:

> Boot into functioning version of Fedora
> Login
> In terminal window:
> > xrandr
> ...
> DP-1 connected 3840x2160+0+0 (normal left inverted right x axis y axis) 953mm x 543mm
> ...
> > grep 3840x2160 /var/log/Xorg.0.log
> ...
> [    10.315] (II) modeset(0): Modeline "3840x2160"x60.0  533.25  3840 3888 3920 4000  2160 2163 2168 2222 +hsync -vsync (133.3 kHz UP)
> ...
> > cat > 90-monitor.conf
> Section "Monitor"
>         Identifier "DP-1"
>         Modeline "3840x2160" 533.25 3840 3888 3920 4000 2160 2163 2168 2222 +hsync -vsync
>         Option "PreferredMode" "3840x2160"
> EndSection
> Ctrl-D
> Reboot PC
> Select malfunctioning version of Fedora using up- and down-arrows
> Press "e" to edit
> Go to the line starting with "linux" using up- and down-arrows
> Press End to go to the end of the line
> Add " 3" (add a space character and the letter 3) to specify runlevel 3
> Press Ctrl-X to boot
> Login
> > sudo cp 90-monitor.conf /etc/X11/xorg.conf.d/
> > telinit 5

If you leave 90-monitor.conf in /etc/X11/xorg.conf.d/ then you can just reboot normally from then on. But remember to remove 90-monitor.conf if you change monitor or if the detection problem gets solved.

On the net, there are warnings that if you get the modeline wrong, you may damage your monitor permanently. I think that applies mainly to owners of steampowered crt-monitors, but who knows. I ran the risk and my monitor works perfectly.