No network detected (wifi not working properly) ~ ethernet works fine

Hi evryone,
I have just installed F33 workstation on my lenovo L340 laptop, it did work just fine(perfectly, just loved it) untill the software update, well I can’t detect any wifi networks.
I did try a lot of solutions that i could find or understand in the web but none worked for me :’)
I am going to give you some command outputs. Please help :cry: :cry: :cry:
iwconfig :

   lo        no wireless extensions.

enp8s0    no wireless extensions.

enp0s20f0u1  no wireless extensions.

wlp7s0    IEEE 802.11  ESSID:off/any  
      Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
      Retry short limit:7   RTS thr:off   Fragment thr:off
      Power Management:on
      
virbr0    no wireless extensions.

virbr0-nic  no wireless extensions.

ifconfig

enp0s20f0u1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
            inet 192.168.1.100  netmask 255.255.255.0  broadcast 192.168.1.255
            inet6 fe80::a916:73a2:2427:a64e  prefixlen 64  scopeid 0x20<link>
            ether 58:2c:80:13:92:63  txqueuelen 1000  (Ethernet)
            RX packets 34951  bytes 32968349 (31.4 MiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 32107  bytes 3712176 (3.5 MiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp8s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 54:05:db:08:36:a5  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 35  bytes 3676 (3.5 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 35  bytes 3676 (3.5 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

virbr0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 192.168.122.1  netmask 255.255.255.0  broadcast 192.168.122.255
        ether 52:54:00:68:a0:60  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp7s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 46:56:dd:6e:62:d1  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lspci :

 07:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter
    08:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)

lshw -C network:

 *-network                 
       description: Wireless interface
       product: RTL8821CE 802.11ac PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:07:00.0
       logical name: wlp7s0
       version: 00
       serial: 9a:ab:7d:fc:59:ca
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtw_8821ce driverversion=5.9.8-200.fc33.x86_64 firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:132 ioport:4000(size=256) memory:a4300000-a430ffff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:08:00.0
       logical name: enp8s0
       version: 10
       serial: 54:05:db:08:36:a5
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=5.9.8-200.fc33.x86_64 firmware=rtl8168g-3_0.0.1 04/23/13 latency=0 link=no multicast=yes port=MII
       resources: irq:17 ioport:3000(size=256) memory:a4204000-a4204fff memory:a4200000-a4203fff

Well I did try restarting the network manager process, did try to reinstall it , my system is up to date as i mentioned.
Please let’s fix this ASAP.
(I am connected via ethernet, in the cold, down on the floor, away from my gf :cry: )

1 Like

Hello …! Welcome to the community! Please do take a few minutes to go over the introductory posts in #start-here when you have the time. They contain lots of useful information.

Sorry for this stupid answer, but did you search here on he forum

By rtl8821ce

There are 16 Topic about this subject included one with a sucessfull end

If anyone satisface you come here and coment again if you are on some problem

Try that first… For example

First install the drivers

su
sudo dnf update
sudo dnf install dkms make kernel-devel -y
git clone https://github.com/tomaspinho/rtl8821ce.git
cd rtl8821ce
sudo ./dkms-install.sh

Regards.,

2 Likes

heyy @hhlp,
well I did that :
-removed old kernels
-uninstalled the drivers
-installed the drivers
-reboot
The nightmare continues … :cry: :sob: :sob:

What about this one

After install the driver

sudo modprobe 8821ce

Importante - check is secure boot is disable in the bios

Regards

2 Likes

Hey man,
First, I’d like to thank you for your support and time.
But as I did what you said, the problem persists.

sudo modprobe 8821ce

had no output, and I did tuggle the airplane mode on and off.
Can we really find a solution ? :sob:

Let’s see is the wifi has any kind of block:

rfkill list     # verify it has any block

you have to get

Soft blocked: no
Hard blocked: no # if you get _YES_ somethings is blocking in your hardware 
rfkill unblock all   # unblock

and again, to verify:

rfkill list       

also

lsmod list | grep 8821ce   # verify if the module if load in the kernel

Note

if you get yes hard block many laptop has as a hard unblocker the Fn + F8

Regards.,

2 Likes

Yoo,
Well rfkill did not show any software or hardware blocks. I tryied lsmod (cat /proc/modules | grep 8821)
it showed the same~~ output

lsmod | grep 8821ce

it shows

8821ce               1945600  0
rtw88_8821ce           16384  0
rtw88_8821c            77824  1 rtw88_8821ce
rtw88_pci              28672  1 rtw88_8821ce
cfg80211              876544  3 rtw88_core,mac80211,8821ce

I am thinking of pushing the module with insmod(similar to modprobe, but a bit stupid)but i showed this(the same output waas for rtw88_8821ce):

 insmod 8821ce
insmod: ERROR: could not load module 8821ce: No such file or directory

Knowing that modprobe showed this :

sudo modprobe 8821ce
[sudo] password for : 
[a####za@a####za ~]$ 

So I’m guessing the module isn’t loaded in the current kernel even thought we forced it in some ways.
I thought i could modify it somehow by accesing /etc/modules.conf but i had this :

cat /etc/modules.conf
cat: /etc/modules.conf: No such file or directory

So guys :cry: … please help :face_with_head_bandage: :face_with_head_bandage: :sob: :sob:

Heyy,
so back to you as I do

lshw -C network , it shows that driver=rtw_8821ce.
but when i do modprob -r rtw_8821ce it says modprobe: FATAL: Module rtw_8821ce not found.
after a lot of modprobes and insmodes to push 8821ce lshw still shows that the driver is trw_8821ce.
well I’m literally going to cry :3

you should try with this repo:

Regards.,

Hey @hhlp
Still no changes.
the lshw -c network allways shows rtw8821ce as driver is this norlmal?
Can we change that by accesing a file smh?
rmmod and modprobe -r did not change anything .

Heyyyyy
So is did install rtw88 the good news is that it’s visble in the lshw (blacklisted all the other drivers and did a cold reboot)

   configuration: broadcast=yes driver=rtl8821ce driverversion=5.9.8-200.fc33.x86_64 latency=0 multicast=yes wireless=unassociated

The bad news is that wifi is not working

hi
i don’t know how i did this but wifi is up and running again, with the original driver rtw_8821ce.
Thank you for your help