No nvidia-kmod-common dep

Links to earlier posts make it so we can see exactly what you have said. The better references you give the more detail is available and the better suggestions can be provided.

Don’t expect volunteers to do all the research for you!

It would be much better if you either post in the current thread (whenever that may be) or provide links to earlier discussion so we can see the data you have already provided.

You should definitely disable the rpmfusion-nonfree-nvidia-driver repo since it seems to me to often conflict with the rpmfusion-nonfree repo when dealing with the nvidia driver (as noted below).

The errors that need addressed promptly are

Problem 1: package akmod-nvidia-3:470.74-1.fc34.x86_64 requires nvidia-kmod-common >= 3:470.74, but none of the providers can be installed
  - cannot install the best update candidate for package akmod-nvidia-3:470.63.01-1.fc34.x86_64
  - package xorg-x11-drv-nvidia-3:470.74-1.fc34.x86_64 is filtered out by modular filtering

That shows up repeatedly and its fallout shows in most of the remaining reported errors.
As was suggested, the modular issue needs to be fixed.

 Problem 3: cannot install both xorg-x11-drv-nvidia-cuda-libs-3:470.74-1.fc34.x86_64 and xorg-x11-drv-nvidia-cuda-libs-3:470.63.01-1.fc34.x86_64
  - package xorg-x11-drv-nvidia-cuda-3:470.63.01-1.fc34.x86_64 requires xorg-x11-drv-nvidia-cuda-libs(x86-64) = 3:470.63.01-1.fc34, but none of the providers can be installed
  - cannot install the best update candidate for package xorg-x11-drv-nvidia-cuda-libs-3:470.63.01-1.fc34.x86_64
  - problem with installed package xorg-x11-drv-nvidia-cuda-3:470.63.01-1.fc34.x86_64

This error is caused by conflicting package versions in rpmfusion-nonfree and rpmfusion-nonfree-nvidia-driver. The fix is to disable the rpmfusion-nonfree-nvidia-driver repo.

Another thing that may help once the repo conflict is resolved would be to add the options --best and --allowerasing to the dnf command line.

Each time you attempt the install from the nvautoinstall tool or from my command line provided, if needed, you can post the output of your attempt to install the driver from rpmfusion and we can address the issues one at a time.

You shouldn’t need the full command. The RPM Fusion docs only say you need to use sudo dnf install akmod-nvidia.

Anyway, the package is xorg-x11-drv-nvidia (not -driver-), so correcting that should fix it.

https://koji.rpmfusion.org/koji/search?match=glob&type=package&terms=xorg-x11*

I wouldn’t use nvidia\* or xorg-x11-drv-nvidia\* though since that installs all packages that match that pattern from the repos. I don’t think we want all of them? It’ll be best to really just stick to the RPM Fusion docs and do exactly what they ask.

If you have installed the packages manually, there won’t be anything for dnf to do, by the way. You should check what all packages you have installed related to nvidia, and remove ones your system does not need:

rpm -qa \*nvidia\*

Nothing matches except from the rpmfusion repo. A couple of extra packages are installed but nothing unrelated, and without using the * in the command you do not get all the needed packages for cuda and devel (package building).

Check the differences in the suggested packages to be installed using it both ways and decide which is best for you. My list given earlier is with using the command I suggested then removing (2?) unnecessary packages. Yep, I realized after the fact that i gave the wrong package name and edited the post.

I understand that of course but I hope you can understand also the “emotional fatigue” of repeating over and over again a recurring problem. But of course I concurr to your point of view but still…

okey so which ones are the most up to date in general? the rpmfusion-non-free then ? not de nvidia branch ?

Most of the time it had created me more problems than it has resolved. Again cfr the post about the upgrade from 33 to 34. Best, unfortunately is to do a manual override package by package.

indeed since it owuld tell me there is a conflict between the version 340 and 470 of course, I know that too well.
And also yeah since I’m installing since several months every updates manually dnf is not justified here until the next update of course.

The only problem is that sometimes I4ve had previous problems with packages not released at the same time than the dep would have been released, but we’ll see in the future of course

1 Like

I just tried doing an install using my command to verify everything would work and got a conflict with the installed kmod-nvidia package that had been built by the akmod package. With the change here it eliminated the conflict.

sudo dnf install nvidia* xorg-x11-drv-nvidia*470* --exclude=*390* --exclude=*340* --exclude=kmod-nvidia

That command does install the packages
nvidia-texture-tools
nvidia-texture-tools-devel
nvidia-query-resource-opengl
nvidia-query-resource-opengl-lib
which are the ones I chose to eliminate earlier but those are the only ones I considered unnecessary for my use. They are easy to remove from the install with additional exclude options.

If you do not want to update the drivers then when the kernel is updated the akmod package will keep the driver modules updated to match the kernel.

I hope you get all the conflicts sorted out and the driver working properly for you.

I would really just follow what RPM Fusion say to the letter. For CUDA, this page lists exactly what needs to be done (note how it always disables the nvidia-driver module in each command also):

https://rpmfusion.org/Howto/CUDA

Your command is wayy too complex than the commands that the RPM Fusion documentation notes. Why install everything and then add lots of excludes instead of specifying only what’s needed? With package installations it’s always better to specify what to install rather than install everything and then exclude bits.

That way the user is explicitly aware of the packages that are being installed for them—they will remember specifying them. Otherwise we get into scenarios where when something breaks, the user can quite truthfully say “well, I didn’t explicitly install it, I don’t know how that happened” XD

All packages from RPM Fusion should release at the same time.

After Fedora releases a new kernel version, RPM Fusion need to run their rebuilds and then push updates, so there’s sometimes a slight lag between Fedora updates and corresponding RPM Fusion updates. In those cases, dnf will generally point out unsatisfied dependencies etc., but we do sometimes get caught in the gap. The solution is to just wait a day and let RPM Fusion updates also hit all the mirrors and then run another update. That should fix it in most cases.

What if I want way more than the default? My way makes less confusion and tweaking for me.

For you maybe. When we’re helping others troubleshoot, we suggest the simplest way that is best for them.

In general installing “A, B, C” by explicitly specifying them is better than saying “Everything but not D”, because you must manually verify that “Everything but not D” is the same as “A, B, C”—so what’s the point then if you end up having to list “A, B, C” anyway?. Also note that verifying that “Everything but not D” is the same as “A, B, C” may not always be simple to do, and “Everything but not D” may change as the package set changes, but “A, B, C” will remain “A, B, C”.