No processor fan on new Rog G14

Installed Fedora 32 on an Asus ROG G14, GA401iv. Fan on Nouveau processor is not working. This is per x-sensor and grellm. The fan works under windows.
Not surprisingly, processor overheats and screen goes black. Reboot and it comes back on again untill it overheats again.
Any ideas?

Just installed F32 on a new Asus G14 notebook. Ryzen9 processor, 32 Gb Ram Nvidia video.
After certain amount of time the screen goes black. Have to shut down then reboot until the next shutdown.
It appears the fan on the Nouveau process is not running. It runs on windows so it is not a hardware issue.
I’m new to Fedora and have no idea how to resolve the issue.
Any ideas?

UPDATE:

Booted up this morning and found no temp readout on graphics processor as well as fan speed.

Processor is Nvidia RTX 2060.
What I have read so far suggests the nouveau driver is kind sucky.
Would anyone advise installing the proprietary drivers from Nvidia?
The file I downloaded from Nvidia is “NVIDIA-Linux-x86_64-450.57.run”
I guess if I Bork the system I can reinstall since there is not much personal stuff on it yet.
Thoughts?

I haven’t used NVidia cards in ages, so I can’t advise directly, but if you decide to give the proprietary drivers a try, @t0xic0der wrote a tool that automates the installation of the driver & various dependencies.

This is what got when attempting the above.
[ ✘ ] RPMFusion NVIDIA repository could not be enabled!
[ ✘ ] Leaving installer

Check if you running the installer with elevated permissions.