No sound after fedora 35 upgrade. Corrupted fedora 34 caused failure

For me it looks like you run out of disk space. You might have to check this first and afterwards if you have enough space left you can do the upgrade following the doc here:

DNF System Upgrade :: Fedora Docs

I don’ t know where the multitasking menu is.

The settings does not have the multitasking under search.

I did the following:


dnf --refresh upgrade

dnf install dnf-plugin-system-upgrade --best

dnf system-upgrade download --refresh --releasever=35

dnf system-upgrade reboot

I think you are right. The about shows fedora 34

🕙 10:28:10 ❯ sudo grubby --info=ALL
[sudo] password for tads: 
index=0
kernel="/boot/vmlinuz-5.15.12-100.fc34.x86_64"
args="ro resume=/dev/mapper/fedora_localhost--live-swap rd.lvm.lv=fedora_localhost-live/root rd.lvm.lv=fedora_localhost-live/swap rhgb quiet"
root="/dev/mapper/fedora_localhost--live-root"
initrd="/boot/initramfs-5.15.12-100.fc34.x86_64.img"
title="Fedora (5.15.12-100.fc34.x86_64) 34 (Workstation Edition)"
id="f8c3d4c14e81446dbd33bb645b598de5-5.15.12-100.fc34.x86_64"
index=1
kernel="/boot/vmlinuz-5.15.11-100.fc34.x86_64"
args="ro resume=/dev/mapper/fedora_localhost--live-swap rd.lvm.lv=fedora_localhost-live/root rd.lvm.lv=fedora_localhost-live/swap rhgb quiet"
root="/dev/mapper/fedora_localhost--live-root"
initrd="/boot/initramfs-5.15.11-100.fc34.x86_64.img"
title="Fedora (5.15.11-100.fc34.x86_64) 34 (Workstation Edition)"
id="f8c3d4c14e81446dbd33bb645b598de5-5.15.11-100.fc34.x86_64"
index=2
kernel="/boot/vmlinuz-5.13.10-200.fc34.x86_64"
args="ro resume=/dev/mapper/fedora_localhost--live-swap rd.lvm.lv=fedora_localhost-live/root rd.lvm.lv=fedora_localhost-live/swap rhgb quiet"
root="/dev/mapper/fedora_localhost--live-root"
initrd="/boot/initramfs-5.13.10-200.fc34.x86_64.img"
title="Fedora (5.13.10-200.fc34.x86_64) 34 (Workstation Edition)"
id="f8c3d4c14e81446dbd33bb645b598de5-5.13.10-200.fc34.x86_64"
index=3
kernel="/boot/vmlinuz-0-rescue-f8c3d4c14e81446dbd33bb645b598de5"
args="ro resume=/dev/mapper/fedora_localhost--live-swap rd.lvm.lv=fedora_localhost-live/root rd.lvm.lv=fedora_localhost-live/swap rhgb quiet"
root="/dev/mapper/fedora_localhost--live-root"
initrd="/boot/initramfs-0-rescue-f8c3d4c14e81446dbd33bb645b598de5.img"
title="Fedora (0-rescue-f8c3d4c14e81446dbd33bb645b598de5) 32 (Thirty Two)"
id="f8c3d4c14e81446dbd33bb645b598de5-0-rescue"

To cover the gambit …

Will let you know if you’re out of space
sudo df -h

Looking to see which repos are enabled
sudo dnf repolist enabled

Checking for Fedora Modular S/W & Repo
sudo dnf module list

Thanks

Well, what I can tell you is that the upgrade to fedora 35 failed. Unfortunately, it didn’t report anything as an error, but I am stuck with 34.

I backed up my home directory, and I upgraded again using DNF. It didn’t do anything. I tried the upgrade using the Software app, and nothing happened either.

I have been procrastinating on installing the NVMe M.2 second (actually, it is the primary now) hard drive. So, I thought this was the best moment to do it.

I installed fedora35 on my new hard drive, and it is different. I can now see the multitasking menu on settings. I have sound in my BlueTooth, but it does not recognize my monitor’s speakers (HDMI/Displayport) or my USB headphone. So the saga continues. I will try to run the first suggestions, and I will post the results.

So, I am trying to find out how to recover my home directory and set my other disk for all the data.

1 Like

You’re on a fresh F35, so it will be more easy. Can you send again the systemctl commands you ran before in F34?

1 Like
[tads@localhost-live ~]$ systemctl --user status "pipewire.*"
Warning: The unit file, source configuration file or drop-ins of pipewire.service changed on disk. Run 'systemctl --use>
Warning: The unit file, source configuration file or drop-ins of pipewire.socket changed on disk. Run 'systemctl --user>
● pipewire.service - PipeWire Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; disabled; vendor preset: disabled)
    Drop-In: /usr/lib/systemd/user/pipewire.service.d
             └─00-uresourced.conf
     Active: active (running) since Mon 2022-01-10 16:06:29 PST; 1h 15min ago
TriggeredBy: ● pipewire.socket
   Main PID: 2771 (pipewire)
      Tasks: 2 (limit: 77032)
     Memory: 7.2M
        CPU: 6.936s
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
             └─2771 /usr/bin/pipewire

Jan 10 16:06:29 localhost-live.T-mobile.com systemd[2372]: Started PipeWire Multimedia Service.

● pipewire.socket - Multimedia System
     Loaded: loaded (/usr/lib/systemd/user/pipewire.socket; enabled; vendor preset: enabled)
     Active: active (running) since Mon 2022-01-10 16:06:28 PST; 1h 15min ago
   Triggers: ● pipewire.service
     Listen: /run/user/1000/pipewire-0 (Stream)
     CGroup: /user.slice/user-1000.slice/user@1000.service/app.slice/pipewire.socket

Jan 10 16:06:28 localhost-live.T-mobile.com systemd[2372]: Listening on Multimedia System.
[tads@localhost-live ~]$ 

[tads@localhost-live ~]$ systemctl --user status "pipewire-pulse.*"
Warning: The unit file, source configuration file or drop-ins of pipewire-pulse.service changed on disk. Run 'systemctl --user daemon-reload' to reload units.
Warning: The unit file, source configuration file or drop-ins of pipewire-pulse.socket changed on disk. Run 'systemctl --user daemon-reload' to reload units.
● pipewire-pulse.service - PipeWire PulseAudio
     Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.service; disabled; vendor preset: disabled)
     Active: active (running) since Mon 2022-01-10 16:06:29 PST; 1h 18min ago
TriggeredBy: ● pipewire-pulse.socket
   Main PID: 2773 (pipewire-pulse)
      Tasks: 2 (limit: 77032)
     Memory: 11.8M
        CPU: 8.515s
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire-pulse.service
             └─2773 /usr/bin/pipewire-pulse

Jan 10 16:23:39 localhost-live.T-mobile.com pipewire-pulse[2773]: default: stream 0x56029bb57850: error no node available
Jan 10 16:23:39 localhost-live.T-mobile.com pipewire-pulse[2773]: mod.protocol-pulse: client 0x56029bb4a340 [Mutter]: ERROR command:-1 (invalid) tag:16 error:25 (Input>
Jan 10 16:28:12 localhost-live.T-mobile.com pipewire-pulse[2773]: default: stream 0x56029bc47af0: error no node available
Jan 10 16:28:12 localhost-live.T-mobile.com pipewire-pulse[2773]: mod.protocol-pulse: client 0x56029bc082a0 [eSpeak]: ERROR command:-1 (invalid) tag:2 error:25 (Input/>
Jan 10 16:28:12 localhost-live.T-mobile.com pipewire-pulse[2773]: default: stream 0x56029bc47af0: error no node available
Jan 10 16:28:12 localhost-live.T-mobile.com pipewire-pulse[2773]: mod.protocol-pulse: client 0x56029bbac940 [speech-dispatcher-espeak-ng]: ERROR command:-1 (invalid) t>
Jan 10 16:28:12 localhost-live.T-mobile.com pipewire-pulse[2773]: default: stream 0x56029bc47af0: error no node available
Jan 10 16:28:12 localhost-live.T-mobile.com pipewire-pulse[2773]: mod.protocol-pulse: client 0x56029bc082a0 [speech-dispatcher-dummy]: ERROR command:-1 (invalid) tag:2>
Jan 10 17:06:36 localhost-live.T-mobile.com pipewire-pulse[2773]: default: stream 0x56029bbc7aa0: error no node available
Jan 10 17:06:36 localhost-live.T-mobile.com pipewire-pulse[2773]: mod.protocol-pulse: client 0x56029bc6e410 [Firefox]: ERROR command:-1 (invalid) tag:4294967295 error:>

● pipewire-pulse.socket - PipeWire PulseAudio
     Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.socket; enabled; vendor preset: enabled)
     Active: active (running) since Mon 2022-01-10 16:06:28 PST; 1h 18min ago
   Triggers: ● pipewire-pulse.service
     Listen: /run/user/1000/pulse/native (Stream)
     CGroup: /user.slice/user-1000.slice/user@1000.service/app.slice/pipewire-pulse.socket

Jan 10 16:06:28 localhost-live.T-mobile.com systemd[2372]: Listening on PipeWire PulseAudio.

systemctl --user status "pipewire-media-session.*" didn’t return anything.

@tad Hi, please follow above commands. The first command to check weather you have enough disk space for download the packages for upgrade or not. The second command to check your current repos. The third one, to check you your current module since from your error messages below mentioned about module conflict.

Your current problem with sound look like some packages are partially installed when you did the upgrade. But first I think we should focus why your current system failed to upgrade, after that we can focus on your sound.

I installed another hard drive and installed a fresh fedora35. I have sound now only on Bluetooth headset.

I don’t see any other device in the output. Previously, my monitor speaker provided sound, but they don’t show as a device under the setting/sound.

So, I have two problems. 1. No sound besides Bluetooth. 2. How can I restore my home directory. (I have opened a new issue, so that way, I will track both.

This is because you use now wireplumber with F35, media-session was a F34 thing.

Have you done a full update since installation of F35?
sudo dnf upgrade --refresh

Check if wireplumber is running now, if not start it:

I restored my home drive from backup and reboot. I have sound in all my devices.

Thanks everyone. I would say that the upgrade for 35 failed, but If I have to guess, then fedora 34 had issues with the upgrade as well.

Gnome and fedora are working as I remember. Thanks so much.

2 Likes

What was Solution, a new installation ? And copying the old home to home?

Please mark the correct solution and or change your Title.

My fedora 34 was corrupted. It was not a real issue with sound or something like that.
I tried to upgrade several times after that and the system didn’t fix it.
I cannot say the fresh install was a solution to the sound, but it was a solution to the fedora being corrupted. I might have done something to the installation, or a package that I installed previously.
I am new to the forum, so Please guide me how to proceed. Should I remove the solution or mark another? What title will be more appropriate for this. I can tell the sound issue was misleading, because I was stuck in a corrupted version that didn’t let me move forward to fedora 35.

I suggest you edit the title to something like this.
No sound after fedora 35 upgrade. Corrupted fedora 34 caused failure or even just No sound after fedora 35 upgrade.

You may use your own words, but the cause was that you did not have a clean fully functioning fedora 34 and the fedora 35 upgrade failed, leaving you with fedora 34. The solution seems correct to me.

1 Like

I have tried to change the title. I don’t know how to do it.
I come from time to time, try several times and give up. I forget for a few days, and come back same result.
I do not know how to change the title, I need help with that and correct it to the right name.

If you have the rights, you should see on the top request, a pencil beside it. Click on it to edit it. I made it now , as @computersavvy proposed.

I see you changed the title. For some reason I see the pencil in the posts, but not for the title.
I can change any post except the title. Anyways that is beside the point. It is good now.

1 Like

You can change the title for your own posts by clicking on the title and it will then show you the pencil to allow editing.

You just need to be on the top of your toppic:

Back to top >> No sound after fedora 35 upgrade. Corrupted fedora 34 caused failure

I was planning to post a video short one of what happen when I hoover over the title. No pencil shows up. Videos/gif, etc are not allowed.
Well, anyway the title is correct now.

Click on the title, not hoover over it.
Both jpg & png are allowed, which can be done with a screenshot.