No Sound Device Fedora 35 on Lenovo P15-2

Welcome to :fedora: community.
Let’s solve your issue
At first make sure you are running latest update that fedora offering right now if not update your system and restart
Can you check that

systemctl --user status wireplumber

your device running wireplumber or not if not enabled this with

systemctl --user enable --now wireplumber

If problem is not solved kindly post the output to look into this
inxi -Fxz
And also check pipewire running or not.

Thanks for the help.

root@fedora tomlink]# systemctl --user enable --now wireplumber
Failed to connect to bus: Operation not permitted (consider using --machine=@.host --user to connect to bus of other user)

[root@fedora tomlink]# inxi -Fxz
System:
Kernel: 5.14.10-300.fc35.x86_64 x86_64 bits: 64 compiler: gcc
v: 2.37-10.fc35 Desktop: GNOME 41.3 Distro: Fedora release 35 (Thirty Five)
Machine:
Type: Laptop System: LENOVO product: 20YQCTO1WW v: ThinkPad P15 Gen 2i
serial:
Mobo: LENOVO model: 20YQCTO1WW v: SDK0J40697 WIN serial:
UEFI: LENOVO v: N37ET36W (1.17 ) date: 11/22/2021
Battery:
ID-1: BAT0 charge: 95.6 Wh (100.0%) condition: 95.6/94.0 Wh (101.7%)
volts: 13.1 min: 11.5 model: Celxpert 5B10W13959 status: Full
CPU:
Info: 8-core model: 11th Gen Intel Core i7-11800H bits: 64 type: MT MCP
arch: Tiger Lake rev: 1 cache: L1: 640 KiB L2: 10 MiB L3: 24 MiB
Speed (MHz): avg: 934 high: 1169 min/max: 800/4600 cores: 1: 807 2: 813
3: 806 4: 801 5: 1122 6: 1084 7: 800 8: 1108 9: 1169 10: 945 11: 796
12: 767 13: 1123 14: 901 15: 800 16: 1112 bogomips: 73728
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Lenovo driver: i915
v: kernel bus-ID: 00:02.0
Device-2: NVIDIA TU117GLM [T1200 Laptop GPU] vendor: Lenovo
driver: nouveau v: kernel bus-ID: 01:00.0
Device-3: Luxvisions Innotech Limited Integrated Camera type: USB
driver: uvcvideo bus-ID: 3-4:4
Display: wayland server: X.Org 1.21.1.4 compositor: gnome-shell driver:
loaded: nouveau note: n/a (using device driver) resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 21.3.4
direct render: Yes
Audio:
Device-1: Intel Tiger Lake-H HD Audio vendor: Lenovo
driver: sof-audio-pci-intel-tgl bus-ID: 00:1f.3
Device-2: NVIDIA vendor: Lenovo driver: snd_hda_intel v: kernel
bus-ID: 01:00.1
Sound Server-1: ALSA v: k5.14.10-300.fc35.x86_64 running: yes
Sound Server-2: PipeWire v: 0.3.43 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
bus-ID: 09:00.0
IF: wlp9s0 state: up mac:
Device-2: Intel Ethernet I225-V vendor: Lenovo driver: igc v: kernel
port: N/A bus-ID: 0b:00.0
IF: enp11s0 state: down mac:
Bluetooth:
Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 3-14:7
Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
Drives:
Local Storage: total: 476.94 GiB used: 22.31 GiB (4.7%)
ID-1: /dev/nvme0n1 vendor: Micron model: MTFDKBA512TFH size: 476.94 GiB
temp: 31.9 C
Partition:
ID-1: / size: 298.89 GiB used: 22.07 GiB (7.4%) fs: btrfs
dev: /dev/nvme0n1p6
ID-2: /boot size: 973.4 MiB used: 202.8 MiB (20.8%) fs: ext4
dev: /dev/nvme0n1p5
ID-3: /boot/efi size: 256 MiB used: 45 MiB (17.6%) fs: vfat
dev: /dev/nvme0n1p1
ID-4: /home size: 298.89 GiB used: 22.07 GiB (7.4%) fs: btrfs
dev: /dev/nvme0n1p6
Swap:
ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
Sensors:
System Temperatures: cpu: 39.0 C mobo: N/A gpu: nouveau temp: 32.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 416 Uptime: 1h 30m Memory: 31.07 GiB used: 5.13 GiB (16.5%)
Init: systemd runlevel: 5 Compilers: gcc: 11.2.1 Packages: N/A
note: see --pkg Shell: Bash v: 5.1.8 inxi: 3.3.11

note: see --pkg Shell: Bash v: 5.1.8 inxi: 3.3.11

[root@fedora tomlink]# ps ax | grep pipe
28929 ? S<sl 0:00 /usr/bin/pipewire

Give the output in </>

Don’t just copy paste like that replace user with your username

OK. I rebooted and now there is a device - “Speaker - Tiger Lake” but no sound when I test.

Hi, since it newly installed, would you like to upgrade your system first. There some upgrades available. Maybe one of them hopefully fix it. sudo dnf upgrade

If the problem persist, let us know (and please post the result aplay -l (L lower case) and aplay -L after upgrade if the problem persit).

I updated earlier today. aplay filename does generate sound, but it is just static. Youtube hangs and does not start any video.

[tomlink@fedora ~]$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 10: HDMI 4 [HDMI 4]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 11: HDMI 5 [HDMI 5]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 12: HDMI 6 [HDMI 6]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: sofhdadsp [sof-hda-dsp], device 0: HDA Analog () []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: sofhdadsp [sof-hda-dsp], device 1: HDA Digital (
)
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: sofhdadsp [sof-hda-dsp], device 3: HDMI1 () []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: sofhdadsp [sof-hda-dsp], device 4: HDMI2 (
)
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: sofhdadsp [sof-hda-dsp], device 5: HDMI3 (*)
Subdevices: 1/1
Subdevice #0: subdevice #0
[tomlink@fedora ~]$ aplay -L
null
Discard all samples (playback) or generate zero samples (capture)
pipewire
PipeWire Sound Server
default
Default ALSA Output (currently PipeWire Media Server)
hdmi:CARD=NVidia,DEV=0
HDA NVidia, HDMI 0
HDMI Audio Output
hdmi:CARD=NVidia,DEV=1
HDA NVidia, HDMI 1
HDMI Audio Output
hdmi:CARD=NVidia,DEV=2
HDA NVidia, HDMI 2
HDMI Audio Output
hdmi:CARD=NVidia,DEV=3
HDA NVidia, HDMI 3
HDMI Audio Output
hdmi:CARD=NVidia,DEV=4
HDA NVidia, HDMI 4
HDMI Audio Output
hdmi:CARD=NVidia,DEV=5
HDA NVidia, HDMI 5
HDMI Audio Output
hdmi:CARD=NVidia,DEV=6
HDA NVidia, HDMI 6
HDMI Audio Output
sysdefault:CARD=sofhdadsp
sof-hda-dsp,
Default Audio Device

I was using an mp3 for testing, aplay apparently does not support it. I tried a .WAV file and sound works fine. But “test” from settings does not work and Firefox and Chrome hang on Youtube .

Would you like to post the aplay command that give you a sound? If the sound you hear are right (not noise), maybe we can create custom conf from there.

aplay “/mnt/drivef/MusicEncore/TICC 19961213/05 Christmas Country Style.wav”

I see. Since the aplay command you’re using didn’t specified from which cards the sound comes, would you like to try again with both command as bellow:

aplay -D plughw:1,0 /usr/share/sounds/alsa/Front_Center.wav

aplay -D plughw:1,1 /usr/share/sounds/alsa/Front_Center.wav

Take notes which of above command give a sound.

You are on a older kernel update your system and recheck it
sudo dnf update
And restart

@frankjunior I updated earlier. That command says “nothing to do”
@oprizal The first command works, the second fails.

Please open file cat /usr/share/pipewire/pipewire.conf and read at the very top comment on how to create local configuration.

After you creating a copy of pipewire.conf in ~/.config/pipewire/pipewire.conf, find at the very bottom file as below:

    # This creates a single PCM source device for the given
    # alsa device path hw:0. You can change source to sink
    # to make a sink in the same way.
    #{ factory = adapter
    #    args = {
    #        factory.name           = api.alsa.pcm.source
    #        node.name              = "alsa-source"
    #        node.description       = "PCM Source"
    #        media.class            = "Audio/Source"
    #        api.alsa.path          = "hw:0"
    #        api.alsa.period-size   = 1024
    #        api.alsa.headroom      = 0
    #        api.alsa.disable-mmap  = false
    #        api.alsa.disable-batch = false
    #        audio.format           = "S16LE"
    #        audio.rate             = 48000
    #        audio.channels         = 2
    #        audio.position         = "FL,FR"
    #    }
    #}

Then edit it as below:

    # This creates a single PCM source device for the given
    # alsa device path hw:0. You can change source to sink
    # to make a sink in the same way.
    { factory = adapter
        args = {
            factory.name           = api.alsa.pcm.sink
            node.name              = "Internal Speaker"
            node.description       = "PCM Internal Speaker"
            media.class            = "Audio/Sink"
            api.alsa.path          = "hw:1,0"
            audio.channels         = 2
            audio.position         = "FL,FR"
        }
    }

After that, close all windows and leave only the terminal and run both command bellow:

systemctl --user restart pipewire
systemctl --user restart wireplumber

After that open Gnome setting on Audio device. There should be new device shown from the drop down menu selector (device name should be “Internal Speaker” on there).

No new device, but sound is working. Thanks!

I had similar problem I did dnf install pipewire-media-session --allowerasing and it worked (it removed wireplumber) but that was when 35 was new almost 3 months ago

Let me also comment on Fedora support here. I have been working with Microsoft on an issue now for a day and a half, with multiple attempts taking hours for a reply (try 10 hours in one case). And it is not yet resolved. You folks here are GREAT!

1 Like

Thanks hope you will like fedora and linux as a whole. Stay happy peace :grinning:

You may need to upgrade by using sudo dnf upgrade --refresh
Your post says you have the 5.15.10 kernel and the latest for fedora 35 is 5.15.14 as it has been for about a week.

Perhaps I updated after that first command.

tomlink@fedora ~]$ uname -a
Linux fedora 5.15.15-200.fc35.x86_64 #1 SMP Sun Jan 16 17:37:06 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux