No sound in Fedora 36 on fresh install/upgrade from F34 (also frozen/no video in Firefox/Chrome)

Hi,

I have no sound through the Broadwell rt286 card/speakers on an HP Spectre x360 13-4102dx laptop with a fresh instance of F36. I noticed this first as a problem that video playback doesn’t work on Firefox and Chrome browsers (e.g. playing any YouTube video just freezes, spinning and then finally saying “If playback doesn’t begin shortly, try restarting your device”, and there is no sound).

I tried rebooting into older kernels, like the last one I had in F34, but no change.

Other symptoms and oddities:

  • sound works through Bluetooth, but not through speakers via Broadwell card
  • “aplay anyfile.mp3” from a command line shell just hangs, no sound plays
  • kcmshell5 kcm_pulseaudio GUI has a section that says “Inactive cards: Built-in Audio” with the “Profile” dropdown set to “Off”, and no other choices/can’t change it (could this be the clue?)

Pipewire status:

$ systemctl --user status pipewire
● pipewire.service - PipeWire Multimedia Service
Loaded: loaded (/usr/lib/systemd/user/pipewire.service; disabled; vendor preset: disabled)
Drop-In: /usr/lib/systemd/user/pipewire.service.d
└─00-uresourced.conf
Active: active (running) since Sun 2022-06-19 20:56:03 EDT; 33min ago
TriggeredBy: ● pipewire.socket
Main PID: 2259 (pipewire)
Tasks: 2 (limit: 9367)
Memory: 2.6M
CPU: 58ms
CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
└─ 2259 /usr/bin/pipewire

Jun 19 20:56:03 localhost.localdomain systemd[1989]: Started pipewire.service - PipeWire Multimedia Service.

Searching system logs shows this:

[root@localhost tlp]# journalctl | egrep -i “audio|sound”
Jun 19 16:52:03 localhost.localdomain kernel: ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
Jun 19 20:52:09 localhost.localdomain kernel: snd_hda_intel 0000:00:03.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
Jun 19 20:52:09 localhost.localdomain kernel: input: HDA Intel HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:03.0/sound/card0/input24
Jun 19 20:52:09 localhost.localdomain kernel: input: HDA Intel HDMI HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:03.0/sound/card0/input25
Jun 19 20:52:09 localhost.localdomain kernel: input: HDA Intel HDMI HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:03.0/sound/card0/input26
Jun 19 20:52:09 localhost.localdomain kernel: input: HDA Intel HDMI HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:03.0/sound/card0/input27
Jun 19 20:52:09 localhost.localdomain kernel: input: HDA Intel HDMI HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:03.0/sound/card0/input28
Jun 19 20:52:09 localhost.localdomain kernel: input: broadwell-rt286 Headset as /devices/platform/broadwell-audio/sound/card1/input29
Jun 19 20:52:11 localhost.localdomain systemd[1]: alsa-restore.service - Save/Restore Sound Card State was skipped because of a failed condition check (ConditionPathExists=!/etc/alsa/state-daemon.conf).
Jun 19 20:52:11 localhost.localdomain systemd[1]: Started alsa-state.service - Manage Sound Card State (restore and store).
Jun 19 20:52:11 localhost.localdomain systemd[1]: Reached target sound.target - Sound Card.
Jun 19 20:56:01 localhost.localdomain systemd[1989]: Listening on pulseaudio.socket - Sound System.
Jun 19 20:56:01 localhost.localdomain systemd[1989]: Starting pulseaudio.service - Sound Service…
Jun 19 20:56:01 localhost.localdomain rtkit-daemon[2008]: Successfully made thread 1998 of process 1998 (/usr/bin/pulseaudio) owned by ‘1000’ high priority at nice level -11.
Jun 19 20:56:02 localhost.localdomain rtkit-daemon[2008]: Successfully made thread 2031 of process 1998 (/usr/bin/pulseaudio) owned by ‘1000’ RT at priority 5.
Jun 19 20:56:02 localhost.localdomain rtkit-daemon[2008]: Successfully made thread 2034 of process 1998 (/usr/bin/pulseaudio) owned by ‘1000’ RT at priority 5.
Jun 19 20:56:02 localhost.localdomain pulseaudio[1998]: stat(’/etc/pulse/default.pa.d’): No such file or directory
Jun 19 20:56:02 localhost.localdomain systemd[1989]: Started pulseaudio.service - Sound Service.
Jun 19 20:56:02 localhost.localdomain pulseaudio[1998]: Failed to register as a handsfree audio agent with ofono: org.freedesktop.DBus.Error.ServiceUnknown: The name is not activatable
Jun 19 21:21:00 localhost.localdomain pulseaudio[1998]: Failed to create sink input: sink is suspended.
Jun 19 21:21:00 localhost.localdomain pulseaudio[1998]: Failed to create sink input: sink is suspended.
Jun 19 21:21:00 localhost.localdomain pulseaudio[1998]: Failed to create sink input: sink is suspended.

Any help or any other logs I can provide?

Many thanks,
TL

I have similar problem on F36. It’s almost a week now, but what I noticed is that when my audio output stops working, I switch to line in (headphones), then test the sound in settings and when I switch back to the default output which I’m using (speaker). Then it works for some time, but after few minutes is back to not working. I don’t know how to best describe it but, it looks like it somehow puts audio output to sleep if not used for longer time.

And I can confirm the issue with videos. First I thought that is related to Vivaldi as it tends to break after update, but then I tried Firefox and had the same issue - not playing videos, freezing / spinning.

Does anyone have solution?

For the videos, can you take a look at: Firefox stopped playing videos - #31 by kwizart

Thanks

Hi – thanks all for replying, for video yes I had already tried the “dnf swap ffmpeg-free ffmpeg --allowerasing” (I didn’t have ffmpeg-free so it didn’t do anything), and from other searches I also tried “dnf swap --allowerasing pipewire-pulseaudio pulseaudio”, and “dnf remove libswscale-free libavcodec-free”… all to no avail.

One detail I seem to remember from F34, I think pipewire didn’t work on F34 for me either so I believe I removed it via reinstalling pulse audio (with “dnf swap --allowerasing pipewire-pulseaudio pulseaudio”). Perhaps those settings carried over when I upgraded F34 directly to F36, and so now neither pulse audio nor pipewire work, perhaps?

If so, is there a command to reswap these, or something? I don’t know enough to be able to tell even which one is running, or what their respective statuses are (except for the pipewire status I posted), or if this is even the problem.

Thanks,
TL

Hi

I installed fedora 36 freshly on my new laptop (Asus zenbook 14 Oled). Sound is not coming from the laptop speakers, but if I connect my headphones/earphones then sound works fine. But not without that. I have tried every solution that I found on internet to fix this, but it is still same.

Also I noticed that when I go to my keyboard settings, gnome freezes for no reason.

Please, if someone knows how to fix this let us know. Or, will there be a fix in the next kernel updates?

Hi Mohammed,

Not sure if this will help your problem but here’s what I finally found out was the cause, and the fix, for mine.

It turns out the pulse audio ‘sink’ was ‘suspended,’ for some reason. I only noticed this because when trying to generate a sound using ‘aplay some-file.mp3’ in a console, either the stdout in the console or syslog showed a message that said " localhost.localdomain pulseaudio[1998]: Failed to create sink input: sink is suspended."

Googling around for this error, I found that the fix is to comment-out a setting called “load-module module-suspend-on-idle” in /etc/pulse/default.pa.

The edited default.pa file section looks like this, after comment-outing:

Automatically suspend sinks/sources that become idle for too long

#load-module module-suspend-on-idle

Then I killed and restarted pulse audio this way: “killall pulseaudio”, and it restarted automatically. Presto, sound!

Hope that helps with your issue!

All best,
TL

Hi TL,

I do not have default.pa in the path /etc/pulse/default.pa. What I do have is /etc/pulse/client.conf.

Thanks

Ok, and what is the content of /etc/pulse/client.conf?

This is what I have in the /etc/pulse/client.conf file.

# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.

## Configuration file for PulseAudio clients. See pulse-client.conf(5) for
## more information. Default values are commented out.  Use either ; or # for
## commenting.

; default-sink =
; default-source =
; default-server =
; default-dbus-server =

; autospawn = no
; daemon-binary = /usr/bin/pulseaudio
; extra-arguments = --log-target=syslog

; cookie-file =

; enable-shm = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB

; auto-connect-localhost = no
; auto-connect-display = no

That file tell you its content is all default.

Did you try aplay as suggested above by @tlp?

Hi Mohammed,

I’m facing the same issue on fresh install of F36, also got the /etc/pulse/client.conf file with contents:

# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.

## Configuration file for PulseAudio clients. See pulse-client.conf(5) for
## more information. Default values are commented out.  Use either ; or # for
## commenting.

; default-sink =
; default-source =
; default-server =
; default-dbus-server =

; autospawn = no 
; daemon-binary = /usr/bin/pulseaudio
; extra-arguments = --log-target=syslog

; cookie-file =

; enable-shm = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB

; auto-connect-localhost = no
; auto-connect-display = no

Did you find any solution related to this issue?

Thanks!

Hi Ammar ALi,

I tried every possible solution available on internet. I could not get the fix yet. I created a new thread (No Sound in Asus (Zenbook UX3402ZA_UX3402ZA) after the fresh installation of Fedora 36).

Which laptop are you using?

Hey Mohammed,

I’m using MSI raider ge75 i7 variant, before you mentioned your laptop I was thinking it was an issue due to nvidia but Zenbook comes with intel graphics so that can’t be the issue.

However, the issue is the exact same, no sound on speakers but works with headphones & bluetooth audio and it seems to be the issue with all linux distros at this point: I tried POP_OS latest, Ubuntu latest lts, and even Kali Linux latest, in the past I’ve experienced Kali to provide surprisingly good hardware compatibility.

I’ll be posting this comment on your thread as well to bump!