No sound in one headphone side

Hello, I have an Edifier W800BT headphone that works fine over bluetooth, but when connected via cable only outputs sound on the left side. The problem doesn’t seen to be on the cable itself, since my headphone works normally on my phone.

System information:

$ uname -a
Linux n 6.0.16-300.fc37.x86_64 #1 SMP PREEMPT_DYNAMIC Sat Dec 31 16:47:53 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
$ gnome-shell --version
GNOME Shell 43.2
$ aplay --list-devices
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC255 Analog [ALC255 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

alsamixer with headphone connected:

alsamixer withut headphone connected:

The headphone only giving sound on one side would most likely mean that it’s likely not inserted fully into the jack to make full stereo contact. Assuming it’s a wired analog headphone (ie, 1/8" jack - not USB), it seems unlikely to be a software problem unless you have it panned all the way to one side for some reason.

1 Like

Sorry, English is not my first language, what does “panned” mean here? The connector is the cylindrical one, and it seems to be connected all the way inside on both my computer and headphone.

Edit: nevermind, for some reason connecting it all the way inside (instead of about two-thirds, for some reason) is what limits the sound to one side.

1 Like

No worries and glad you got it figured out! I’ve definitely done the same thing before. “Panned” in stereo audio terms would mean that you intentionally set it to play on one side more than the other.

If you want to go down a rabbit hole of audio technicalities about it:

1 Like

Hello, I’d like to ask another question that’s confusing me about this topic.

I just tested this video on three different devices:

  1. On an ipad air 1 with the plug totally inserted, where it worked as expected with a sound on each side.
  2. On a redmi cellphone, both with the plug partially (headphone and/or cellphone) and totally inserted, where it didn’t work at all (which is troubling me because I tested it some days ago and it worked normally with the plug totally inserted as far as I remember), the sound was coming from the cellphone speakers.
  3. On my computer, where partially inserting the plug onto the headphone makes only the left sound be broadcast on both sides of the headphone. Meanwhile, fully inserting it makes the left sound be broadcast on the left side of the phone.

In those cases, I’m not so sure anymore where is the cause of the problem, because each of they seems to be incompatible to me. How can I make sure that full stereo contact is made? Can I somehow reasign the jack so that fully inserting it would make the sound stereo again on my computer (even at the cost of it not working my cellphone via cable)?