Nvidia 390 drivers stopped working with kernel 5.5 and probably also Nvidia 340

Nvidia 390 drivers stopped working with kernel 5.5 and probably also Nvidia 340. I was unable to get Nvidia-390 drivers to work with new kernel 5.5. Other people look to have the same problems. I posted here: https://bugzilla.rpmfusion.org/show_bug.cgi?id=5536 and other people confirm, there are more links to Nvidia forums.

If everyone with 390 and 340 drivers are unable to use kernel 5.5, what it will mean?

Give a nouveau driver an another try:  Possibly its work is good enough now.
rant:  Either “the Nvidia liberates the drivers”, or “an LTS-Kernel in Fedora”
– seems like a “neither”.

1 Like

I play complex 3D-graphical game called Transport Fever 2. Is nouveau so good now that I can try this game with it?

I think Nvidia390 isn’t working yet with 5.5.x - you’ll have to stick to 5.4.x for a while.
I don’t know the game but if it’s complex, forget nouveau. Maybe consider a Radeon card, or hopefully Nvidia will soon open source their drivers (or contribute to nouveau).

1 Like

I was also given this link https://gitlab.com/snippets/1937313 “NVIDIA 440.59 - Kernel 5.6 Patch” and at this link https://devtalk.nvidia.com/default/topic/1071186/linux/patch-for-legacy-driver-390-132-with-linux-5-5-x/ “Patch for legacy driver 390.132 with Linux-5.5.x” I was told that “underflow issue was a kernel bug, and got fixed in 5.5.6”. That seems to sound hopeful, maybe I have to just wait a while.

@florian thanks for advice. Yes, it’s very complex. It’s a “country simulator” with many towns where every citizen is simulated.

Kernel 5.5.6 appeared in repos, I tried it, no luck. Maybe meant kernel 5.6?

New maintainer for 390 assigned, work is said to be in progress: https://bugzilla.rpmfusion.org/show_bug.cgi?id=5536

2 Likes

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.