Nvidia driver not listed in nvidia-settings

Hello, everyone!
I’ve been trying to set up my drivers for several days already and this is what I have. I’ve used this instruction and stack and Step 10
Additionally, I had added nouveau to the blacklist

This is outputs

$ modinfo -F version nvidia
515.57
$ glxinfo | egrep "OpenGL vendor|OpenGL renderer"

OpenGL vendor string: AMD
OpenGL renderer string: AMD Radeon Vega 10 Graphics (raven, LLVM 14.0.0, DRM 3.46, 5.18.13-200.fc36.x86_64)
$ cat /etc/X11/xorg.conf.d/20-nvidia.conf
#This file is provided by xorg-x11-drv-nvidia
#Do not edit

Section "OutputClass"
	Identifier "nvidia"
	MatchDriver "nvidia-drm"
	Driver "nvidia"
	Option "AllowEmptyInitialConfiguration"
	Option "SLI" "Auto"
	Option "BaseMosaic" "on"
	Option "PrimaryGPU" "yes"
EndSection

Section "ServerLayout"
	Identifier "layout"
	Option "AllowNVIDIAGPUScreens"
EndSection

Nvidia card successfully listed in fedora settings:

BUT, not listed in nvida-settings:

As result, I can’t use Davinci resolve and have a bad FPS rate in games :frowning:

EDIT 1:

I catched record in “Problem reporting” app

image

EDIT 2:
Nvidia bug report - Filebin | 6nj54p6qp3e5ab13

1 Like

Any ideas @t0xic0der (as the authority on this bit :))

Wow, this guy is a legend! I saw few of his posts, if he could help me - I’ll be so happy

1 Like

The problem was so easy!
I’d just deleted xorg.conf and it starts work…
Now I’m feeling so dummy :smile:

1 Like

You have two GPU, NVIDIA and AMD : at the beginning, driver not shown in nvidia-settings only means AMD used so the information is exact. After you delete xorg.conf … what happened as usually hardware configuration is in hardware layer BIOS/EFI.

I had custom xorg.config, about what I successfully forgotten
Currently, I’m fighting with a different issue, my system when I use Nvidia suddenly hangs, and only a hard reboot helps.