NVIDIA driver not working after Fedora 33 install

That means the the binary is working. (Hooray!) @florian @alciregi

Now let’s help you with your problem.

1 Like

Yes? What? What happens?

It’s probably some configuration issue. Maybe the RPM Fusion documentation for nvdia drivers and CUDA can help. Or the installer tool from t0xic0der, though you seem to have run into some trouble.
https://rpmfusion.org/Howto/NVIDIA
https://rpmfusion.org/Howto/CUDA

If those don’t work, there’s also the negativo17 repo. https://negativo17.org/nvidia-driver/ The downside is that it’s a third party repo, and I prefer to keep those to a minimum. The plus side is that it’s focused on making it easy to install nvidia and CUDA drivers, at least as easy as that mess can be made. It’s been working fine for me through many Fedora releases and upgrades, especially with the akmod package (dkms gave me occasional trouble). I’m currently on kernel 5.8.16-200 (F32, but will be upgrading to F33 soon).

As a side note, gotta love it when someone asks for help with something known to work and the recommendations are to buy different hardware or make major system changes… Tis the internet.

Thank you, I appreciate that.

At the moment, when I run sudo dnf upgrade I get a list of skipped packages with conflicts:

Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 nvidia-driver-libs                          x86_64                3:455.32.00-1.el8                 cuda-rhel8-x86_64                 78 M
 nvidia-persistenced                         x86_64                3:455.32.00-1.el8                 cuda-rhel8-x86_64                 98 k
Skipping packages with broken dependencies:
 cuda-11-1                                   x86_64                11.1.1-1                          cuda-rhel8-x86_64                2.8 k
 cuda                                        x86_64                11.1.1-1                          cuda-rhel8-x86_64                2.7 k
 cuda-drivers                                x86_64                455.32.00-1                       cuda-rhel8-x86_64                7.0 k
 cuda-runtime-11-1                           x86_64                11.1.1-1                          cuda-rhel8-x86_64                2.7 k
 dnf-plugin-nvidia                           noarch                2.0-1.el8                         cuda-rhel8-x86_64                 12 k
 nvidia-driver                               x86_64                3:455.32.00-1.el8                 cuda-rhel8-x86_64                2.4 M
 nvidia-modprobe                             x86_64                3:455.32.00-1.el8                 cuda-rhel8-x86_64                 74 k
 nvidia-settings                             x86_64                3:455.32.00-1.el8                 cuda-rhel8-x86_64                1.7 M
 nvidia-xconfig                              x86_64                3:455.32.00-1.el8                 cuda-rhel8-x86_64                262 k

How do I fix these? These appeared after using the installation tool.

I see your point but in this case I actually appreciated the suggestion. I didn’t realize that non-Nvidia GPUs could meet my needs. Still, I need my current setup to work, and I know that there are probably other people out there who run into the same problem, get frustrated, don’t know how to get help, and then switch to Windows.

I have a GEFORCE GTX 1050, and the drivers I needed were gotten from rpmfusion and installed with “dnf install kernel-devel kernel-headers akmod-nvidia nvidia* xorg-x11-drv-nvidia*”. Then when that was done I just rebooted after a short wait and it worked with no errors.

I looked for your card and found it is a legacy card and supported by the 340 drivers. Iinstructions for downloading and installing the appropriate drivers are here. I see that you have the 455 drivers installed and they are too new to support your card. You will need to remove the currently installed drivers and install the ones that are correct for your card by explicitly giving the version number in the dnf command. To follow those directions you will have to enable the rpmfusion repo and disable the cuda-rhel8-x86_64 repo. It should also fix the conflict issues seen when trying to do an upgrade. You do not need all those cuda packages in most cases so the packages skipped with dependency issues should be removed as well as any nvidia packages already installed.

It is quite possible the nvidia drivers that are the correct version (340) to support your card will not work with the latest kernels. You are free to try them but may need to get a newer card.

Just for your information though. Here you can see that support for your card was EOL in November 2019. It may or may not work for you.

2 Likes

Not quite. The “9” series is legacy, but OP’s Geforce GTX 960 is a “900” series card which is supported by the current drivers.

See the “Supported Products” tab: https://www.nvidia.com/Download/driverResults.aspx/166177/en-us

2 Likes

OK! I missed that :frowning:
but still @hx2a installed his driver from the RHEL8 repo and there often are conflicts. The rpmfusion repo does not usually have those conflicts, so I still recommend removal of all the cuda and nvidia packages then reinstall from the rpmfusion repo.

It’s confusing how the RHEL8 packages got there. Is it from t0xic0der’s install tool? The OP clearly shows using the rpmfusion repo.

CUDA is a requirement, but it does require extra steps when using rpmfusion.

Something seems messed up. Maybe it’s time to backtrack and uninstall whatever is currently installed, and then follow the details for one method (rpmfusion, t0xic0der’s tool, negativo17).

For my use the xorg-x11-drv-nvidia-cuda.x86_64 and xorg-x11-drv-nvidia-cuda-libs.x86_64 packages, both from the rpmfusion-nonfree-updates repo meet my needs. It is possible more might be needed, but that is up to testing first and adding more if needed after the GPU drivers are working properly.

AFAIK t0xic0der’s tool uses rpmfusion. I have not used it, but have been watching the thread on it. Having more than one repo enabled that can provide the same package often causes conflict problems.

I tried to fix the package conflicts and made a giant mess, so I just reinstalled Fedora completely. It’s not a big deal, I had installed Fedora a few days prior so it was easy to get back to where I was. I have not tried installing anything Nvidia related yet.

What should I try next that I haven’t tried already?

Note: I have surgery tomorrow and won’t actually be able to test anything or respond for about a week. I’ll pick this up when I return.

Probably, with a fresh install, the best thing to do is add the rpmfusion.org repo’s (free and non-free) to your repo’s. To do that, go to their site and follow the instructions for adding their repo’s on Fedora 33 (" Enable RPM Fusion on your system and verifying RPM Fusion’s signing keys"). Then follow their instuctions to install NVIDIA, see Howto NVIDIA.

Please read that Howto in detail, coz many sections can be suited for your situation (esp. the Special Notes people tend to ignore, don’t know why).

You should end with a working system. If not, return here and post the issues you’ve encountered. Have fun!

Hoped the surgery went well.

It uses RPM Fusion repositories as reference so I highly doubt if that is the case.

Once you reinstall the workstation, just run my tool. It would automate everything from adding the repositories to enabling it and to installing the drivers for you in a convenient manner.

Hope that your surgery goes/has gone well @hx2a. :smile:

Follow these steps once you get yourself a fresh installation of F33.

  1. Download this. This would get you the v0.3.0 of the tool which is the most recent as of 8th Oct 2020 and folks have reported it to be working just fine on Fedora 33.
  2. Make the binary you just downloaded have the permission to execute by running this command
    sudo chmod +x NVAutoInstFedora32.
  3. Run sudo ./NVAutoInstFedora32 --help to know about the kinds of stuff this tool is capable of.
  4. Run sudo ./NVAutoInstFedora32 --compat to see if your device is compatible with the tool and the proprietary drivers from the RPM Fusion repositories. (Most likely yes, but checking once again won’t do much harm I think)
  5. Run sudo ./NVAutoInstFedora32 --rpmadd to add and enable the RPM Fusion repositories for the proprietary NVIDIA drivers for Fedora 33. The tool would first check for the availability of the repositories to see if it has been already installed (if so it would automatically abort), the check the availability of an active internet connection and finally add and enable the said repositories.
  6. Run sudo ./NVAutoInstFedora32 --driver to begin installing the drivers and its dependencies. The tool would first check the presence of any driver or dependencies to see if they are already installed and skip those to save time and begin installation if an active internet connection is available and if the first the repositories have been added. (This step won’t work if you don’t follow step #5)
  7. Once it has completed, the tool would automatically exit. You would want to make a reboot now.

Notes

  1. The code is open so I would implore you to take a look should you think that the tool is doing funny things in the background :laughing: or if you want to contribute to make this tool better :heart_eyes:
  2. The tool follows the RPM Fusion repository instructions as reference so there is no reason as to why you would want to follow the instructions line-by-line there when you are doing exactly the same thing here.

Feel free to tag me in should you have questions.

1 Like

Thanks! Happily, the surgery went very well and I am recovering quickly. :slight_smile: Unfortunately, the driver install did not. :frowning: I followed the exact steps in @t0xic0der’s post and I still get the “NVIDIA kernel module missing. Falling back to nouveau” message on startup.

Any other ideas? Is it possible there is a hardware issue or that my graphics card is deficient? Why would this work for others and not me?

If you did not install the kernel-headers package it cannot build the kmod for nvidia.

Shouldn’t @t0xic0der’s driver tool install them for me? Is there a way to check that the kmod was built correctly?

The tool is supposed to make it happen. I believe this is a packaging issue from the RPM Fusion end. Let me quickly check the bugzilla if at all there exists any issue regarding this and if not, file one.

Right. The tool installs all dependencies and builds the kernel modules and then exits out only when it has detected that the kernel modules were successfully built. The way I see it - the driver was correctly installed but one of the issues posted at my repo also state the same thing regarding this.

If the kernel modules have been successfully built, then wouldn’t the following commands work?

$ modinfo -F version nvidia
modinfo: ERROR: Module nvidia not found.
$ sudo modprobe -v nvidia
modprobe: FATAL: Module nvidia not found in directory /lib/modules/5.8.18-300.fc33.x86_64
$ sudo lsmod | grep nvidia
$