NVIDIA driver not working after Fedora 33 install

Right. They are supposed to exit with code zero. Something’s not right.

I mean even if you install not with my tool and follow the steps provided by the RPM Fusion repos, you are most likely going to end up with the same result - unless the bug causing the kernel module build failure is resolved. :confused:

In my first attempt described in my original post, I followed these steps:

sudo dnf install fedora-workstation-repositories
sudo dnf config-manager --set-enabled rpmfusion-nonfree-nvidia-driver
# reboot
# verify:
sudo dnf repository-packages rpmfusion-nonfree-nvidia-driver info
sudo dnf install akmod-nvidia nvidia* xorg-x11-drv-nvidia*
# wait 5 minutes, this should show the version number
modinfo -F version nvidia
# reboot, should have nvidia tools installed now

And that modinfo command would show me a version number (455…). Perhaps the tool didn’t wait long enough for everything to build? When I used your tool I rebooted right after it was finished, so if something was supposed to happen after 5 minutes I didn’t give it a chance.

And what do I do now? Can I get it to try again?

EDIT:I’m eating my words right now, by running a sudo dnf remove *nvidia* And then the commands as described i the above post. I was able to get my nvidia drivers working. hx2a, I think that if you’re getting the output of that modinfo command, things should be working.

I’m Actually having a similar issue with a 2080ti, Secure boot is off on my machine as well, And I’ve tried installing the drivers manually through RPM Fusion, and witha fresh install using t0xic0der’s script.

What’s odd is that this works perfectly fine on my optimums laptop with a1060 in it.

hx2a, can you share what motherboard you might have? I’m wondering if this is a hardware incomparably , that’s unrelated to the card?

I just tried that remove command and repeated the previous steps and it still doesn’t work. I waited for the output of that modinfo command to give the correct version number.

Sure! I have an Asus P8Z77-M Pro motherboard. I’d be surprised if that was it, but what do I know. The nvidia drivers worked fine with Ubuntu.

So, is everyone out of ideas? @t0xic0der?

The only idea I have left is to try moving the 1080 card I have in another computer to this one to see if it works at all. That would at least tell me if there is some issue with the 960 card currently in this machine.

1 Like

The thing is, the steps described by everyone are correct (well, apart from what @tetrodotoxin mentioned as you need not install “everything” from Nvidia to make sure that it runs) but it is more of a kernel module building issue that fails the installation’s final set up. I would ask you to try installing the kernel-headers package for the kernel installed like @computersavvy mentioned to see if it is the reason behind the inability to build the kernel modules.

Let me know if it works. I think, I might need to snatch my brother’s Pavilion to test and replicate this issue.

I have not used his installer as I had a working system before he created it.
You can check to see if the kmod was built properly with a simple dnf command.

 sudo dnf list '*nvidia*'  

On my system I get the following

Installed Packages
akmod-nvidia.x86_64                                                         3:455.38-1.fc32                                   @rpmfusion-nonfree-updates
kmod-nvidia-5.8.16-200.fc32.x86_64.x86_64                                   3:455.38-1.fc32                                   @@commandline             
kmod-nvidia-5.8.18-200.fc32.x86_64.x86_64                                   3:455.38-1.fc32                                   @@commandline             
kmod-nvidia-5.9.8-100.fc32.x86_64.x86_64                                    3:455.38-1.fc32                                   @@commandline             
nvidia-persistenced.x86_64                                                  3:455.38-1.fc32                                   @rpmfusion-nonfree-updates
nvidia-settings.x86_64                                                      3:455.38-1.fc32                                   @rpmfusion-nonfree-updates

Note that the 3 kmod packages that go with my 3 kernels are automatically built by akmod, and show as installed from the commandline. I have not even rebooted to the 5.9 kernel yet.
If yours do not show that then the kmod is not being built.

1 Like

No dice. The kernel headers were already installed. I went through the install steps and it still doesn’t work. :sob: I am still getting the “NVIDIA kernel module missing. Falling back to nouveau” message.

From @computersavvy’s suggestion I tried the command:

$ sudo dnf list '*nvidia*'

Here is the result:

Last metadata expiration check: 0:07:03 ago on Thu 19 Nov 2020 09:47:43 PM EST.
Installed Packages
akmod-nvidia.x86_64                                                           3:455.45.01-1.fc33                                    @rpmfusion-nonfree-updates
kmod-nvidia-5.9.8-200.fc33.x86_64.x86_64                                      3:455.45.01-1.fc33                                    @@commandline             
nvidia-persistenced.x86_64                                                    3:455.45.01-1.fc33                                    @rpmfusion-nonfree-updates
nvidia-settings.x86_64                                                        3:455.45.01-1.fc33                                    @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia.x86_64                                                    3:455.45.01-1.fc33                                    @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-kmodsrc.x86_64                                            3:455.45.01-1.fc33                                    @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64                                               3:455.45.01-1.fc33                                    @rpmfusion-nonfree-updates

I see the kmod package so it must have been built successfully. What else could be wrong if it was built correctly?

The nvidia-persistenced package was installed by me after I noticed I didn’t have it like it is on @computersavvy’s computer. Adding it didn’t change anything.

BTW on my other computer with the 1080 card, CUDA stopped working and in my attempt to fix it I messed up the NVidia drivers also. I was able to get everything working again though. I’m getting a lot of practice installing NVidia drivers. :slight_smile:

Like I saw it coming. The tool automatically should have done this for you, and in fact it did - though the packaging issues could not make it happen.

That sucks I know. The best alternative would be to keep using the i915 card (should you have one) and force it to perform better by following this guide.

That is of course a redirection and not a solution. We need to wait on our end before we have more information as to why this is happening. I would suggest you to go ahead and file an issue stating the above issues precisely in the RPM Fusion’s bugzilla.

i didn’t read about secure boot in this Thread before, but have you checked your bios settings? Maybe you have secure boot enabled. That prevents loading the module because RPMFusion do not provide signed modules.

AFAIK ubuntu can deal with secureboot installation, you have to enter a password that will be used. I didn’t know the details, but ubuntu generates an certificate store for your secureboots ands signs new driver automatically. So maybe you have to switch off secure boot in your bios Settings. :wink:

4 Likes

Bloody hell. That was it.

Your comment about Ubuntu signing modules and RPMFusion not being able to provided the necessary clue that there was a relevant difference and I needed to research this further. I remember previously reading something about secure boot and did go into the Bios to disable that but must have gotten confused and done it wrong.

For the motherboard on this computer, disabling secure boot takes a few steps. I had to go into the Bios, then Advanced => Boot, scroll down to Secure Boot. The screen says Secure Boot state "enabled" but that is not a changable dropdown. I had to go into Key Management and delete the keys. Now the previous screen says Secure Boot state "disabled". When I rebooted, I did not get that error message.

Now I just have to install the CUDA stuff but that should be straightforward.

Thank you, @truster, for the commenting and providing the helpful clue that helped me solve this. And thank you @t0xic0der and everyone else who posted, for sticking with me and this thread.

Let this thread serve as a warning to others that disabling secure boot is critical and one should carefully research this that it was done correctly before proceeding with NVidia driver installations.

Relevant helpful references:


1 Like

I suggest you simply install these packages from rpmfusion (of course yours will be the f33 versions).

xorg-x11-drv-nvidia-cuda.x86_64                                                  3:455.38-1.fc32                                         @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.x86_64                                             3:455.38-1.fc32                                         @rpmfusion-nonfree-updates

Then try and see if it meets your needs for cuda. It serves for me, but you may need more than that provides with what you do.

Good advice. I just did that and it worked. Much easier than messing downloading the rpm files from the NVidia website. Thank you!

@hx2a Please mark @truster’s reply as the solution as that would help folks with the same issue.