Nvidia drivers not working anymore after kernel 6.0.x update and even after kernel down grade

Hello, after having updated to kernel 6.0.5 my nvidia driver’s stopped working and my system felled back on nouveau. I searched here and i found someone with my same issue. i tried the given answer (i.e., downgrade to 5.19.xx) and wait for stable drivers, however akmods still did not work.
Here’s the output given by akmods:

Some additional info:

image

Instal Rpm Fusion nonfree repository with following link

After that you can go to the gnome app centre and see the update for nvidia driver

dnf says that the nvidia driver is already up to date
image

Have you tried to uninstall the driver dnf remove xorg-x11-drv-nvidia\* and reinstall dnf install akmod-nvidia . Also you mentioned you downgraded the kernel did you remove it or reboot into an earlier kernel.

Thanks in advance,

I just ran dnf remove *nvidia* and dnf install akmod-nvidia xorg-x11-drv-nvidia
And after having rebooted the system i’m back where i was at before.

I just pressed shift when it was booting up and chose the 5.19.xx grub file
running uname -r gives this

$ uname -r
5.19.16-200.fc36.x86_64

I don’t know why your driver did not update as the latest nvidia driver in rpmfusion is 520.56. You might also try and uninstall then reinstall the latest kernel.Also make sure kernel-devel updated as well.

I agree with straycat.

  1. boot to kernel 5.19.16
  2. dnf remove kernel*6.0.5*
  3. dnf upgrade --refresh
  4. After the upgrade and installation of the latest kernel completes wait at least 5 minutes
  5. dnf list installed kmod-nvidia* to see if the module was properly built for the new kernel
  6. If properly built then reboot and the nvidia driver should work.

I have had no problem with the latest kernel and the nvidia 520 drivers.

1 Like

Thank you all very much, the NVIDIA driver 520.56.06 just became available and, after updating my drivers the issue was solved. I’m still unsure why booting into a different kernel didn’t result in the old drivers working but I’ll investigate on this on my own.