NVIDIA kernel drivers are not loading when installing using rpm-ostree with Silverblue/Kinoite

Hello

I started configure a fresh Kinoite installation with NVIDIA GPU. I have followed the instruction on the rpmfusion website added the repository and ran the following commands from the rpmfusion website.

sudo rpm-ostree install akmod-nvidia xorg-x11-drv-nvidia
systemctl reboot
sudo rpm-ostree kargs --append=rd.driver.blacklist=nouveau --append=modprobe.blacklist=nouveau --append=nvidia-drm.modeset=1
systemctl reboot

After rebooting the computer I check rpm-ostree status:

$ rpm-ostree status
State: idle
Deployments:
‚óŹ fedora:fedora/35/x86_64/kinoite
                   Version: 35.20220327.0 (2022-03-27T00:49:24Z)
                BaseCommit: 932f2d216e7d3fd67189bcb1d6c756ffa4ff779546e229ce5d15770c4f463055
              GPGSignature: Valid signature by 787EA6AE1147EEE56C40B30CDB4639719867C58F
           LayeredPackages: akmod-nvidia oddjob oddjob-mkhomedir samba samba-common-tools samba-winbind
                            samba-winbind-clients samba-winbind-krb5-locator xorg-x11-drv-nvidia
             LocalPackages: rpmfusion-free-release-35-1.noarch rpmfusion-nonfree-release-35-1.noarch

It looks like the kargs command updated the kernel arguments, the append configure appear in the current kernel arguments line. I viewed the current kernel arguments with the karg --editor

$ rpm-ostree kargs --editor

# Current kernel arguments are shown below, and can be directly edited.
# Empty or commented lines (starting with '#') will be ignored.
# Individual kernel arguments should be separated by spaces, and the order 
# is relevant.
# Also, please note that any changes to the 'ostree=' argument will not be
# effective as they are usually regenerated when bootconfig changes.

rhgb quiet root=UUID=8ab03901-f0a0-4e37-a011-34ef1315c768 rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1

When verify if the nvidia modules has loaded using lsmod the nvidia driver is not listed and open the NVIDIA settings application. it does not appear the nvidia modules have not loaded.

$ lsmod | grep nvidia

Does not return an output

$ lsmod | grep nouveau
nouveau              2387968  38
mxm_wmi                16384  1 nouveau
wmi                    32768  2 mxm_wmi,nouveau
video                  57344  1 nouveau
i2c_algo_bit           16384  1 nouveau
drm_ttm_helper         16384  1 nouveau
ttm                    81920  2 drm_ttm_helper,nouveau
drm_kms_helper        315392  1 nouveau
drm                   634880  20 drm_kms_helper,drm_ttm_helper,ttm,nouveau

The NVIDIA setting application dose not show any display setting more evidence the system is not loading the nvidia drives. In the comments of the buffer that appears after running the rpm-ostree kargs --editors there is a note:

# Also, please note that any changes to the 'ostree=' argument will not be
# effective as they are usually regenerated when bootconfig changes.

It appears the kernel command line option (kernel arguments) are loading, I see the blacklist nouveau and nvidia drm setting when I exame the /proc/cmdline file

$ cat /proc/cmdline
BOOT_IMAGE=(hd0,gpt2)/ostree/fedora-5fc3b3e4876af9d9cbc1b62fbd2a8d03ab6a1970cae87dda14baa70fe22fb940/vmlinuz-5.16.16-200.fc3
5.x86_64 rhgb quiet root=UUID=8ab03901-f0a0-4e37-a011-34ef1315c768 ostree=/ostree/boot.0/fedora/5fc3b3e4876af9d9cbc1b62fbd2a
8d03ab6a1970cae87dda14baa70fe22fb940/0 rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1

I am at a lost on where to look next. Do I need to wait for a kernel update?

References

Thank you
Aaron

Make sure that your secure boot is disabled

NVIDIA drivers loaded after disabling secure boot. Thank you.