Nvidia Kernel Module again missing after update

Hi,
I use Fedora 35 on a Dell XPS 15 9500 with an Nvidia GPU. After installing the propriatary nvidia software via device drivers in the software app Fedora was automatically switiching from wayland to xorg after a while thereby making the device run perfectly with my GPU. After a recent software update, the whole thing somehow was reverting back to claiming “nvidia kernel module missing”. Is there any way to make the GPU properly work again. Am not that experienced with nvidia drivers and setups. Thanks for responding!

We need to see two different things.

  1. what is the output of inxi -Gxx? (you may need to install inxi)
  2. What version of the nvidia drivers are installed. dnf list installed *nvidia* It seems the update on f35 with the nvidia driver now replaces the 470 driver with the 495 driver and that update also removed support for some older nvidia cards. The 495 driver is also updated for better support of wayland, but if wayland is not your goal then it is not actually needed.

If you are a victim of the driver update it is possible to revert back to the 470 driver and recover. This is what worked for some.

His issue was that he did not have the rpmfusion repos enabled, but with those repos the fix in that post will work for almost everyone.

If this works by reverting to the 470 driver then you will need to add a line in /etc/dnf/dnf.conf excludepkg=*nvidia* to prevent the automatic update to the 495 driver in the future.

Thanks for your quick response.
My output of inxi -Gxx is the following:

Graphics:
  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Dell driver: i915 
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:9bc4 
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: Dell 
  driver: nouveau v: kernel bus-ID: 01:00.0 chip-ID: 10de:1f95 
  Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo 
  bus-ID: 1-11:3 chip-ID: 0bda:5510 
  Display: wayland server: X.Org 1.21.1.3 compositor: gnome-shell driver: 
  loaded: modesetting unloaded: fbdev,vesa resolution: 3840x2400~60Hz 
  s-dpi: 96 
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.2.5 
  direct render: Yes 

The drivers installed are highlighted like this:

akmod-nvidia.x86_64                        3:495.44-1.fc35 @rpmfusion-nonfree-nvidia-driver
kmod-nvidia-5.14.14-300.fc35.x86_64.x86_64 3:495.44-1.fc35 @@commandline        
kmod-nvidia-5.14.16-301.fc35.x86_64.x86_64 3:495.44-1.fc35 @@commandline        
kmod-nvidia-5.14.17-301.fc35.x86_64.x86_64 3:495.44-1.fc35 @@commandline        
nvidia-settings.x86_64                     3:495.44-1.fc35 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia.x86_64                 3:495.44-4.fc35 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-kmodsrc.x86_64         3:495.44-4.fc35 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.x86_64            3:495.44-4.fc35 @rpmfusion-nonfree-nvidia-driver

I would prefere to work with wayland - I thought, I would have to switch away from wayland to make the gpu work, but in general I would prefere to make the new drivers work. Is there a way to do this - otherwise, I will try to revert to the 470 driver…
Best

The GTX 1650 is supported by the 495 driver so it should not be necessary to revert to the 470 driver. I have a ‘Geforce GTX 1660 Ti’ in my laptop with fedora 35 and using the 495.44 driver.

Another issue that is seen with F35 and the 495 driver is that earlier kernels would still use the 470 driver but the more recent kernels sometimes cause secure boot to interfere.

Please post the output of dmesg | grep -iE 'secure|nvidia' so we can see exactly what is happening during boot. A new boot before running that is preferred.

1 Like

This is the result:

dmesg | grep -iE 'secure|nvidia'
[    0.000000] Command line: BOOT_IMAGE=(hd0,gpt2)/vmlinuz-5.14.17-301.fc35.x86_64 root=UUID=792ee388-5941-4707-b022-f6cc8d58c348 ro rootflags=subvol=root rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1
[    0.000000] secureboot: Secure boot disabled
[    0.010374] secureboot: Secure boot disabled
[    0.080772] Kernel command line: BOOT_IMAGE=(hd0,gpt2)/vmlinuz-5.14.17-301.fc35.x86_64 root=UUID=792ee388-5941-4707-b022-f6cc8d58c348 ro rootflags=subvol=root rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1
[    0.767667] integrity: Loaded X.509 cert 'Fedora Secure Boot CA: fde32599c2d61db1bf5807335d7b20e4cd963b42'
[    7.538975] nouveau 0000:01:00.0: NVIDIA TU117 (167000a1)

That shows that secure boot is disabled and thus is not the issue. The kernel command line seems correct also.

The 470 driver did not receive the updates nvidia put into the 495 driver to make it more compatible with wayland so reverting to that still would not allow wayland with the nvidia drivers.

Lets look at what the journalctl says about nvidia at the last boot.
journalctl -b | grep -i nvidia

journalctl -b | grep -i nvidia
Nov 17 20:32:27 fedora kernel: Command line: BOOT_IMAGE=(hd0,gpt2)/vmlinuz-5.14.17-301.fc35.x86_64 root=UUID=792ee388-5941-4707-b022-f6cc8d58c348 ro rootflags=subvol=root rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1
Nov 17 20:32:27 fedora kernel: Kernel command line: BOOT_IMAGE=(hd0,gpt2)/vmlinuz-5.14.17-301.fc35.x86_64 root=UUID=792ee388-5941-4707-b022-f6cc8d58c348 ro rootflags=subvol=root rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1
Nov 17 20:32:27 fedora dracut-cmdline[319]: Using kernel command line parameters:  rd.driver.pre=btrfs   BOOT_IMAGE=(hd0,gpt2)/vmlinuz-5.14.17-301.fc35.x86_64 root=UUID=792ee388-5941-4707-b022-f6cc8d58c348 ro rootflags=subvol=root rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1
Nov 17 20:32:33 fedora systemd[1]: Starting Fallback to nouveau as nvidia did not load...
Nov 17 20:32:34 fedora kernel: nouveau 0000:01:00.0: NVIDIA TU117 (167000a1)
Nov 17 20:32:34 fedora systemd[1]: Finished Fallback to nouveau as nvidia did not load.
Nov 17 20:32:34 fedora audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=nvidia-fallback comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Nov 17 20:32:53 fedora nvidia-settings-user.desktop[2729]: ERROR: Unable to find display on any available system

BTW, you can keep the formatting seen on your screen with copy & paste if you use the </> button above to surround the pasted text with the preformatted text code tags.

2 Likes
journalctl -b | grep -i nvidia
Nov 17 20:32:27 fedora kernel: Command line: BOOT_IMAGE=(hd0,gpt2)/vmlinuz-5.14.17-301.fc35.x86_64 root=UUID=792ee388-5941-4707-b022-f6cc8d58c348 ro rootflags=subvol=root rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1
Nov 17 20:32:27 fedora kernel: Kernel command line: BOOT_IMAGE=(hd0,gpt2)/vmlinuz-5.14.17-301.fc35.x86_64 root=UUID=792ee388-5941-4707-b022-f6cc8d58c348 ro rootflags=subvol=root rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1
Nov 17 20:32:27 fedora dracut-cmdline[319]: Using kernel command line parameters:  rd.driver.pre=btrfs   BOOT_IMAGE=(hd0,gpt2)/vmlinuz-5.14.17-301.fc35.x86_64 root=UUID=792ee388-5941-4707-b022-f6cc8d58c348 ro rootflags=subvol=root rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1
Nov 17 20:32:33 fedora systemd[1]: Starting Fallback to nouveau as nvidia did not load...
Nov 17 20:32:34 fedora kernel: nouveau 0000:01:00.0: NVIDIA TU117 (167000a1)
Nov 17 20:32:34 fedora systemd[1]: Finished Fallback to nouveau as nvidia did not load.
Nov 17 20:32:34 fedora audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=nvidia-fallback comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Nov 17 20:32:53 fedora nvidia-settings-user.desktop[2729]: ERROR: Unable to find display on any available system
[heikoschmid@fedora ~]$ 


How about doing a reinstall of everything nvidia just to see what happens.
sudo dnf remove kmod-nvidia && sudo dnf reinstall *nvidia*
Follow that with a reboot.

Unfortunatelly that did not help - the problem is still there. But I received some error message, while the software was reinstalled

Transaktion wird ausgeführt
  Vorbereitung läuft    :                                                   1/1 
  Neuinstallieren       : xorg-x11-drv-nvidia-libs-3:495.44-4.fc35.x86_    1/10 
  Neuinstallieren       : xorg-x11-drv-nvidia-kmodsrc-3:495.44-4.fc35.x    2/10 
  Neuinstallieren       : nvidia-settings-3:495.44-1.fc35.x86_64           3/10 
  Ausgeführtes Scriptlet: xorg-x11-drv-nvidia-3:495.44-4.fc35.x86_64       4/10 
  Neuinstallieren       : xorg-x11-drv-nvidia-3:495.44-4.fc35.x86_64       4/10 
  Ausgeführtes Scriptlet: xorg-x11-drv-nvidia-3:495.44-4.fc35.x86_64       4/10 
  Neuinstallieren       : akmod-nvidia-3:495.44-1.fc35.x86_64              5/10 
  Ausgeführtes Scriptlet: akmod-nvidia-3:495.44-1.fc35.x86_64              5/10 
  Aufräumen             : nvidia-settings-3:495.44-1.fc35.x86_64           6/10 
  Ausgeführtes Scriptlet: xorg-x11-drv-nvidia-3:495.44-4.fc35.x86_64       7/10 
  Aufräumen             : xorg-x11-drv-nvidia-3:495.44-4.fc35.x86_64       7/10 
  Aufräumen             : akmod-nvidia-3:495.44-1.fc35.x86_64              8/10 
  Aufräumen             : xorg-x11-drv-nvidia-kmodsrc-3:495.44-4.fc35.x    9/10 
  Aufräumen             : xorg-x11-drv-nvidia-libs-3:495.44-4.fc35.x86_   10/10 
  Ausgeführtes Scriptlet: akmod-nvidia-3:495.44-1.fc35.x86_64             10/10 
  Ausgeführtes Scriptlet: xorg-x11-drv-nvidia-libs-3:495.44-4.fc35.x86_   10/10 
Failed to connect to bus: Das Argument ist ungültig
Failed to connect to bus: Das Argument ist ungültig

Failed to connect to bus: Das Argument ist ungültig
Failed to connect to bus: Das Argument ist ungültig

  Überprüfung läuft     : akmod-nvidia-3:495.44-1.fc35.x86_64              1/10 
  Überprüfung läuft     : akmod-nvidia-3:495.44-1.fc35.x86_64              2/10 
  Überprüfung läuft     : nvidia-settings-3:495.44-1.fc35.x86_64           3/10 
  Überprüfung läuft     : nvidia-settings-3:495.44-1.fc35.x86_64           4/10 
  Überprüfung läuft     : xorg-x11-drv-nvidia-3:495.44-4.fc35.x86_64       5/10 
  Überprüfung läuft     : xorg-x11-drv-nvidia-3:495.44-4.fc35.x86_64       6/10 
  Überprüfung läuft     : xorg-x11-drv-nvidia-kmodsrc-3:495.44-4.fc35.x    7/10 
  Überprüfung läuft     : xorg-x11-drv-nvidia-kmodsrc-3:495.44-4.fc35.x    8/10 
  Überprüfung läuft     : xorg-x11-drv-nvidia-libs-3:495.44-4.fc35.x86_    9/10 
  Überprüfung läuft     : xorg-x11-drv-nvidia-libs-3:495.44-4.fc35.x86_   10/10 

Reinstalliert:
  akmod-nvidia-3:495.44-1.fc35.x86_64                                           
  nvidia-settings-3:495.44-1.fc35.x86_64                                        
  xorg-x11-drv-nvidia-3:495.44-4.fc35.x86_64                                    
  xorg-x11-drv-nvidia-kmodsrc-3:495.44-4.fc35.x86_64                            
  xorg-x11-drv-nvidia-libs-3:495.44-4.fc35.x86_64

Sorry for the german - hope this helps somehow…

Don’t know if that helped, but you are definitely missing some of the packages I have.

# dnf list installed *nvidia*
Installed Packages
akmod-nvidia.x86_64                                               3:495.44-1.fc35                         @rpmfusion-nonfree-updates
kmod-nvidia-5.14.15-300.fc35.x86_64.x86_64                        3:495.44-1.fc35                         @@commandline             
kmod-nvidia-5.14.16-301.fc35.x86_64.x86_64                        3:495.44-1.fc35                         @@commandline             
kmod-nvidia-5.14.17-301.fc35.x86_64.x86_64                        3:495.44-1.fc35                         @@commandline             
nvidia-modprobe.x86_64                                            3:495.44-1.fc35                         @rpmfusion-nonfree-updates
nvidia-persistenced.x86_64                                        3:495.44-1.fc35                         @rpmfusion-nonfree-updates
nvidia-settings.x86_64                                            3:495.44-1.fc35                         @rpmfusion-nonfree-updates
nvidia-xconfig.x86_64                                             3:495.44-1.fc35                         @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia.x86_64                                        3:495.44-4.fc35                         @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda.x86_64                                   3:495.44-4.fc35                         @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.i686                                3:495.44-4.fc35                         @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.x86_64                              3:495.44-4.fc35                         @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-devel.x86_64                                  3:495.44-4.fc35                         @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-kmodsrc.x86_64                                3:495.44-4.fc35                         @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.i686                                     3:495.44-4.fc35                         @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64                                   3:495.44-4.fc35                         @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-power.x86_64                                  3:495.44-4.fc35                         @rpmfusion-nonfree-updates

The kmod-nvidia are built by the system. The rest came from rpmfusion.

Any idea, how I might be able to install those packages?

sudo dnf install nvidia*495* xorg-x11-drv-nvidia*495*

Tried to reboot after installing - no changes

The 'unable to connect to bus ’ messages seem to be a red herring and have no consequences that have been identified. Related to the removal scripts used when packages are upgraded or removed or reinstalled.

1 Like

OK - so thats not helping to solve the issue…

That message is definitely not related