NVIDIA Kernel Module Missing

I have installed the NVIDIA driver following this instruction:

However, when my computer starts, it will show the message:
nvidia kernel module missing falling back to nouveau.

I checked my graphic card:
$lspci | grep -i --color ‘vga|3d|2d’
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile) (rev 02)
01:00.0 3D controller: NVIDIA Corporation GP107GLM [Quadro P620] (rev a1)

Actually, I am unsure whether my computer uses NVIDIA or Intel graphic card. I guess that may be the reason. Any suggestions?

How about showing us exactly which nvidia packages are installed.
Please post the output of this command.

 dnf list installed '*nvidia*' 
$  dnf list installed '*nvidia*' 
Installed Packages
akmod-nvidia.x86_64                       3:455.45.01-3.fc33 @rpmfusion-nonfree-nvidia-driver
kmod-nvidia-5.9.10-200.fc33.x86_64.x86_64 3:455.45.01-1.fc33 @@commandline      
kmod-nvidia-5.9.11-200.fc33.x86_64.x86_64 3:455.45.01-3.fc33 @@commandline      
kmod-nvidia-5.9.13-200.fc33.x86_64.x86_64 3:455.45.01-3.fc33 @@commandline      
nvidia-persistenced.x86_64                3:455.45.01-1.fc33 @rpmfusion-nonfree-nvidia-driver
nvidia-settings.x86_64                    3:455.45.01-1.fc33 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia.x86_64                3:455.45.01-1.fc33 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda.x86_64           3:455.45.01-1.fc33 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.x86_64      3:455.45.01-1.fc33 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-kmodsrc.x86_64        3:455.45.01-1.fc33 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.x86_64           3:455.45.01-1.fc33 @rpmfusion-nonfree-nvidia-driver

Ok, so that machine is likely optimus config and you seem to have the needed packages…

We need to know if the nvidia driver is actually loading. We also need to know if the kernel is properly blocking the nouveau driver from loading.

Please post the output of these 2 commands

lsmod | egrep -i 'nouveau|nvidia|i915'
cat /etc/default/grub
$lsmod | egrep -i 'nouveau|nvidia|i915'
nouveau              2310144  1
ttm                   122880  1 nouveau
i915                 2646016  11
i2c_algo_bit           16384  2 i915,nouveau
mxm_wmi                16384  1 nouveau
drm_kms_helper        266240  2 i915,nouveau
cec                    61440  2 drm_kms_helper,i915
drm                   626688  11 drm_kms_helper,i915,ttm,nouveau
wmi                    36864  7 intel_wmi_thunderbolt,dell_wmi,wmi_bmof,dell_smbios,dell_wmi_descriptor,mxm_wmi,nouveau
video                  53248  4 dell_wmi,dell_laptop,i915,nouveau
$ cat /etc/default/grub
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1"
GRUB_DISABLE_RECOVERY="true"
GRUB_ENABLE_BLSCFG=true

do not forget to disable “Secure Boot” in your BIOS Settings as it prevents loading custom Modules

1 Like

I don’t know that the above line from your /etc/default/grub is causing a problem, but each entry there should only occur once. I would suggest changing that to

GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 rhgb quiet"

Once the change is made then rebuild the grub.cfg file with

sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

The lsmod command clearly shows the nouveau driver installed even though it is blacklisted in the kernel command line. The intel driver (i915) is for the intel graphics part of your laptop, and I wanted to verify it was loading properly.

That message seems strange with what you have installed.
I guess it is possible that not everything needed for proper building of the kmod is correctly installed or that something was corrupted, so I suggest the following.

sudo dnf erase akmod-nvidia kernel-devel kmod-nvidia --noautoremove
sudo dnf install kernel-devel akmod-nvidia*455* kernel-headers

I am assuming you are running the latest kernel (5.9.13 or later) as the nvidia module will be built for the kernel actually running when the above is done.

If a reboot after doing the above does not properly start the nvidia card then go back to the bios and verify that secure boot is disabled as stated by the rpmfusion howto since the nvidia driver taints the kernel and secure boot can prevent loading it.

If all the above fails there is also a dedicated optimus howto at rpmfusion that could be used as a last resort.

1 Like

I had the same issues as the poster and disabling secure boot allowed the nvida drivers to be loaded.