OBS buggy/crashing

I recently installed the latest version of OBS studio in the rpm-fusion-free repository, and OBS was really buggy and crashed. So weird artefacts happend when I wanted to record my screen. I’m running Fedora 33 Gnome and I’m running the default configuration, so probably with wayland. Is this a known issue? I heard that it might be related to Wayland…

1 Like

quite weird Obs-studio is very stable but:

  1. could you please execute obs-studio in the terminal? and see what happens.
  2. you can backup the obs-studio config folder and rename/delete it to another name, it located under hidden files you can find it in nautilus and start with a fresh config…
  3. you can also install from flathub and check the differences.

https://flathub.org/apps/details/com.obsproject.Studio

Regards.,

1 Like

I get this error message in the terminal:

QSocketNotifier: Can only be used with threads started with QThread
Attempted path: share/obs/obs-studio/locale/en-US.ini
Attempted path: /usr/share/obs/obs-studio/locale/en-US.ini
Attempted path: share/obs/obs-studio/locale.ini
Attempted path: /usr/share/obs/obs-studio/locale.ini
Attempted path: share/obs/obs-studio/locale/fr-FR.ini
Attempted path: /usr/share/obs/obs-studio/locale/fr-FR.ini
info: Using preferred locale 'fr-FR'
Attempted path: share/obs/obs-studio/themes/Dark.qss
Attempted path: /usr/share/obs/obs-studio/themes/Dark.qss
info: CPU Name: Intel(R) Core(TM) i5-8250U CPU @ 1.60GHz
info: CPU Speed: 2176.535MHz
info: Physical Cores: 4, Logical Cores: 8
info: Physical Memory: 7829MB Total, 1543MB Free
info: Kernel Version: Linux 5.10.19-200.fc33.x86_64
info: Distribution: Fedora 33
info: Session Type: wayland
info: Window System: X11.0 - vendor string: Fedora Project - vendor release: 12010000
info: Portable mode: false
Attempted path: share/obs/obs-studio/themes/Dark/no_sources.svg
Attempted path: /usr/share/obs/obs-studio/themes/Dark/no_sources.svg
QMetaObject::connectSlotsByName: No matching signal for on_advAudioProps_clicked()
QMetaObject::connectSlotsByName: No matching signal for on_advAudioProps_destroyed()
QMetaObject::connectSlotsByName: No matching signal for on_actionGridMode_triggered()
QMetaObject::connectSlotsByName: No matching signal for on_program_customContextMenuRequested(QPoint)
QMetaObject::connectSlotsByName: No matching signal for on_transitionRemove_clicked()
info: OBS 26.1.2 (linux)
info: ---------------------------------
info: ---------------------------------
info: audio settings reset:
	samples per sec: 48000
	speakers:        2
info: ---------------------------------
info: Initializing OpenGL...
info: Loading up OpenGL on adapter Intel Mesa Intel(R) UHD Graphics 620 (KBL GT2)
info: OpenGL loaded successfully, version 4.6 (Core Profile) Mesa 20.3.4, shading language 4.60
info: ---------------------------------
info: video settings reset:
	base resolution:   1920x1080
	output resolution: 1280x720
	downscale filter:  Bicubic
	fps:               60/1
	format:            NV12
	YUV mode:          709/Partial
info: NV12 texture support not available
info: Audio monitoring device:
	name: Par défaut
	id: default
info: ---------------------------------
warning: Failed to load 'en-US' text for module: 'decklink-captions.so'
warning: Failed to load 'en-US' text for module: 'decklink-ouput-ui.so'
libDeckLinkAPI.so: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type
warning: A DeckLink iterator could not be created.  The DeckLink drivers may not be installed
info: No blackmagic support
warning: v4l2loopback not installed, virtual camera disabled
error: os_dlopen(libnvidia-encode.so.1->libnvidia-encode.so.1): libnvidia-encode.so.1: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type

info: FFMPEG VAAPI supported
error: os_dlopen(libvlc.so.5->libvlc.so.5): libvlc.so.5: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type

info: Couldn't find VLC installation, VLC video source disabled
info: ---------------------------------
info:   Loaded Modules:
info:     vlc-video.so
info:     text-freetype2.so
info:     rtmp-services.so
info:     obs-x264.so
info:     obs-transitions.so
info:     obs-outputs.so
info:     obs-filters.so
info:     obs-ffmpeg.so
info:     linux-v4l2.so
info:     linux-pulseaudio.so
info:     linux-jack.so
info:     linux-decklink.so
info:     linux-capture.so
info:     linux-alsa.so
info:     image-source.so
info:     frontend-tools.so
info:     decklink-ouput-ui.so
info:     decklink-captions.so
info: ---------------------------------
info: ==== Startup complete ===============================================
info: All scene data cleared
info: ------------------------------------------------
info: pulse-input: Server name: 'pulseaudio 14.0-rebootstrapped'
info: pulse-input: Audio format: s16le, 44100 Hz, 2 channels
info: pulse-input: Started recording from 'bluez_sink.00_0C_8A_EF_01_09.a2dp_sink.monitor'
info: [Loaded global audio device]: 'Audio du Bureau'
info: pulse-input: Server name: 'pulseaudio 14.0-rebootstrapped'
info: pulse-input: Audio format: s16le, 44100 Hz, 2 channels
info: pulse-input: Started recording from 'alsa_input.pci-0000_00_1f.3.analog-stereo'
info: [Loaded global audio device]: 'Mic/Aux'
info: Switched to scene 'Scène'
info: ------------------------------------------------
info: Loaded scenes:
info: - scene 'Scène':
info: ------------------------------------------------
qt.qpa.wayland: Wayland does not support QWindow::requestActivate()
"/proc/31247/root"
"/proc/31247/root"
error: Failed to fetch parent window geometry!
error: gl_platform_init_swapchain  failed
error: obs_display_init: Failed to create swap chain
error: Failed to fetch parent window geometry!
error: gl_platform_init_swapchain  failed
error: obs_display_init: Failed to create swap chain
error: Failed to fetch parent window geometry!
error: gl_platform_init_swapchain  failed
error: obs_display_init: Failed to create swap chain
error: Failed to fetch parent window geometry!
error: gl_platform_init_swapchain  failed
error: obs_display_init: Failed to create swap chain
error: Failed to fetch parent window geometry!
error: gl_platform_init_swapchain  failed
error: obs_display_init: Failed to create swap chain
info: adding 42 milliseconds of audio buffering, total audio buffering is now 42 milliseconds (source: Audio du Bureau)

info: ==== Shutting down ==================================================
info: pulse-input: Stopped recording from 'bluez_sink.00_0C_8A_EF_01_09.a2dp_sink.monitor'
info: pulse-input: Got 111 packets with 156288 frames
info: pulse-input: Stopped recording from 'alsa_input.pci-0000_00_1f.3.analog-stereo'
info: pulse-input: Got 350 packets with 154288 frames
info: All scene data cleared
info: ------------------------------------------------
"/proc/31247/root"
info: [Scripting] Total detached callbacks: 0
info: Freeing OBS context data
info: == Profiler Results =============================
info: run_program_init: 637,455 ms
info:  ┣OBSApp::AppInit: 2,333 ms
info:  ┃ ┗OBSApp::InitLocale: 1,229 ms
info:  ┗OBSApp::OBSInit: 499,746 ms
info:    ┣obs_startup: 13,725 ms
info:    ┗OBSBasic::OBSInit: 328,724 ms
info:      ┣OBSBasic::InitBasicConfig: 0,078 ms
info:      ┣OBSBasic::ResetAudio: 0,163 ms
info:      ┣OBSBasic::ResetVideo: 73,243 ms
info:      ┣OBSBasic::InitOBSCallbacks: 0,004 ms
info:      ┣OBSBasic::InitHotkeys: 0,05 ms
info:      ┣obs_load_all_modules: 198,68 ms
info:      ┃ ┣obs_init_module(decklink-captions.so): 0,028 ms
info:      ┃ ┣obs_init_module(decklink-ouput-ui.so): 0,638 ms
info:      ┃ ┣obs_init_module(frontend-tools.so): 75,055 ms
info:      ┃ ┣obs_init_module(image-source.so): 0,005 ms
info:      ┃ ┣obs_init_module(linux-alsa.so): 0,001 ms
info:      ┃ ┣obs_init_module(linux-capture.so): 0,877 ms
info:      ┃ ┣obs_init_module(linux-decklink.so): 0,158 ms
info:      ┃ ┣obs_init_module(linux-jack.so): 0,001 ms
info:      ┃ ┣obs_init_module(linux-pulseaudio.so): 0,002 ms
info:      ┃ ┣obs_init_module(linux-v4l2.so): 2,869 ms
info:      ┃ ┣obs_init_module(obs-ffmpeg.so): 0,443 ms
info:      ┃ ┃ ┗nvenc_check: 0,425 ms
info:      ┃ ┣obs_init_module(obs-filters.so): 0,01 ms
info:      ┃ ┣obs_init_module(obs-outputs.so): 0,002 ms
info:      ┃ ┣obs_init_module(obs-transitions.so): 0,004 ms
info:      ┃ ┣obs_init_module(obs-x264.so): 0,001 ms
info:      ┃ ┣obs_init_module(rtmp-services.so): 0,374 ms
info:      ┃ ┣obs_init_module(text-freetype2.so): 0,007 ms
info:      ┃ ┗obs_init_module(vlc-video.so): 0,1 ms
info:      ┣OBSBasic::ResetOutputs: 0,093 ms
info:      ┣OBSBasic::CreateHotkeys: 0,03 ms
info:      ┣OBSBasic::InitService: 1,083 ms
info:      ┣OBSBasic::InitPrimitives: 0,173 ms
info:      ┗OBSBasic::Load: 11,928 ms
info: obs_hotkey_thread(25 ms): min=0,095 ms, median=0,804 ms, max=1,569 ms, 99th percentile=1,09 ms, 100% below 25 ms
info: audio_thread(Audio): min=0,001 ms, median=0,125 ms, max=0,279 ms, 99th percentile=0,208 ms
info: obs_graphics_thread(16,6667 ms): min=0,048 ms, median=0,163 ms, max=0,407 ms, 99th percentile=0,356 ms, 100% below 16,667 ms
info:  ┣tick_sources: min=0,001 ms, median=0,014 ms, max=0,039 ms, 99th percentile=0,03 ms
info:  ┣output_frame: min=0,022 ms, median=0,073 ms, max=0,389 ms, 99th percentile=0,148 ms
info:  ┃ ┗gs_context(video->graphics): min=0,022 ms, median=0,073 ms, max=0,389 ms, 99th percentile=0,147 ms
info:  ┃   ┣render_video: min=0,018 ms, median=0,057 ms, max=0,315 ms, 99th percentile=0,125 ms
info:  ┃   ┃ ┗render_main_texture: min=0,015 ms, median=0,048 ms, max=0,31 ms, 99th percentile=0,116 ms
info:  ┃   ┗gs_flush: min=0 ms, median=0,002 ms, max=0,067 ms, 99th percentile=0,022 ms
info:  ┗render_displays: min=0,002 ms, median=0,009 ms, max=0,044 ms, 99th percentile=0,038 ms
info: =================================================
info: == Profiler Time Between Calls ==================
info: obs_hotkey_thread(25 ms): min=25,16 ms, median=25,95 ms, max=26,716 ms, 16,9725% within ±2% of 25 ms (0% lower, 83,0275% higher)
info: obs_graphics_thread(16,6667 ms): min=16,332 ms, median=16,664 ms, max=17,044 ms, 99,3846% within ±2% of 16,667 ms (0,307692% lower, 0,307692% higher)
info: =================================================
info: Number of memory leaks: 0

Oh, I forgot to mention that I activated fractional scaling:

gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']"

This might be the issue…

I deleted the config file and restarted the setup process from scratch. For the automatic configuration process I selected the recording profile, and at the end of the configuration I get this error :
Recording Error : Software (x264)

Do I need to install some codecs in order for it to work properly ? For the moment I haven’t installed any codec (I just installed ffmpeg).
Does someone have an idea?

1 Like

I haven’t used OBS, but I suppose you can modify the recording profile (or use different one) to encode video with some other codec (dnf info ffmpeg will list what it supports). To install x264 and other patent encumbered encoders you can use Howto/Multimedia - RPM Fusion

This is the info you need

https://docs.fedoraproject.org/en-US/quick-docs/setup_rpmfusion/

https://docs.fedoraproject.org/en-US/quick-docs/assembly_installing-plugins-for-playing-movies-and-music/

Regards.

1 Like

But my question is, do I need these codecs for obs to work? Is the laggy obs with artefacts due to the lack of codecs?

You need at least x264 encoder (available in RPMFusion) to use current video profile.
Or you can configure OBS to use one of codecs supported by ffmpeg, this will list them:

dnf info ffmpeg

Other issues might be related to Wayland, but it should get better with next major release, read this topic: OBS and Wayland | OBS Forums

1 Like

Thanks a lot for your help !
Do these encoders are necessary for obs just to start correctly? Without any recording or livestreaming, obs lags on itself. When I move the obs window, there are graphic artifacts and glitches. It’s probably related to something other than codecs, right?

Yes.
Logout and choose xOrg instead of wayland on login screen, you’ll see if there’s any difference.

1 Like