Problem: package obs-studio-28.1.2-2.fc37.x86_64 requires obs-studio-libs(x86-64) = 28.1.2-2.fc37, but none of the providers can be installed
- cannot install the best candidate for the job
- nothing provides qt5-qtbase(x86-64) = 5.15.7 needed by obs-studio-libs-28.1.2-2.fc37.x86_64
Can anyone please help me with this problem ? my qt is 5.15.7, and obs need 5.15.6… I don’t want to downgrade the QT version in my system.
Should I wait for the Fedora repo to upgrade the OBS packages? Or what
obs-studio doesn’t seem to be distributed by the Fedora Project, see Search | koji or obs-studio - Fedora Packages
Is it possible you installed it from another, a 3rd party repo? Maybe from rpmfusion?
It seems obs-studio comes from rpmfusion for use on fedora. The latest version there is 28.1.2-2 and the version compatible with qt5 on fedora is 28.1.2-1. Installing that version on my system would give this
Install 5 Packages
Downgrade 113 Packages
Skip 2 Packages
Total download size: 420 M
Is this ok [y/N]:
and the downgrades would almost all be qt5 packages with installing the 28.1.2-1 version.
I think getting in a hurry to do the update would be a step backward since the qt5 packages on my system seem to not be compatible with either the 28.1.2-2 version or the 28.1.2-1 version and would all need to be downgraded to be compatible with the 28.1.2-1 version.