Only 4k option available for 5k monitor (LG Ultrafine 5K)

Hi,

I’m using fedora silverblue 32. As a former mac book user I own a 5k monitor. When I start Windows the 5k resolution (5120x2880@60) for the LG Ultrafine monitor, which is connected to the notebook using a thunderbolt 3 cable, is configured automatically and just works out of the box. I tested that both with my old MacBook Pro 2017 (running an AMD graphics card) and my new Lenovo ThinkPad P15 (running a nvidia RTX 4000 graphics card).

In fedora silverblue / wayland I’m unable to select such a high resolution. The highest selectable resolution in settings => Display is 4096x2304. I know that the LG Ultrafine was developed together with Apple. But because Windows is able to use the 5k resolution on my ThinkPad notebook without installing any apple drivers, there should be no apple particularities involved and it should be possible to get it working on Linux too.

There are some blog posts about that out there but I couldn’t get it running. For example the post Manually add a resolution to Gnome with Wayland @ superuser.com describes that they were able to the get it working using a kernel boot parameter.

So I did the following which just didn’t worked out:

  1. Have a look into the monitor.xml to get the connector ID of the external monitor:

    cat $HOME/.config/monitors.xml
     <monitors version=“2”>
          <configuration>
            <logicalmonitor>
              <x>2880</x>
              <y>0</y>
              <scale>1</scale>
              <monitor>
                <monitorspec>
                  <connector>DP-1</connector>
                  <vendor>GSM</vendor>
                  <product>LG UltraFine</product>
                  <serial>903NTPCBA640</serial>
                </monitorspec>
                <mode>
                  <width>4096</width>
                  <height>2304</height>
                  <rate>59.999771118164062</rate>
                </mode>
              </monitor>
            </logicalmonitor>
            <logicalmonitor>
              <x>0</x>
              <y>0</y>
              <scale>2</scale>
              <primary>yes</primary>
              <monitor>
                <monitorspec>
                  <connector>eDP-1</connector>
                  <vendor>APP</vendor>
                  <product>Color LCD</product>
                  <serial>0x00000000</serial>
                </monitorspec>
                <mode>
                  <width>2880</width>
                  <height>1800</height>
                  <rate>60.001377105712891</rate>
                </mode>
              </monitor>
            </logicalmonitor>
          </configuration>
        </monitors>

  2. So now I knew the connector (DP-1) I added this as boot parameter:
    rpm-ostree kargs --append=video=DP-1:5120x2880@60
    systemctl reboot

  3. After reboot, the resolution of the LG Ultrafine still seems to be 4k because with a scaling factor of 100% the size the size of everything seems to be the same. I would have expected everything to be smaller so that more pixels are available. In settings => Display the highest resolution is still 4096x2304.

  4. Now I tried to delete the monitor file and reboot:
    rm $HOME/.config/monitors.xml
    systemctl reboot

  5. If I open settings => Display now, the LG UltraFine 5K monitor is autodetected with a resolution of 3840x2160. The highest selectable resolution is still 4096x2304.

Any suggestions? Is using 5k with Wayland possible or are there any restrictions preventing that?

Regards
Meinert

This is a tiled monitor (two almost independent DP lanes packed in a TB3 cable) and you will see it as two 2560x2880 logical panels. Setting this resolution manually will result in a composite 5k desktop. The 4k resolution is set by default as a highest available.

Thanks a lot for the suggestion. I haven’t been able to get it working. Found a lot of advice how to configure it for a x session using xrandr but not how to configure it for wayland.

But anyway, I read that it should work with linux kernel 5.9 out of the box: https://gitlab.freedesktop.org/drm/intel/-/issues/27. I read that fedora will use the 5.9 kernel in near future / november (the test week already started), so I will wait just some time and use the 4k resolution till then.

Thanks a lot.

Regards
Meinert

Have a look at gnome-monitor-config. Depending on the desktop you use, there might be other ways to configure resolutions (gnome-control-center?).

That said the Wayland compositor you use should understand tiled displays and perhaps add custom workarounds for that. From kernel side everything should be ready by now as the tile properties are properly exposed already.

Hi,

I installed the 5.9 kernel like described in the fedora test day wiki post https://fedoraproject.org/wiki/Test_Day:2020-10-26_Kernel_5.9_Test_Week.

After that I was able to configure the 5k resolution in the gnome settings dialog like one would expect :-). So I will just wait till the new kernel version is supported officially by fedora.

Thanks for your help. It gave me some new pointers where to look :-).

Regards
Meinert

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.