openconnect and toolbox containers

I have a new and up to date installation of SilverBlue on my machine. I have a vpn connection established through the main system to my work (I am using openconnect for this). I have a toolbox container on which I have nodejs installed.

If I try to establish a connection with work sites via the VPN through firefox or a terminal on the machine, it all works fine. Trying to establish the same connection using curl or npm install within the toolbox container doesn’t work - curl tells me it cannot resolve the host. The toolbox container can however, resolve non work/vpn urls.

Is there some way to get the container to make network calls through the vpn running on the host OS?

The reason I need it available in the container is that there are packages for the nodejs project hosted on non public repositories.

Any help or advice would be greatly appreciated.

1 Like

Hello @orsettobruno, welcome to the community! Please do take a minute to glance over the information in #start-here.

Are you able to reach the hosts in the VPN using IP addresses?

1 Like

It looks like it’s going to be me understanding that the toolbox has some shared resources, and other aspects of it are not shared. In this instance, it does not share the same /etc directory. As a result, my main OS was using an /etc/resolv.conf that gets written to by openconnect with the correct entries. I copied that contents of that into the toolbox and was then able to resolve the addresses without any problems.

Now, whether there is a way to make this more seamless, I don’t know. It might just be a case of “that’s what you get with a toolbox”. What I did find difficult was getting more in depth documentation on how toolboxes work. There is a nice simple guide on creating them, entering them, deleting them on the Fedora site, but nothing more detailed than that.

1 Like

Using openconnect from the command line previously, but I have switched to using the VPN tools built into Gnome network-manager and the toolbox is now using the VPN without any extra tinkering. I also don’t have to restart the network to “fix” things when I disconnect from the VPN this way.

I imagine that using the command line openconnect tool was not setting up everything required for the toolbox to be able to utilize the VPN connectivity.