Opening link I sometimes have: Firefox is already running, but is not responding

Hi everybody,

I stumble upon a small issue regarding Firefox with Wayland on Fedora 31.
My problem is that often when clicking a link in an application like VSCode or Slack or Intellij,
It does not work as it tries to open a new Firefox instance, and I have this error:
“Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system.”

What is weird is that after a new start, It works for sometimes but then after a while not anymore.
If I close Firefox, it will also works for the first app, but not the second one…
(The first app used to click a link can open Firefoxx or a new tab, but not the second)

So I don’t know how I should troubleshoot/analyse this issue.
I tried setting MOZ_ENABLE_WAYLAND=1 but it did not help.

Any advice would be welcome,

Regards

Julien.

1 Like

Hi,

Is suspect the apps are try to launch firefox using x11, you could try confirming by setting:

MOZ_DISABLE_WAYLAND=1

Thanks Tom.

I removed the firefox-x11 launcher, to be sure to always have firefox under Wayland.
So I’m not sure about setting MOZ_DISABLE_WAYLAND=1

I did some simple test.
In a new gnome session, with all application closed,
I open VScode and click on a link -> it opens Firefox properly
Then I open slack and click on a link -> it fails to open firefox

I close everything again and do the opposite:
I open slack and click on a link -> it opens Firefox properly
I open vscode and click on a link -> It fails to open firefox

!??

The firefox-x11 package is just a wrapper which launches firefox with the MOZ_DISABLE_WAYLAND=1 environment variable set.

I suspect both these apps may be using xwayland, rather than native; which is probably causing conflict. Are this apps flatpak or snap, or installed via dnf/yum?

I had a similar issue with keepass2, which doesn’t support wayland and has no intentions of doing so and I suspect its not an easy fix to get these apps to work seamlessly with wayland; so for time being I’m running firefox x11.

Thanks Tom.

1 Like

You probably still have “Firefox” (not Wayland) set as the default Web application.

To fix, go to the Settings (click the WiFi/Sound/Power button and click the gear) -> Details -> Default Applications, and change the Web setting from Firefox to Firefox on Wayland (note these names are from Fedora 30, where Firefox x11 was default, so the names may be a bit different on Fedora 31).

Hi,

Firefox on Wayland was made the default, for fedora 31. In Default Applications without any other browsers installed, Firefox is the only option (which is wayland); unless firefox-x11 is installed.

Thanks Tom.

You can use temporally chromium-freeworld…

I removed the snap managed slack version and installed the rpm directly from slack’s download page, it resolved the problem. Thanks for this tip!

Hi,

Good to hear that has resolved the problem. Just bear in mind you will need manually update slack, as updates will no longer be managed by snap. It may be worth raising a bug report with snap.

Also it may be worth trying slack from flathub:

https://flathub.org/apps/details/com.slack.Slack

Thanks Tom.

I also replaced the snap slack version with the flathub one, and now the link open properly on Firefox !

Thanks for your help

Firefox 74 should help with this issue, see