OpenRGB is not working (i2c-piix4 is not detected/loaded)

Hello guys, I’m quite new to the linux world and at specialy to Fedora (I have it for just about 1 week), so sorry if my question is going to sound noobish.


SYSTEM:

Laptop model: Asus TUF A15
CPU: AMD
GPU: 2060
OS: Fedora 35
Gnome: 41.5
Windowing System: Wayland


I am trying to install the OpenRGB by fallowing the steps from here (Gitlab - CalcProgrammer1/OpenRGB).

sudo dnf install automake gcc-c++ qt5-qtbase-devel hidapi-devel libusbx-devel mbedtls-devel
git clone https://gitlab.com/CalcProgrammer1/OpenRGB
cd OpenRGB
qmake-qt5 OpenRGB.pro
make -j$(nproc)

If I am running it via ./openrgb I am getting the fallowing error:


Attempting to connect to local OpenRGB server.
Connection attempt failed
Local OpenRGB server unavailable.
Running standalone.
QSocketNotifier: Can only be used with threads started with QThread
<h2>WARNING:</h2><p>One or more I2C/SMBus interfaces failed to initialize.</p><p>RGB DRAM modules and some motherboards' onboard RGB lighting will not be available without I2C/SMBus.</p><p>On Linux, this is usually because the i2c-dev module is not loaded.  You must load the i2c-dev module along with the correct i2c driver for your motherboard.  This is usually i2c-piix4 for AMD systems and i2c-i801 for Intel systems.</p><p>See <a href='https://help.openrgb.org/'>help.openrgb.org</a> for additional troubleshooting steps if you keep seeing this message.<br></p>
QObject::connect: No such signal QPlatformNativeInterface::systemTrayWindowChanged(QScreen*)

Also via sudo ./openrgb I am getting almost the same error:

Attempting to connect to local OpenRGB server.
Connection attempt failed
Local OpenRGB server unavailable.
Running standalone.
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
<h2>WARNING:</h2><p>One or more I2C/SMBus interfaces failed to initialize.</p><p>RGB DRAM modules and some motherboards' onboard RGB lighting will not be available without I2C/SMBus.</p><p>On Linux, this is usually because the i2c-dev module is not loaded.  You must load the i2c-dev module along with the correct i2c driver for your motherboard.  This is usually i2c-piix4 for AMD systems and i2c-i801 for Intel systems.</p><p>See <a href='https://help.openrgb.org/'>help.openrgb.org</a> for additional troubleshooting steps if you keep seeing this message.<br></p>

In both cases I have an issue with i2c-piix4 as far as I understand because I have an AMD processor. Because of that I’ve try to use the fallowing commands in order to load the kernel

sudo modprobe i2c-dev
modprobe i2c-piix4 (I've tried also with sudo)

I’ve also fallowed the steps from here (OpenRGB Kernel Patch · Wiki · Adam Honse / OpenRGB · GitLab) regarding the Kernel Patch until step 5 because I don’t know where /boot/config-file is in fedora.

///////////////Kernel Patch steps that I did//////////////////////:
git clone https://github.com/torvalds/linux
cd linux
git checkout master
patch -p1 < /home/user/OpenRGB/OpenRGB.patch
////////////////////////////////////////////////////////////////////////////

grubby --update-kernel=ALL --args="acpi_enforce_resources=lax"
sudo chmod 777 /dev/i2c-0


Things that I’ve tried while doing my reseach:

  1. sudo usermod -a -G video username and reboot the system, still dose not work.
  2. As this a user suggested from here (openRGB - missing i2c-piix4), I’ve also tried:
    - sudo dnf install libi2c-devel
    - qmake-qt5 OpenRGB.pro
    - make clean (to be sure everyhing is clean)
    - make -j$(nproc) (to rebuild it)
  3. I’ve also find this repository (Github - ProjectSynchro/i2c-piix4-aura-dkms) which it should contain the i2c-piix4 package that is missing for me but I have no idea how to install it properlly. Everyhing that I’ve tried it was a failed.

Non of the thing about didn’t work for me, could any of you guys please help me to make my OpenRGB work? Or at least point me in the right direction?

Hi, maybe you want to try from https://copr.fedorainfracloud.org and search OpenRGB. From this repos you could search some app packages that not present on main Fedora repo. Copr are maintained by individual user (not official maintainer) who want to make certain apps to other users. Just make sure to read carfully the instructions there.

https://copr.fedorainfracloud.org/coprs/fulltext/?fulltext=openrgb

I did try this… at specilly the
sudo usermod -a -G video username and reboot the system, still dose not work.

To be more precise I’ve try all of those 2 options:

For each of them I did:
sudo dnf copr enable birkch/OpenRGB
sudo dnf install openrgb → it didn’t work, I get this error message


Error:
Copr repo for OpenRGB owned by birkch 2.3 kB/s | 3.3 kB 00:01
No match for argument: openrgb
Error: Unable to find a match: openrgb


and the other one was:

sudo dnf copr enable name/OpenRGB
sudo dnf install openrgb

Where it did work but I get the same exact issue:

Attempting to connect to local OpenRGB server.
Connection attempt failed
Local OpenRGB server unavailable.
Running standalone.
QSocketNotifier: Can only be used with threads started with QThread
QObject::connect: No such signal QPlatformNativeInterface::systemTrayWindowChanged(QScreen*)
<h2>WARNING:</h2><p>One or more I2C/SMBus interfaces failed to initialize.</p><p>RGB DRAM modules and some motherboards' onboard RGB lighting will not be available without I2C/SMBus.</p><p>On Linux, this is usually because the i2c-dev module is not loaded.  You must load the i2c-dev module along with the correct i2c driver for your motherboard.  This is usually i2c-piix4 for AMD systems and i2c-i801 for Intel systems.</p><p>See <a href='https://help.openrgb.org/'>help.openrgb.org</a> for additional troubleshooting steps if you keep seeing this message.<br></p>

Could you tell me how can I fix this if you know?

Hey, thx for reply.

I did try this already, or to be more precise I did try the fallowing to links already:

  • name/OpenRGB Copr where this one worked in terms of instalation but I get the same error when trying to run:
Attempting to connect to local OpenRGB server.
Connection attempt failed
Local OpenRGB server unavailable.
Running standalone.
QSocketNotifier: Can only be used with threads started with QThread
QObject::connect: No such signal QPlatformNativeInterface::systemTrayWindowChanged(QScreen*)
<h2>WARNING:</h2><p>One or more I2C/SMBus interfaces failed to initialize.</p><p>RGB DRAM modules and some motherboards' onboard RGB lighting will not be available without I2C/SMBus.</p><p>On Linux, this is usually because the i2c-dev module is not loaded.  You must load the i2c-dev module along with the correct i2c driver for your motherboard.  This is usually i2c-piix4 for AMD systems and i2c-i801 for Intel systems.</p><p>See <a href='https://help.openrgb.org/'>help.openrgb.org</a> for additional troubleshooting steps if you keep seeing this message.<br></p>

So my problem is still the same regarding the i2c SMBus, do you know how can I fix it?

Try to install ‘libi2c-devel’ package and see how is going

I did try this already, is in the section Things that I’ve tried while doing my reseach:, step 2.

And it didn’t work.

Hi, for the moment I don’t have any idea but from your post may be there are some steps you want to try again.

For above step, may be you need to disable “Secure Boot” from your BIOS setting. Usually with dkms it will generate new module during the booting. You may also need kernel-devel and kernel-header to install.

For boot config that needed to create initial .config, I believe in Fedora Linux it available in /boot/ directory with name start with config-* followed by kernel version. Usually we want to use the latest kernel version config-LATEST-KERNEL-VERSION-INSTALLED. You could check your current kernel version with uname -r.

For this step, you also need to disable secure boot in BIOS setting since look like you want to install custom kernel build.

Got it working by…

sudo usermod -a -G video USER
sudo dnf copr enable name/OpenRGB
sudo dnf install openrgb libi2c
sudo modprobe i2c_dev
sudo openrgb

Now My Motherboard, GPU and RAM show up. For my NZXT Kraken I had to install some udev rules.

I’ve tried also your solution but sadly for me is not working and I am getting the same error as before.