[Optimus] KDE on Nvidia descrete card black screen

Just began running them commands again while trimming the unnecessary ones to further simplify my guide.

1 Like

Okay, to be fair i thought the same thing. 2 days ago i downloaded the .ISO for this purpose, but between gnome and kde i prefer kde, so i wasn’t sure about that change.

Oh thank you, i think that i will reinstall the system tomorrow, because until tomorrow morning i need the pc. Thank you so much for the help! :slight_smile:

Try Dash-to-Panel extension on GNOME and you would begin getting those KDE vibes. Although it would be unfair to compare them both as they both are great at what they do but the least I can do is to make you feel like home with Workstation until I find a way to fix NVIDIA on Plasma based Fedora 32.

Thank you for the advice! One last thing, for nvidia i need to be on X11 right? Wayland is not supported yet?

The package would automatically get your X11 renderer. You need not worry about it. :smile:

Oh ok thank you again. For now i prefer to leave this thread open without a solution, just in case.

Sure thing. But just because you are moving to Workstation. (Are you?) You might want to rename it.

To be honest i will try Workstation, but i don’t know if i want to rename the thread, i feel like that is more suitable to close the thread with a message like “I’ve switched to Gnome”. This is because the messages in the thread refers to my attempt to use nvidia on kde, even if was not a success. Sounds right for you?

Nice insight there. It sounds right to me. It would be only justified if we leave a KDE thread as-is to let know the posterity with the struggles that took place.

Yes we can leave this open, so if someone in the future found a solution it can be posted here.

Perhaps for anycase try as root: systemctl set-default graphical.target
And then reboot.

Thank you for the suggestion, but after that it doesn’t work as well… I think that is a xorg problem. I will try to learn how to create a custom xorg.conf and see if i can fix this. If i fail even with that i will switch to Workstation as suggested by @t0xic0der.

1 Like

Hi @simonbonfo, I recently replied to your comment on a similar reddit post explaining the solution I found, but just in case you didn’t see it (and for others encountering this issue in the future) I though I should post it here as well.

I recently had the exact same issues as @simobonfo and solved it. I found the solution here on the nvidia forums - essentially, the Arch wiki misguided you. In the RPMfusion guide (that the fedoraproject guide is based on), it tells you to configure your display manager according to the arch wiki. Unfortunately, the wiki is wrong (at least for fedora32). You need to edit the /etc/sddm/Xsetup file, not /usr/share/sddm/scripts/Xsetup.

After that, SDDM/everything else worked just fine for me. As a side note, I did have to add xrandr --dpi 96 to /etc/sddm/Xsetup as well since everything became smaller. You may not have to.

3 Likes

@caleb.gartner Hi, thank you so much for the reply, i see it on reddit, but i was in a hurry and i didn’t reply. Now I’m running gnome but it can be a solution for others. I left this post open for this exact reason.
Thank you and have a good day :slight_smile:

1 Like

We need someone to try this out and confirm. Then we can mark this as the solution of this thread.

@t0xic0der For now i’m unable to reinstall fedora on my pc :/. I will try as soon as possible.

Hi @t0xic0der, I had the same issue on Fedora 33 KDE on an optimus-based laptop.
The solution from @caleb.gartner worked for me. So I believe the article on the arch wiki is indeed incorrect.

2 Likes

Cool. I believe we can mark his answer as the solution for this thread.