Packages for OpenMPI development?

I have installed openmpi and openmpi-devel packages, run the module load mpi/openmpi-x86_64 command, but building a CMake project with

find_package(MPI REQUIRED)

still fails to find MPI. mpi.h header is also not present in the system.

Any help would be appreciated.

It is:

(ins)[asinha@ankur  ~]$ rpmls openmpi-devel | grep mpi.h
-rw-r--r--  /usr/include/openmpi-x86_64/mpi.h
-rw-r--r--  /usr/include/openmpi-x86_64/openmpi/mpiext/mpiext_pcollreq_mpifh.h
lrwxrwxrwx  /usr/lib64/openmpi/lib/libmpi_mpifh.so

It depends on what the find_package function is doing there—you can generally provide it with hints on where to look.

There’s some more information here on how these MPI compilers are packaged for Fedora:

https://docs.fedoraproject.org/en-US/packaging-guidelines/MPI/#_packaging_of_mpi_compilers

Thank you. Adding openmpi-x86_64/ to the include directive seems to work.

1 Like