Paraview on Fedora 36 does not start

Apologies if this is not the right place for the following query (I’m a novice user of ParaView).
I did a fresh install of Fedora 36 (from scratch) and then I installed ParaView in two ways:

a) Via dnf --best install, but then it fails to launch due to a graphic issue:
paraview[1]3087 paraview: symbol lookup error: /usr/bin/…/lib64/paraview/libvtkFiltersParallelDIY2.so.1: undefined symbol: _ZN20vtkDIYGhostUtilities29InflateBoundingBoxIfNecessaryEP11vtkPolyDataPKdR14vtkBoundingBox

b) Then I tried with ParaView-5.10.1-MPI-Linux-Python3.9-x86_64.tar.gz from Download | ParaView, but the error now is:
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
qt.qpa.plugin: Could not load the Qt platform plugin “xcb” in “” even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
Available platform plugins are: xcb.

The whole Fedora system, in particular the Qt plataform, was installed using the dnf --best command. Please, any suggestions to correct it? Thanks in advance.

Regards.
Jorge.

PD: some data:

$ cat /proc/version
Linux version 5.18.16-200.fc36.x86_64 (mockbuild@bkernel01.iad2.fedoraproject.org) (gcc (GCC) 12.1.1 20220507 (Red Hat 12.1.1-1), GNU ld version 2.37-27.fc36) #1 SMP PREEMPT_DYNAMIC Wed Aug 3 15:44:49 UTC 2022

$ which paraview
/usr/bin/paraview

$ paraview &
[1] 3015
$ paraview: symbol lookup error: /usr/bin/…/lib64/paraview/libvtkFiltersParallelDIY2.so.1: undefined symbol: _ZN20vtkDIYGhostUtilities29InflateBoundingBoxIfNecessaryEP11vtkPolyDataPKdR14vtkBoundingBox
[1]+ Exit 127 paraview

$ /home/test/TMP/ParaView-5.10.1-MPI-Linux-Python3.9-x86_64/bin/paraview &
[1] 4303
$ Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
qt.qpa.plugin: Could not load the Qt platform plugin “xcb” in “” even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
Available platform plugins are: xcb.
error: exception occurred: Subprocess aborted
[1]+ Exit 1 paraview

$ QT_QPA_PLATFORM=wayland

$ /home/test/TMP/ParaView-5.10.1-MPI-Linux-Python3.9-x86_64/bin/paraview &
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
qt.qpa.plugin: Could not load the Qt platform plugin “xcb” in “” even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
Available platform plugins are: xcb.
error: exception occurred: Subprocess aborted
[1]+ Exit 127 paraview

$ cat /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 23
model : 113
model name : AMD Ryzen 7 3700X 8-Core Processor
stepping : 0
microcode : 0x8701013
cpu MHz : 2200.000
cache size : 512 KB
physical id : 0
siblings : 8
core id : 0
cpu cores : 8
apicid : 0
initial apicid : 0
fpu : yes
fpu_exception : yes
cpuid level : 16
wp : yes
$ glxinfo
name of display: :0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
Extended renderer info (GLX_MESA_query_renderer):
Vendor: nouveau (0x10de)
Device: NVA8 (0x10c3)
Version: 22.1.4
Accelerated: yes
Video memory: 1000MB
Unified memory: no
Preferred profile: core (0x1)
Max core profile version: 3.3
Max compat profile version: 3.3
Max GLES1 profile version: 1.1
Max GLES[23] profile version: 3.1
OpenGL vendor string: nouveau
OpenGL renderer string: NVA8
OpenGL core profile version string: 3.3 (Core Profile) Mesa 22.1.4
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
— cropped text —
#end

SOLVED. The bug was that, after installing Fedora 36, an outdated user PATH had been reused, instead of appending the user definitions to the new Fedora 36 default PATH. Advice: pay attention to the user environment in the updates, upgrades, or migrations.

To enable an updated path it is easiest to log out then back in. If using a terminal window then close the terminal window and reopen it for the same effect.

Dear Jeff: ok, thanks for the suggestion. Anyway, the problem in this case was that the user account’s bashrc started an empty PATH, throwing away all the initial system definitions and replacing them with an outdated version of them. Regards.