Pasted text is auto-selected and enter is stripped

When I select something in the terminal (tilix) and then paste it using the middle-button, the text that is pasted is selected and enter is stripped (a new line shows in the screen but it doesn’t actually press enter to execute it, for instance).

Previously, the text wouldn’t stay selected and any enters would actually run the command. Now that doesn’t work. I have to de-select the text and press enter myself.

Does anyone know how to turn this off? Fedora 35 here.

image

2 Likes

Assuming you are using Bash (which is the default for Fedora), put this line to your ~/.bashrc:

bind 'set enable-bracketed-paste off'

Or this if you have a ~/.inputrc file:

set enable-bracketed-paste off

Search for enable-bracketed-paste in the Bash manual page to read about this feature. It is set to on by default for security reasons.

3 Likes