Performance Issue

Hello I’m new to this forum. I don’t know where to post this.!
My friend uses kali linux with gnome DE and has i3 processor and 3 gb ram and normal hdd, but his boot performance is far better than me although i have i7 processor with 16gb ram and same type hdd. Also previously when i used to use Kali as main os It booted faster than fedora. I’ve attached a screenshot .Wanted to know whether is it normal boot time or not? And i’ve planned to use ssd because of this issue. If it is normal boot time then i’ll buy ssd otherwise I will tweak it, if i get help from you.

Screenshot%20from%202019-07-10%2021-49-50|690x387

IIRC “userspace” has a tendency to include stuff that isn’t necessarily related to your boot process. If it’s actually appearing to be slower (not just what systemd-analyze says), look into the systemd-analyze commands critical-chain, plot, and blame.

3 Likes

Hello @abhin and welcome to the community! Please do have a look at the posts in the #start-here category if you haven’t had a chance yet.

From my point of view, even if I don’t know why, Fedora boot time is a bit slower than i.e. Ubuntu.
BTW you could look at what is the component that take more time during boot using the command systemd-analyze blame.
And post the result here.

Thanks for your reply @alciregi
yes, I’ve noticed the boot speed of other distro is faster than fedora on the same machine . Even the fedora with other DesktopEnvironment is faster than Gnome DE. In the modern age we have this linux with huge boot time. Even windows on same machine booted 2 times faster. Is there any solution to tackle this boot time? But want to use the gnomeDE.

Thanks for your reply @refi64 ,
Is there any way to considerably decrease the boot time of fedora without any bug. If yes please let me know. I’ve attached the screenshot of systemd-analyse blame and critical-chain

libvirtd seems to be a major offender in this case, maybe try disabling that if you’re not using it actively?

Also, dbus-broker seems to take an usually long amount of time to start (3.5s for you vs 33ms on my system), though you can’t exactly disable that if you want the system to boot…