Persian Language Problem

Hello everyone
When I use Persian Language on Fedora Workstation 33 Everything is OK
But sometimes it converts to English automatic
Then I should change it to English and then change it again to Persian Language

Everybody knows its problem?

1 Like

Hi!
Are you talking about the keyboard layout or the display language in Gnome applications?

As for the keyboard layout, I experience the same, Gnome automatically switches to another keyboard layout that I have installed, completely unncessarily getting in my way. I still haven’t had the time to investigate. I think it would be good to know what triggers or determines switching keyboard layout.
Maybe someone knows a dconf key to disable automatic keyboard layout switching. Thanks!

1 Like

I use GNOME desktop in fedora
but sometimes my language changes automatic
but it displays same previous language
and I should change the language manually and then change it again to same language…!

I really don’t know its problem :frowning_face:

Sounds like the problem I am experiencing as well. Shortcut to change keyboard layout is Super+Space

There is an option under Keyboard in settings:

Switch input sources individually for each window.
@augenauf could it be that this is active that you have this kind of problems?

Also check if the main language you use is on first position. So it is marked as default layout.

I use already Fedora34 might be that it is new ?!

1 Like

Did Fedora 34 release?
I use Fedora 33…

In my menu there is not “Keyboard” menu under “Mouse & Touchpad” menu!

see:

Not yet. Beta on Tuesday, and final release end of April.

whats the answer of my question please?

Fedora 34 will solve that problem. For now @augenauf gave you a workaround with :

to change the locale.

Or use a other desktop environment till then. Where not changes the locale per Window as Gnome does.

You can look at Input Source switching with:
gsettings get org.gnome.desktop.input-sources per-window

1 Like

NO!
I say sometimes it displays “fa” (Persian) as language layout but writes English!

I should Change it with Super Space to English and then change it to Persian Again!

Please do what grumpey say and check if the result is true or false and give feedback.