Php-fpm configuration for Nextcloud Server doesn't work

Hi,

I’m trying to setup a home Nextcloud instance on Fedora Server using nextcloud packages from repo.

I mostly followed the Fedora Wiki step by step to sort things into place and Nextcloud is now running in LAN.
However, upon examining “Overview” section in “Settings”, I was quickly highlighted the warnings about two errors:

  • The PHP memory limit is below the recommended value of 512MB.
  • PHP configuration option output_buffering must be disabled

And the info from “System” section suggested similar:

It is very strange as /etc/php-fpm.d/nextcloud.conf coming from nextcloud-httpd package should already setup things correctly:

php_value[memory_limit] = 512M
php_value[upload_max_filesize] = 10G
php_value[post_max_size] = 10G
php_value[output_buffering] = false

In comparison, the popular NextCloudPi seems to setup those values in a customized .ini file. Before going that route, I would be much appreciate if someone could point me out on how to get the packaged configuration into effectiveness.

Packages that were used are:

  • nextcloud-24.0.5-1.fc36.noarch
  • nextcloud-httpd-24.0.5-1.fc36.noarch

Thanks a lot!

EDIT: Add package version.

I’m running Nextcloud on Fedora with php-fpm.

Here are my current php-fpm settings:

php_value[session.save_handler] = files
php_value[session.save_path]    = /var/lib/php/session
php_value[soap.wsdl_cache_dir]  = /var/lib/php/wsdlcache
php_value[opcache.interned_strings_buffer] = 128

The other values are set in /etc/php.ini:

output_buffering = 4096
memory_limit = 4096M
post_max_size = 25G
upload_max_filesize = 25G

The settings in Nextcloud accurately reflect those settings for me:

May I know where you put those settings?
In the global config like /etc/php-fpm.conf or /etc/php-fpm.d/nextcloud.conf that comes from nextcloud-httpd package?

Nextcloud seems to demand this be off according the documentation. May I know if you had below “Warning” in “Overview” module of “Setting”?

Screenshot 2022-10-26 at 09-39-54 Settings - Nextcloud

Actually, this may looks a lot like this bug.

Oh, good find! My nextcloud setup is interesting as it’s been going since 2014 (back when it was owncloud). It started as a regular Apache install. I moved to Fedora packaging and there was an unfortunate period of time where the nextcloud packages went stale due to a lapse in maintainers, so I no longer use the Fedora packages and just use the Nextcloud updater. The php-fpm values are in www.conf but that should correlate to your nextcloud.conf. The php.ini values I shared are in /etc/php.ini.

It sounds like the fix for that has already been pushed and you’re on the latest version. Have you tried restarting php-fpm (systemctl restart php-fpm) ?