Pipewire doesn't actually recognize any Sound outputs (devices)

I believe it should be run from /usr/share/pipewire/pipewire.conf

Under context.exec=
there should be a line
{ path = "/usr/bin/pipewire-media-session" args = "" }

In F35, it changes to a service.

1 Like

You probably mean /usr/share/pipewire/pipewire.conf not /usr/share/pipewire.conf right?

It is in there. Interesting, I wonder why it is not running it.

To be fair they do say you “can” run it here but it is better to be run as a service in the comments. Maybe one of the reasons it is better to run it as as service is what I am seeing now, ha ha.

I assume since it isn’t doing anything I should comment it out.

229 context.exec = [
230     #{ path = <program-name> [ args = "<arguments>" ] }
231     #
232     # Execute the given program with arguments.
233     #
234     # You can optionally start the session manager here,
235     # but it is better to start it as a systemd service.
236     # Run the session manager with -h for options.
237     #
238     { path = "/usr/bin/pipewire-media-session" args = "" }
239     #
240     # You can optionally start the pulseaudio-server here as well
241     # but it is better to start it as a systemd service.
242     # It can be interesting to start another daemon here that listens
243     # on another address with the -a option (eg. -a tcp:4713).
244     #
245     #{ path = "/usr/bin/pipewire" args = "-c pipewire-pulse.conf" }
246   ]

Yup… /usr/share/pipewire … (need more coffee)

It also looks in

1 Like

Ah, there is a .config based pipewire.conf file there that came over from my arch install. Arch has pipewire-media-session as a separate service but Fedora runs it using this pipewire config file. Which means in arch ~/.config/pipewire/pipewire.conf has he line line for the media session commented out.

The order the configs are read is…

I am just going to leave it as service for now, sounds like i will want it this way if I upgrade to F35.

1 Like

Detailed Description

PipeWire rt-loop object.

This loop starts a new real-time thread that is designed to run the processing graph.

I guess you really needed that in order to make it work. Glad you figured it out. I got lucky as my configurations were already prepared, thanks to a particular repo that I had to add to my system to run a few things.
Now, I wish I received as much extensive information as you did on your thread here.
My requests for info have been lost in the unknown… :slight_smile: